tcpflow prints "write error to stdout" after every packet

Bug #1340990 reported by Joost Cassee on 2014-07-11
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
tcpflow (Debian)
Fix Released
Unknown
tcpflow (Ubuntu)
Undecided
Unassigned

Bug Description

[From https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=736417]

tcpflow prints "write error to stdout" after every packet. This is printed when the expected length and the actually written length are different, in tcpip.c line 272.

The bug has been fixed in Debian version 1.4.4+repack1-3

Changed in tcpflow (Debian):
status: Unknown → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in tcpflow (Ubuntu):
status: New → Confirmed
Marcus Pereira (marcds) wrote :

Please add this fix to trusty too, it is only on utopic or vivid.

Or at least to trusty-proposed or trusty-backports.

Bartosz Cisek (bartoszcisek) wrote :

I have the same problem. Luckily managed to compile 1.4.4+repack1-3 from vivid on trusty and it works fine.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.