Installation of daily build 10/14 fails

Bug #66214 reported by b sanders on 2006-10-15
18
Affects Status Importance Assigned to Milestone
tasksel (Ubuntu)
Critical
Colin Watson

Bug Description

Trying the daily build, either using the cd alone or with network repositories enabled, fails with the same error condition:

Oct 15 07:24:42 in-target: yelp zenity zip
Oct 15 07:24:42 in-target: E:
Oct 15 07:24:42 in-target: Couldn't find task edubuntu-standard
Oct 15 07:24:42 in-target:
Oct 15 07:24:42 in-target: E:
Oct 15 07:24:42 in-target: Couldn't find task kubuntu-standard
Oct 15 07:24:42 in-target:
Oct 15 07:24:42 in-target: E:
Oct 15 07:24:42 in-target: Couldn't find task xubuntu-standard
Oct 15 07:24:42 in-target:
Oct 15 07:24:42 in-target: 0 upgraded, 654 newly installed, 0 to remove and 0 not upgraded.
Oct 15 07:24:42 in-target: tasksel: aptitude failed (100)
Oct 15 07:24:43 main-menu[3323]: WARNING **: Configuring 'pkgsel' failed with error code 1
Oct 15 07:24:43 main-menu[3323]: WARNING **: Menu item 'pkgsel' failed.

This error occurs even when trying to build a server. Moving on in the process and installing grub works fine.

Tollef Fog Heen (tfheen) wrote :

This needs checking, but if correct is certainly RC.

Colin Watson (cjwatson) wrote :

Confirmed (not in practice, but by code inspection). Braindump from IRC:

<Kamion> I see what might be causing that. Hmm. Hmm.
<Kamion> aptitude doesn't fail if the task is missing. apt-get does ...
<Kamion> the fix might be to drop the stupid derivative-specific *-standard tasks and replace them with a single standard task
<Kamion> since they're all the same anyway

Changed in tasksel:
assignee: nobody → kamion
importance: Undecided → Critical
status: Unconfirmed → Confirmed
Colin Watson (cjwatson) wrote :

revno: 839
committer: Colin Watson <email address hidden>
branch nick: edgy
timestamp: Sun 2006-10-15 21:30:05 +0100
message:
  standard task should no longer be per-derivative (#66214)

Changed in tasksel:
status: Confirmed → In Progress
Colin Watson (cjwatson) wrote :

tasksel (2.50ubuntu7) edgy; urgency=low

  * Update Ubuntu tasks from seeds, collapsing *-standard into a single
    standard task (closes: Malone #66214).

 -- Colin Watson <email address hidden> Sun, 15 Oct 2006 22:50:31 +0100

Changed in tasksel:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers