Activity log for bug #574287

Date Who What changed Old value New value Message
2010-05-03 08:31:47 Martin Erik Werner bug added bug
2010-05-03 08:31:47 Martin Erik Werner attachment added dpkg.log http://launchpadlibrarian.net/47497143/dpkg.log
2010-05-03 08:31:47 Martin Erik Werner attachment added Dependencies.txt http://launchpadlibrarian.net/47488602/Dependencies.txt
2010-05-03 10:00:08 Martin Erik Werner tasksel (Ubuntu): status New Confirmed
2010-05-03 10:17:04 Martin Erik Werner description Binary package hint: tasksel TEST CASE 1. ran sudo tasksel and selected "virtual machine host" >> installed 8 packages 2. ran sudo tasksel and deselected "virtual machine host" >> uninstalled 654 packages including my whole desktop system 3. Insert appropriate swearwords here I'm attaching the relevant part of dpkg.log ProblemType: Bug Architecture: i386 Date: Mon May 3 09:15:17 2010 DistroRelease: Ubuntu 9.10 NonfreeKernelModules: nvidia Package: tasksel 2.73ubuntu23 PackageArchitecture: all ProcEnviron: LANGUAGE=en_GB.UTF-8 LANG=en_GB.UTF-8 SHELL=/bin/bash ProcVersionSignature: Ubuntu 2.6.31-21.59-generic-pae SourcePackage: tasksel Uname: Linux 2.6.31-21-generic-pae i686 XsessionErrors: (gnome-settings-daemon:2371): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed (gnome-settings-daemon:2371): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed (polkit-gnome-authentication-agent-1:2492): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed (nautilus:2468): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed (gnome-panel:2467): Gdk-WARNING **: /build/buildd/gtk+2.0-2.18.3/gdk/x11/gdkdrawable-x11.c:952 drawable is not a pixmap or window Binary package hint: tasksel METHOD 1. ran sudo tasksel and selected "virtual machine host" >> installed 8 packages 2. ran sudo tasksel and deselected "virtual machine host" >> uninstalled 654 packages including my whole desktop system 3. Insert appropriate swearwords here I'm attaching the relevant part of dpkg.log ProblemType: Bug Architecture: i386 Date: Mon May 3 09:15:17 2010 DistroRelease: Ubuntu 9.10 NonfreeKernelModules: nvidia Package: tasksel 2.73ubuntu23 PackageArchitecture: all ProcEnviron:  LANGUAGE=en_GB.UTF-8  LANG=en_GB.UTF-8  SHELL=/bin/bash ProcVersionSignature: Ubuntu 2.6.31-21.59-generic-pae SourcePackage: tasksel Uname: Linux 2.6.31-21-generic-pae i686 XsessionErrors:  (gnome-settings-daemon:2371): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed  (gnome-settings-daemon:2371): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed  (polkit-gnome-authentication-agent-1:2492): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed  (nautilus:2468): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed  (gnome-panel:2467): Gdk-WARNING **: /build/buildd/gtk+2.0-2.18.3/gdk/x11/gdkdrawable-x11.c:952 drawable is not a pixmap or window
2010-05-03 10:22:58 Martin Erik Werner description Binary package hint: tasksel METHOD 1. ran sudo tasksel and selected "virtual machine host" >> installed 8 packages 2. ran sudo tasksel and deselected "virtual machine host" >> uninstalled 654 packages including my whole desktop system 3. Insert appropriate swearwords here I'm attaching the relevant part of dpkg.log ProblemType: Bug Architecture: i386 Date: Mon May 3 09:15:17 2010 DistroRelease: Ubuntu 9.10 NonfreeKernelModules: nvidia Package: tasksel 2.73ubuntu23 PackageArchitecture: all ProcEnviron:  LANGUAGE=en_GB.UTF-8  LANG=en_GB.UTF-8  SHELL=/bin/bash ProcVersionSignature: Ubuntu 2.6.31-21.59-generic-pae SourcePackage: tasksel Uname: Linux 2.6.31-21-generic-pae i686 XsessionErrors:  (gnome-settings-daemon:2371): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed  (gnome-settings-daemon:2371): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed  (polkit-gnome-authentication-agent-1:2492): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed  (nautilus:2468): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed  (gnome-panel:2467): Gdk-WARNING **: /build/buildd/gtk+2.0-2.18.3/gdk/x11/gdkdrawable-x11.c:952 drawable is not a pixmap or window Binary package hint: tasksel METHOD 1. Remove the ubuntu-desktop metapackage 2. ran sudo tasksel and selected "virtual machine host" >> installed 8 packages 4. ran sudo tasksel and deselected "virtual machine host" >> uninstalled 654 packages including my whole desktop system 5. Insert appropriate swearwords here I'm attaching the relevant part of dpkg.log ProblemType: Bug Architecture: i386 Date: Mon May 3 09:15:17 2010 DistroRelease: Ubuntu 9.10 NonfreeKernelModules: nvidia Package: tasksel 2.73ubuntu23 PackageArchitecture: all ProcEnviron:  LANGUAGE=en_GB.UTF-8  LANG=en_GB.UTF-8  SHELL=/bin/bash ProcVersionSignature: Ubuntu 2.6.31-21.59-generic-pae SourcePackage: tasksel Uname: Linux 2.6.31-21-generic-pae i686 XsessionErrors:  (gnome-settings-daemon:2371): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed  (gnome-settings-daemon:2371): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed  (polkit-gnome-authentication-agent-1:2492): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed  (nautilus:2468): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed  (gnome-panel:2467): Gdk-WARNING **: /build/buildd/gtk+2.0-2.18.3/gdk/x11/gdkdrawable-x11.c:952 drawable is not a pixmap or window
2010-05-03 10:56:50 Martin Erik Werner description Binary package hint: tasksel METHOD 1. Remove the ubuntu-desktop metapackage 2. ran sudo tasksel and selected "virtual machine host" >> installed 8 packages 4. ran sudo tasksel and deselected "virtual machine host" >> uninstalled 654 packages including my whole desktop system 5. Insert appropriate swearwords here I'm attaching the relevant part of dpkg.log ProblemType: Bug Architecture: i386 Date: Mon May 3 09:15:17 2010 DistroRelease: Ubuntu 9.10 NonfreeKernelModules: nvidia Package: tasksel 2.73ubuntu23 PackageArchitecture: all ProcEnviron:  LANGUAGE=en_GB.UTF-8  LANG=en_GB.UTF-8  SHELL=/bin/bash ProcVersionSignature: Ubuntu 2.6.31-21.59-generic-pae SourcePackage: tasksel Uname: Linux 2.6.31-21-generic-pae i686 XsessionErrors:  (gnome-settings-daemon:2371): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed  (gnome-settings-daemon:2371): GLib-CRITICAL **: g_propagate_error: assertion `src != NULL' failed  (polkit-gnome-authentication-agent-1:2492): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed  (nautilus:2468): Eel-CRITICAL **: eel_preferences_get_boolean: assertion `preferences_is_initialized ()' failed  (gnome-panel:2467): Gdk-WARNING **: /build/buildd/gtk+2.0-2.18.3/gdk/x11/gdkdrawable-x11.c:952 drawable is not a pixmap or window TEST CASE 1. Boot Lucid LiveCD 2. run "sudo tasksel" and select "virtual machine host" 3. run "sudo tasksel" and deselect "virtual machine host" 4. watch how tasksel uninstalls your system
2010-05-03 11:12:20 Martin Erik Werner description TEST CASE 1. Boot Lucid LiveCD 2. run "sudo tasksel" and select "virtual machine host" 3. run "sudo tasksel" and deselect "virtual machine host" 4. watch how tasksel uninstalls your system TEST CASE 1. Boot a LiveCD (1.5 on Karmic, remove ubuntu-desktop metapackage, step not required on Lucid) 2. run "sudo tasksel" and select "virtual machine host" 3. run "sudo tasksel" and deselect "virtual machine host" 4. watch how tasksel uninstalls your system Confirmed to apply to Lucid and Karmic, other versions not tested.
2010-05-03 12:06:59 Martin Erik Werner description TEST CASE 1. Boot a LiveCD (1.5 on Karmic, remove ubuntu-desktop metapackage, step not required on Lucid) 2. run "sudo tasksel" and select "virtual machine host" 3. run "sudo tasksel" and deselect "virtual machine host" 4. watch how tasksel uninstalls your system Confirmed to apply to Lucid and Karmic, other versions not tested. TEST CASE 1. Boot Lucid LiveCD 2. run "sudo tasksel" and select "virtual machine host" 3. run "sudo tasksel" and deselect "virtual machine host" 4. watch how tasksel uninstalls your system OBSERVATIONS What seems to happen is that apt vengefully removes ALL of the items associated with one task, including several base dependencies of other tasks (e.g. ubuntu-desktop) One illustrative example is the openssh-server task: This one includes the packages openssh-server, tcpd and libwrap0. From a normal ubuntu-desktop (e.g. ~liveCD) both tcpd and libwrap0 are already installed, and the task-install pulls in only openssh-server. However when the task is removed, all these three packages (openssh-server, tcpd and libwrap0) are forcefully removed. Since libwrap0 is a core dependency of gnome, a large part of gnome will be removed alongside the removal of the task.
2010-06-02 22:32:11 Martin Erik Werner bug task added apt (Ubuntu)
2010-06-05 19:23:59 Zachary Richey removed subscriber Zachary Richey
2010-06-24 00:14:09 Martin Erik Werner apt (Ubuntu): status New Invalid
2010-06-24 00:15:03 Martin Erik Werner bug task added tasksel (Debian)
2010-06-24 19:04:51 Martin Erik Werner bug watch added http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=587046
2010-06-24 19:04:51 Martin Erik Werner tasksel (Debian): importance Undecided Unknown
2010-06-24 19:04:51 Martin Erik Werner tasksel (Debian): status New Unknown
2010-06-24 19:04:51 Martin Erik Werner tasksel (Debian): remote watch Debian Bug tracker #587046
2010-06-27 01:05:00 Bug Watch Updater tasksel (Debian): status Unknown New
2011-02-09 16:09:17 Guntbert Reiter bug added subscriber guntbert
2011-02-14 23:03:54 Martin Erik Werner summary tasksel uninstalled my system! tasksel: forcefully removes packages when tasks overlap
2011-06-13 02:38:05 young-sin tasksel (Ubuntu): assignee young-sin (d-yd-tls)
2011-06-13 06:47:57 Tsega bug added subscriber Tsega
2011-06-21 20:16:56 JasonPorter bug added subscriber JasonPorter
2011-07-27 16:00:25 Brian Murray tasksel (Ubuntu): assignee young-sin (d-yd-tls)
2011-09-19 21:17:56 Ubuntu Foundations Team Bug Bot tags apport-bug i386 apport-bug i386 testcase
2011-09-20 15:11:20 Tsega removed subscriber Tsega
2011-10-24 19:00:49 benjamin tasksel (Ubuntu): assignee benjamin (varghese-benjamin09)
2011-10-24 21:29:09 C de-Avillez tasksel (Ubuntu): assignee benjamin (varghese-benjamin09)
2011-10-28 06:53:11 jeevithan tasksel (Ubuntu): assignee jeevithan (jeevithan1990)
2011-10-28 06:55:50 jeevithan tasksel (Ubuntu): status Confirmed In Progress
2012-08-01 20:53:34 Martin Erik Werner tasksel (Ubuntu): assignee jeevithan (jeevithan1990)
2012-08-01 20:55:02 Martin Erik Werner tasksel (Ubuntu): status In Progress Confirmed
2012-08-13 20:04:22 Bug Watch Updater tasksel (Debian): status New Fix Released
2013-02-16 15:46:15 Eliah Kagan bug added subscriber Eliah Kagan
2013-03-11 21:12:18 ola aljundi apt (Ubuntu): status Invalid Confirmed
2013-03-11 21:12:35 ola aljundi apt (Ubuntu): assignee ola aljundi (ola-jundi)
2013-03-11 21:12:41 ola aljundi tasksel (Ubuntu): assignee ola aljundi (ola-jundi)
2013-05-10 20:51:49 Martin Erik Werner apt (Ubuntu): assignee ola aljundi (ola-jundi)
2013-05-10 20:51:51 Martin Erik Werner tasksel (Ubuntu): assignee ola aljundi (ola-jundi)
2013-05-10 20:51:57 Martin Erik Werner apt (Ubuntu): status Confirmed Invalid
2013-11-11 02:54:14 Colan Schwartz bug added subscriber Colan Schwartz
2014-05-13 12:06:10 Erick Brunzell bug added subscriber Erick Brunzell