networkless expert install offers tasks which aren't on the CD

Bug #218604 reported by Martin Pitt on 2008-04-17
2
Affects Status Importance Assigned to Milestone
Ubuntu CD Images
Critical
Colin Watson
tasksel (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: debian-installer

Hardy RC amd64 alternate expert install: At the 'select software' step, I selected ubuntu-desktop and SSH server. This failed, since the openssh-server package is not on the CD. Ideally the menu would only offer tasks which install packages that are available with the current set of apt sources.

Colin Watson (cjwatson) wrote :

Hmm, that's how it's supposed to behave. I'll look into this, thanks.

Colin Watson (cjwatson) wrote :

tasksel is fine; the problem is that the cdimage scripts aren't adding the Task field to openssh-server. Moving to ubuntu-cdimage.

Changed in tasksel:
status: New → Invalid
Changed in ubuntu-cdimage:
assignee: nobody → kamion
importance: Undecided → Critical
status: New → Triaged
Colin Watson (cjwatson) wrote :

Furthermore: the problem here is that ssh is actually included directly in the ship seed rather than by including the task. Now, one option would be to include the task instead, but there are other cases here that are more complex than openssh-server where that doesn't work so well. I think the best option is for cdimage to opportunistically add Task overrides for anything it finds that match any task, regardless of whether it added the whole task to the seed; then tasksel will just be able to work off Task-Key to decide whether to display the task.

Colin Watson (cjwatson) wrote :

revno: 686
committer: Colin Watson <email address hidden>
branch nick: cdimage
timestamp: Tue 2008-04-22 00:16:02 +0100
message:
  generate Task fields for all tasks, regardless of whether the whole task supposed to be on the CD or not (LP: #218604); in the process, implement Task-Seeds and remove some old hacks around its lack

Changed in ubuntu-cdimage:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers