tasksel in d-i does not install all of lubuntu-desktop

Bug #1530397 reported by Lyn Perrine on 2015-12-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
tasksel (Ubuntu)
Critical
Colin Watson

Bug Description

To reproduce install a xenial lubuntu image with tasksel. Then try to install and it will not issue an error but will boot without a splash screen or a graphical lightdm greeter and levae you with a blank tty. Which is not intended lubuntu behaivor. This did not install all of the dependencies of lubuntu. However ubuntu-bug from the alternate installer itself does not work.

This is with lubuntu xenial 1231 alternate amd 64 and had had problems with other people on lubuntu QA team but no bug report yet. This is with tasksel 3.34ubunbut2 on xenial on ubuntu 16.04

The installer will not warn the user anything is wrong then boot to a black screen. but the user can only run in a tty. I also saved the debug logs from debain installer right before I rebooted and have attahced them in a tar file.

Lyn Perrine (walterorlin) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1530397

tags: added: iso-testing
Colin Watson (cjwatson) on 2016-01-02
Changed in tasksel (Ubuntu):
status: New → In Progress
importance: Undecided → Critical
assignee: nobody → Colin Watson (cjwatson)
summary: - taskel on debian installer does not install all of lubuntu desktop.
+ tasksel in d-i does not install all of lubuntu-desktop
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tasksel - 3.34ubuntu3

---------------
tasksel (3.34ubuntu3) xenial; urgency=medium

  * Revert Ubuntu-specific change which no longer makes sense now that
    Choices-C for the relevant questions holds task names rather than short
    descriptions (LP: #1530397):
    - Canonicalise tasksel/first or tasksel/tasks preseeding before
      displaying the main tasks question, in order that unseen preseeding of
      task names rather than descriptions works correctly.
  * Rework code to include preseeded tasks in the choices list on new
    installs regardless of filtering, since it was previously entangled with
    the canonicalisation code.

 -- Colin Watson <email address hidden> Sat, 02 Jan 2016 02:19:39 +0000

Changed in tasksel (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers