Ubuntu

Activity log for bug #992852

Date Who What changed Old value New value Message
2012-05-01 20:56:29 Bryce Harrington bug added bug
2012-05-01 20:57:14 Bryce Harrington task (Ubuntu): importance Undecided High
2012-05-01 20:57:14 Bryce Harrington task (Ubuntu): status New Triaged
2012-05-01 20:57:14 Bryce Harrington task (Ubuntu): assignee Bryce Harrington (bryce)
2012-05-17 03:25:16 Launchpad Janitor task (Ubuntu): status Triaged Fix Released
2012-05-17 03:29:15 Bryce Harrington description Executed this: task 8e27016d-5695-4d4c-8bc0-99895f73a8e3 done Task 1 'blah blah blah' is neither pending nor waiting. - End will be set to '4/27/2012'. - Status will be changed from 'pending' to 'completed'. Complete task 2 'foo foo foo'? (yes/no/all/quit) ^C See http://taskwarrior.org/issues/995 [Impact] When referencing tasks by their uuid (instead of id), certain uuids get interpreted as durations rather than uuids, which can result in mass-deletion of tasks. [Development Fix] Cherrypick of upstream patch, uploaded to quantal. [Stable Fix] Since we ship the same task version in quantal and precise, use the same patch. [Test Case] 1. Create tasks until one gets generated which has a 'd' before the first dash 2. Attempt to delete this task using its uuid (Similarly for modify, done, etc.) Broken Behavior: Prompts to delete ALL tasks Fixed Behavior: Just deletes the specified task [Regression Potential] None. Patch is upstream, and confirmed to fix the issue without causing other problems. The scope of risk is narrow as well; most task users reference tasks by ids, not uuids; uuids are more used with scripts and such. [Original Report] Executed this: task 8e27016d-5695-4d4c-8bc0-99895f73a8e3 done Task 1 'blah blah blah' is neither pending nor waiting. - End will be set to '4/27/2012'. - Status will be changed from 'pending' to 'completed'. Complete task 2 'foo foo foo'? (yes/no/all/quit) ^C See http://taskwarrior.org/issues/995
2012-05-17 03:40:30 Bryce Harrington bug added subscriber Ubuntu Stable Release Updates Team
2012-05-17 03:45:20 Bryce Harrington nominated for series Ubuntu Precise
2012-05-17 03:45:20 Bryce Harrington bug task added task (Ubuntu Precise)
2012-05-17 03:45:31 Bryce Harrington task (Ubuntu Precise): status New Fix Committed
2012-05-17 03:45:34 Bryce Harrington task (Ubuntu Precise): importance Undecided High
2012-05-17 04:19:38 Launchpad Janitor branch linked lp:ubuntu/task
2012-05-18 08:12:08 Martin Pitt bug added subscriber SRU Verification
2012-05-18 08:12:15 Martin Pitt tags verification-needed
2012-05-18 08:49:48 Launchpad Janitor branch linked lp:ubuntu/precise-proposed/task
2012-05-22 18:18:17 Bryce Harrington tags verification-needed verification-done
2012-05-29 18:55:15 Launchpad Janitor task (Ubuntu Precise): status Fix Committed Fix Released