task is missing the gnutls integration that enables syncing with a taskd server

Bug #1344560 reported by Craig Magina on 2014-07-19
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
task (Debian)
Fix Released
Unknown
task (Ubuntu)
High
Unassigned

Bug Description

A new feature in 2.3.0 includes the ability to sync with the taskwarrior server, taskd, however it requires that the package be built with gnutls. The error I get when running task sync, is:

Taskwarrior was built without GnuTLS support. Sync is not available.

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: task 2.3.0+dfsg-3
ProcVersionSignature: Ubuntu 3.16.0-4.9-generic 3.16.0-rc5
Uname: Linux 3.16.0-4-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.14.4-0ubuntu2
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Jul 18 21:30:02 2014
EcryptfsInUse: Yes
InstallationDate: Installed on 2014-07-19 (0 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
SourcePackage: task
UpgradeStatus: No upgrade log present (probably fresh install)

Craig Magina (craig.magina) wrote :
Changed in task (Debian):
status: Unknown → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in task (Ubuntu):
status: New → Confirmed
Changed in task (Ubuntu):
importance: Undecided → High
Changed in task (Debian):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package task - 2.4.3+dfsg-2

---------------
task (2.4.3+dfsg-2) unstable; urgency=medium

  * Upload to unstable.

 -- Sebastien Badia <email address hidden> Wed, 29 Apr 2015 01:38:54 +0200

Changed in task (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.