Update TaskWarrior package to the version 2.3.0

Bug #1286939 reported by Sergey Korolev on 2014-03-02
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
task (Ubuntu)
Undecided
Unassigned

Bug Description

Version 2.3.0 released at 2014-01-15 http://taskwarrior.org/download/
Already in Debian Testing: https://packages.debian.org/jessie/task
This version has one very important feature: ability to sync with taskd (TaskWarrior sync server).

Jakub Wilk (jwilk) wrote :

FWIW, the sync feature is not enabled in the Debian package:

$ task sync
Taskwarrior was built without GnuTLS support. Sync is not available.

Sergey Korolev (knopki) wrote :

That's bad. Don't know why it's not enabled.
I don't now how to correctly enable GnuTLS (I have no experience in package building) so I simply remove this line from debian/rules:
 -DCMAKE_DISABLE_FIND_PACKAGE_GnuTLS=TRUE \

Can't test now is it really working with taskd, but:
$ task sync
Taskserver is not configured.

If necessary I can test, I have a taskd server setup, and I can put it on whatever ubuntu release you want. Currently I have one running 14.04, let me know.

For now I have a README which tells people to install from source. This is how I install from source including all the various packages:

sudo apt-get install build-essentail cmake libgnutls-dev uuid-dev
cd /tmp
wget http://taskwarrior.org/download/task-2.3.0.tar.gz
tar xzf task-2.3.0.tar.gz
cd task-2.3.0
cmake .
make && sudo make install

Sergey Korolev (knopki) wrote :

I installed taskwarrior from debian source package as described in #2. I use it with taskd about 3 weeks and sync work without problems.

mthmulders (maarten-mulders) wrote :

I also built taskwarrior as described in #2 and tested with https://inthe.am/. Seems to work fine. Needed to have libgnutls-dev installed before building. Can this be the default for upcoming releases?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in task (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package task - 2.4.3+dfsg-2

---------------
task (2.4.3+dfsg-2) unstable; urgency=medium

  * Upload to unstable.

 -- Sebastien Badia <email address hidden> Wed, 29 Apr 2015 01:38:54 +0200

Changed in task (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers