tar Fails to Grok tar File it's Written.

Bug #20171 reported by Ralph Corderoy
4
Affects Status Importance Assigned to Milestone
tar (Ubuntu)
Medium
Scott James Remnant (Canonical)

Bug Description

On Ubuntu 5.04:

    $ tar --version
    tar (GNU tar) 1.14
    Copyright (C) 2004 Free Software Foundation, Inc.
    This program comes with NO WARRANTY, to the extent permitted by law.
    You may redistribute it under the terms of the GNU General Public License;
    see the file named COPYING for details.
    Written by John Gilmore and Jay Fenlason.

    $ apt-show-versions -p tar
    tar/unknown uptodate 1.14-2

This version of tar has problems reading tar files it, that is 1.14-2,
has recently created. First problem:

    $ tar xRvf big.tar nonexistentfile
    block 1: level 0 backup of blake on 20050807-225123
    Reading `level 0 backup of blake on 20050807-225123'
    block 521103: tar: Skipping to next header
    block 1075261: ** Block of NULs **
    tar: nonexistentfile: Not found in archive
    tar: Error exit delayed from previous errors
    $ echo $?
    2

The `Skipping to next header' shouldn't occur. It's because 1.14 has
problems with sparse files apparently.

Second problem:

    $ tar xf small.tar home/ralph/pysloc
    tar: home/ralph/.mozilla/firefox/mc0oqdco.default/cert8.db: \
        invalid sparse archive member
    tar: Skipping to next header
    tar: Error exit delayed from previous errors

More sparse file problems.

Note, `tar tvf' doesn't cause either of these errors, giving a false
sense of security regarding the integrety of the tar file.

I've raised the issue on the bug-tar mailing list:
http://lists.gnu.org/archive/html/bug-tar/2005-08/msg00015.html

Given the use of tar in backups, and that `tar tvf' doesn't show the
problem, only extracting files from the backup does, I was wondering if
this should be a higher priority than normal bug.

tar-1.15.1 doesn't give the errors above. I'm trying it on a wider
range of 1.14 tar files to see if it has other problems.

http://lists.gnu.org/archive/html/bug-tar/2005-08/msg00015.html: http://lists.gnu.org/archive/html/bug-tar/2005-08/msg00015.html

Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

I think I remember these problems at the time in Debian, the upstream release
notes for 1.15 include some stuff about sparse files being fixed.

Breezy already contains 1.15.1

Revision history for this message
Ralph Corderoy (ralph-inputplus) wrote :

Unfortunately, 1.15.1 has problems restoring a backup that 1.14 doesn't
have. Perhaps the fix will be out in time for Breezy to pick up.

    http://lists.gnu.org/archive/html/bug-tar/2005-08/msg00023.html

Revision history for this message
Scott James Remnant (Canonical) (canonical-scott) wrote :

Hmm, upstream bug tags got lost in the merge I guess...

Changed in tar:
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.