Please update to 1.11.1

Bug #1546373 reported by James Henstridge
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
TagLib
Fix Released
Unknown
taglib (Debian)
Fix Released
Unknown
taglib (Ubuntu)
Medium
Simon Quigley

Bug Description

https://github.com/taglib/taglib/blob/master/NEWS

TagLib 1.11.1 (Oct 24, 2016)
============================

 * Fixed binary incompatible change in TagLib::String.
 * Fixed reading ID3v2 CTOC frames with a lot of entries.
 * Fixed seeking ByteVectorStream from the end.

TagLib 1.11 (Apr 29, 2016)
==========================

1.11:

 * Fixed reading APE items with long keys.
 * Fixed reading ID3v2 SYLT frames when description is empty.

1.11 BETA 2:

 * Better handling of PCM WAV files with a 'fact' chunk.
 * Better handling of corrupted APE tags.
 * Efficient decoding of unsynchronized ID3v2 frames.
 * Fixed text encoding when saving certain frames in ID3v2.3 tags.
 * Fixed updating the size of RIFF files when removing chunks.
 * Several smaller bug fixes and performance improvements.

1.11 BETA:

 * New API for creating FileRef from IOStream.
 * Added support for ID3v2 PCST and WFED frames.
 * Added support for pictures in XiphComment.
 * Added String::clear().
 * Added FLAC::File::strip() for removing non-standard tags.
 * Added alternative functions to XiphComment::removeField().
 * Added BUILD_BINDINGS build option.
 * Added ENABLE_CCACHE build option.
 * Replaced ENABLE_STATIC build option with BUILD_SHARED_LIBS.
 * Better handling of duplicate ID3v2 tags in all kinds of files.
 * Better handling of duplicate tag chunks in WAV files.
 * Better handling of duplicate tag chunks in AIFF files.
 * Better handling of duplicate Vorbis comment blocks in FLAC files.
 * Better handling of broken MPEG audio frames.
 * Fixed crash when calling File::properties() after strip().
 * Fixed crash when parsing certain MPEG files.
 * Fixed crash when saving Ogg files.
 * Fixed possible file corruptions when saving ASF files.
 * Fixed possible file corruptions when saving FLAC files.
 * Fixed possible file corruptions when saving MP4 files.
 * Fixed possible file corruptions when saving MPEG files.
 * Fixed possible file corruptions when saving APE files.
 * Fixed possible file corruptions when saving Musepack files.
 * Fixed possible file corruptions when saving WavPack files.
 * Fixed updating the comment field of Vorbis comments.
 * Fixed reading date and time in ID3v2.3 tags.
 * Marked ByteVector::null and ByteVector::isNull() deprecated.
 * Marked String::null and String::isNull() deprecated.
 * Marked XiphComment::removeField() deprecated.
 * Marked Ogg::Page::getCopyWithNewPageSequenceNumber() deprecated. It returns null.
 * Marked custom integer types deprecated.
 * Many smaller bug fixes and performance improvements.

TagLib 1.10 (Nov 11, 2015)
==========================

1.10:

 * Added new options to the tagwriter example.
 * Fixed self-assignment operator in some types.
 * Fixed extraction of MP4 tag keys with an empty list.

1.10 BETA:

 * New API for the audio length in milliseconds.
 * Added support for ID3v2 ETCO and SYLT frames.
 * Added support for album artist in PropertyMap API of MP4 files.
 * Added support for embedded frames in ID3v2 CHAP and CTOC frames.
 * Added support for AIFF-C files.
 * Better handling of duplicate ID3v2 tags in MPEG files.
 * Allowed generating taglib.pc on Windows.
 * Added ZLIB_SOURCE build option.
 * Fixed backwards-incompatible change in TagLib::String when constructing UTF16 strings.
 * Fixed crash when parsing certain FLAC files.
 * Fixed crash when encoding empty strings.
 * Fixed saving of certain XM files on OS X.
 * Changed Xiph and APE generic getters to return space-concatenated values.
 * Fixed possible file corruptions when removing tags from WAV files.
 * Added support for MP4 files with 64-bit atoms in certain 64-bit environments.
 * Prevented ID3v2 padding from being too large.
 * Fixed crash when parsing corrupted APE files.
 * Fixed crash when parsing corrupted WAV files.
 * Fixed crash when parsing corrupted Ogg FLAC files.
 * Fixed crash when parsing corrupted MPEG files.
 * Fixed saving empty tags in WAV files.
 * Fixed crash when parsing corrupted Musepack files.
 * Fixed possible memory leaks when parsing AIFF and WAV files.
 * Fixed crash when parsing corrupted MP4 files.
 * Stopped writing empty ID3v2 frames.
 * Fixed possible file corruptions when saving WMA files.
 * Added TagLib::MP4::Tag::isEmpty().
 * Added accessors to manipulate MP4 tags.
 * Fixed crash when parsing corrupted WavPack files.
 * Fixed seeking MPEG frames.
 * Fixed reading FLAC files with zero-sized padding blocks.
 * Added support for reading the encoder information of WMA files.
 * Added support for reading the codec of WAV files.
 * Added support for multi channel WavPack files.
 * Added support for reading the nominal bitrate of Ogg Speex files.
 * Added support for VBR headers in MPEG files.
 * Marked FLAC::File::streamInfoData() deprecated. It returns an empty ByteVector.
 * Marked FLAC::File::streamLength() deprecated. It returns zero.
 * Fixed possible file corruptions when adding an ID3v1 tag to FLAC files.
 * Many smaller bug fixes and performance improvements.

Debian PTS: https://packages.qa.debian.org/t/taglib.html

Changed in taglib (Debian):
status: Unknown → New
tags: added: upgrade-software-version xenial
Changed in taglib (Ubuntu):
status: New → Confirmed
Changed in taglib (Ubuntu):
importance: Undecided → Critical
Revision history for this message
Amr Ibrahim (amribrahim1987) wrote : Re: Please update to bugfix release 1.10

1.10 fixes a lot of crashes.

summary: - Please package taglib 1.10
+ Please update to bugfix release 1.10
Revision history for this message
Amr Ibrahim (amribrahim1987) wrote :

Also fixes LP: #1353988

description: updated
summary: - Please update to bugfix release 1.10
+ [FFe] Please update to bugfix release 1.10
Revision history for this message
Martin Pitt (pitti) wrote : Re: [FFe] Please update to bugfix release 1.10

Sounds OK to me, FFE approved (assuming that this does not bump SONAME).

Changed in taglib (Ubuntu):
status: Confirmed → Triaged
Revision history for this message
Amr Ibrahim (amribrahim1987) wrote :

Thanks Martin.

Upstream is paving the road to release 1.11. They released 1.11 BETA 2 on 4 March 2016. It's left to Ubuntu developers to decide which version to package.

https://github.com/taglib/taglib/blob/master/NEWS
TagLib 1.11 (Mar 4, 2016)
=====================

 * Fixed reading APE items with long keys.
 * Fixed reading ID3v2 SYLT frames when description is empty.

1.11 BETA 2:

 * Better handling of PCM WAV files with a 'fact' chunk.
 * Better handling of corrupted APE tags.
 * Efficient decoding of unsynchronized ID3v2 frames.
 * Fixed text encoding when saving certain frames in ID3v2.3 tags.
 * Fixed updating the size of RIFF files when removing chunks.
 * Several smaller bug fixes and performance improvements.

1.11 BETA:

 * New API for creating FileRef from IOStream.
 * Added support for ID3v2 PCST and WFED frames.
 * Added support for pictures in XiphComment.
 * Added String::clear().
 * Added FLAC::File::strip() for removing non-standard tags.
 * Added alternative functions to XiphComment::removeField().
 * Added BUILD_BINDINGS build option.
 * Added ENABLE_CCACHE build option.
 * Replaced ENABLE_STATIC build option with BUILD_SHARED_LIBS.
 * Better handling of duplicate ID3v2 tags in all kinds of files.
 * Better handling of duplicate tag chunks in WAV files.
 * Better handling of duplicate tag chunks in AIFF files.
 * Better handling of duplicate Vorbis comment blocks in FLAC files.
 * Better handling of broken MPEG audio frames.
 * Fixed crash when calling File::properties() after strip().
 * Fixed crash when parsing certain MPEG files.
 * Fixed crash when saving Ogg files.
 * Fixed possible file corruptions when saving ASF files.
 * Fixed possible file corruptions when saving FLAC files.
 * Fixed possible file corruptions when saving MP4 files.
 * Fixed possible file corruptions when saving MPEG files.
 * Fixed possible file corruptions when saving APE files.
 * Fixed possible file corruptions when saving Musepack files.
 * Fixed possible file corruptions when saving WavPack files.
 * Fixed updating the comment field of Vorbis comments.
 * Fixed reading date and time in ID3v2.3 tags.
 * Marked ByteVector::null and ByteVector::isNull() deprecated.
 * Marked String::null and String::isNull() deprecated.
 * Marked XiphComment::removeField() deprecated.
 * Marked Ogg::Page::getCopyWithNewPageSequenceNumber() deprecated. It returns null.
 * Marked custom integer types deprecated.
 * Many smaller bug fixes and performance improvements.

Revision history for this message
Amr Ibrahim (amribrahim1987) wrote :

Pinging the release team.

Revision history for this message
Martin Pitt (pitti) wrote :

For the record, it's not the release team's job to package new upstream software. If some developer still wants to do that, we can consider it, but two days before final freeze it gets really tight now.

Revision history for this message
Amr Ibrahim (amribrahim1987) wrote :

Sorry for the trouble, Martin. I think the release team has been subscribed here again to weight their opinion on updating to 1.11 or 1.10, not to package it themselves. Please someone correct me if I am wrong.

Revision history for this message
Martin Pitt (pitti) wrote :

The changes in 1.11 look fine too, but let's not package a beta release so close to xenial's release. If there's an 1.11 final in time and someone wants to package and test this right away rather than doing 1.10 first, that's fine.

Revision history for this message
Scarlett Gately Moore (sgclark) wrote :

If the Kubuntu team is indeed responsible for packaging this, we should have been notified prior to this turning into a Ffe, don't you think? I myself am too busy, perhaps someone else will. This is unlikely so close to release.
Scarlett

Revision history for this message
Aaron Honeycutt (aaronhoneycutt) wrote : Re: [Bug 1546373] Re: [FFe] Please update to bugfix release 1.10

I agree with Scarlett 100% since the release was in Nov (before the freeze
I believe) we should have been told. It's much to late to include it since
we are a week till release (USA wise).

Revision history for this message
Amr Ibrahim (amribrahim1987) wrote : Re: [FFe] Please update to bugfix release 1.10

If this FFe is not accepted, it is worth a shot to pass it as an SRU after Xenial release since it has many bug fixes. It fixes these for example bug #1366317 and bug #1353988.

Revision history for this message
Clive Johnston (clivejo-deactivatedaccount) wrote :

I cant seem to find a 1.10 release in Debian, does anyone know if they have it? Any packaging I can find is over 2 years old at this point.

Anyway, I grabbed the old packaging and tweaked it a bit. I got it to build locally and uploaded it to LP. There are a few issues with symbols need ironed out, but in the mean time could anyone willing to test it please do so.

It is in my PPA https://launchpad.net/~clivejo/+archive/ubuntu/xenial/

Revision history for this message
Clive Johnston (clivejo-deactivatedaccount) wrote :

Amr, would you have a complete list of LP bugs this update would fix?

Revision history for this message
Martin Pitt (pitti) wrote :

> If this FFe is not accepted

It was accepted two weeks ago in comment #3

Revision history for this message
Amr Ibrahim (amribrahim1987) wrote :
Martin Pitt (pitti)
Changed in taglib (Ubuntu):
importance: Critical → Medium
Revision history for this message
Clive Johnston (clivejo-deactivatedaccount) wrote :

Amr,

Thanks, I've added those to the changelog as being closed by this Update.

Do you know people who can test this package?

Revision history for this message
Clive Johnston (clivejo-deactivatedaccount) wrote :

It needs testing to ensure those bugs are actually fixed and it doesn't trigger any new ones!

Revision history for this message
Amr Ibrahim (amribrahim1987) wrote :

I don't know specific people. But I know that Amarok, Juk and Clementine developers and users could test this.

Revision history for this message
Amr Ibrahim (amribrahim1987) wrote :

Mixxx and Kodi too.

summary: - [FFe] Please update to bugfix release 1.10
+ Please update to bugfix release 1.10
Revision history for this message
Daniel Schürmann (daschuer) wrote : Re: Please update to bugfix release 1.10

We ship taglib 1.10 along with Mixxx 2.0 for Linux, Windows and Mac since 2016-01-01 and do not face a single single taglib related crasher since then.
1.9 taglib was one of the main reasons for a crash before. The taglib source tree includes a nice collections of problem files for test.

We strongly recommend to use taglib 1.10, because Mixxx does not have a quarantine process for taglib like Rhythmbox or Clementine.

https://launchpad.net/~mixxx/+archive/ubuntu/mixxx

Revision history for this message
Amr Ibrahim (amribrahim1987) wrote :

Clive, I think the update can be pushed to yakkety (16.10) now.

Revision history for this message
Amr Ibrahim (amribrahim1987) wrote :

You can update to 1.11. It has been recently released.

TagLib 1.11 (Apr 29, 2016)
==========================

1.11:

 * Fixed reading APE items with long keys.
 * Fixed reading ID3v2 SYLT frames when description is empty.

1.11 BETA 2:

 * Better handling of PCM WAV files with a 'fact' chunk.
 * Better handling of corrupted APE tags.
 * Efficient decoding of unsynchronized ID3v2 frames.
 * Fixed text encoding when saving certain frames in ID3v2.3 tags.
 * Fixed updating the size of RIFF files when removing chunks.
 * Several smaller bug fixes and performance improvements.

1.11 BETA:

 * New API for creating FileRef from IOStream.
 * Added support for ID3v2 PCST and WFED frames.
 * Added support for pictures in XiphComment.
 * Added String::clear().
 * Added FLAC::File::strip() for removing non-standard tags.
 * Added alternative functions to XiphComment::removeField().
 * Added BUILD_BINDINGS build option.
 * Added ENABLE_CCACHE build option.
 * Replaced ENABLE_STATIC build option with BUILD_SHARED_LIBS.
 * Better handling of duplicate ID3v2 tags in all kinds of files.
 * Better handling of duplicate tag chunks in WAV files.
 * Better handling of duplicate tag chunks in AIFF files.
 * Better handling of duplicate Vorbis comment blocks in FLAC files.
 * Better handling of broken MPEG audio frames.
 * Fixed crash when calling File::properties() after strip().
 * Fixed crash when parsing certain MPEG files.
 * Fixed crash when saving Ogg files.
 * Fixed possible file corruptions when saving ASF files.
 * Fixed possible file corruptions when saving FLAC files.
 * Fixed possible file corruptions when saving MP4 files.
 * Fixed possible file corruptions when saving MPEG files.
 * Fixed possible file corruptions when saving APE files.
 * Fixed possible file corruptions when saving Musepack files.
 * Fixed possible file corruptions when saving WavPack files.
 * Fixed updating the comment field of Vorbis comments.
 * Fixed reading date and time in ID3v2.3 tags.
 * Marked ByteVector::null and ByteVector::isNull() deprecated.
 * Marked String::null and String::isNull() deprecated.
 * Marked XiphComment::removeField() deprecated.
 * Marked Ogg::Page::getCopyWithNewPageSequenceNumber() deprecated. It returns null.
 * Marked custom integer types deprecated.
 * Many smaller bug fixes and performance improvements.

summary: - Please update to bugfix release 1.10
+ Please update to 1.11
description: updated
Revision history for this message
Amr Ibrahim (amribrahim1987) wrote : Re: Please update to 1.11

Please update to 1.11.

Simon Quigley (tsimonq2)
Changed in taglib (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
status: Triaged → In Progress
Revision history for this message
Urs Fleisch (ufleisch) wrote :

I just wanted to add that I ship the Windows, Mac OS X and Android builds of Kid3 with TagLib 1.11 since it was released in April. Nobody has complained about any bug related to TagLib since then (with more than 35000 downloads according to the SourceForge stats). So I think that TagLib 1.11 is a good release and I would like to see it in yakkety.

Revision history for this message
Iain Lane (laney) wrote :

Ok, as long as this is not a transition (the API and ABI are compatible), then feel free to go ahead.

If you need sponsorship, please attach the required files here and subscribe ~ubuntu-sponsors, otherwise just upload.

Try to do it soon, so there is maximum time for testing.

Revision history for this message
Urs Fleisch (ufleisch) wrote :

Unfortunately, versions 1.9.1 and 1.11 are not binary compatible, see this post for the original problem (it contains links to a few images showing that unicode text is garbled).

https://mail.kde.org/pipermail/taglib-devel/2015-November/002798.html

See my answer

https://mail.kde.org/pipermail/taglib-devel/2015-December/002800.html

To summarize: A binary incompatiblity was introduced in the String constructor between versions 1.8 and 1.9. In version 1.10, this change was reverted. This makes TagLib 1.11 binary compatible with versions 1.10, 1.8, ..., but not 1.9 and 1.9.1.

I still think that 1.11 is one of the best TagLib releases so far, but if you make the transition from TagLib 1.9.1 to TagLib 1.11, should should recompile everything which was built against TagLib 1.9.x.

Simon Quigley (tsimonq2)
Changed in taglib (Ubuntu):
assignee: Simon Quigley (tsimonq2) → nobody
Changed in taglib (Debian):
status: New → Fix Released
Revision history for this message
Rik Mills (rikmills) wrote :

It seems the lack of an update to 1.10 or later in Yakkety 16.10 now means that qmmp cannot load mp3 files.

Ref: https://sourceforge.net/p/qmmp-dev/tickets/878/

Simon Quigley (tsimonq2)
Changed in taglib (Ubuntu):
assignee: nobody → Simon Quigley (tsimonq2)
Revision history for this message
Simon Quigley (tsimonq2) wrote :

It seems that this package can be cleanly synced from Debian.

I checked out the Ubuntu delta, and it seems it's just a patch that has been applied upstream and is no longer needed when 0.11 is applied. Same with the other patch that is in there.

So someone just has to sync from Debian manually.

Revision history for this message
Simon Quigley (tsimonq2) wrote :

(Sid, to be specific)

Revision history for this message
Matteo Cypriani (mcy) wrote :

taglib 1.11.1 has just be released, and fixes an ABI breakage, cf. https://bugs.debian.org/839767
I plan on uploading it in sid this week, and I would recommend that you wait for this version to sync in Ubuntu.

(And indeed, qmmp 1.1 should not have been packaged without taglib >= 1.10. qmmp 1.1.4 is in sid now and works fine with taglib 1.11.)

Revision history for this message
Simon Quigley (tsimonq2) wrote :

Thanks Matteo for looking into this!

I indeed noticed some breakage when trying to do this locally (before I checked out what Debian had).

Changed in taglib:
status: Unknown → Confirmed
description: updated
Revision history for this message
Flames_in_Paradise (ellisistfroh-deactivatedaccount) wrote :

@ tsimonq2: You don't need2ask anybody else -> but file a bugreport for sync -> bug 1636316 <DONE>

Thats actually much less ardous then filling in a SRU. ;-)

Revision history for this message
Matteo Cypriani (mcy) wrote : Re: [Bug 1546373] Re: Please update to 1.11

Le lundi 24 octobre 2016 03:20:40 EDT, vous avez écrit :
> taglib 1.11.1 has just be released, and fixes an ABI breakage, cf.
> https://bugs.debian.org/839767 I plan on uploading it in sid this week

Done last night, so you should be good to go!

Changed in taglib:
status: Confirmed → Fix Released
Revision history for this message
Amr Ibrahim (amribrahim1987) wrote : Re: Please update to 1.11

It's is zesty-proposed.

Changed in taglib (Ubuntu):
status: In Progress → Fix Committed
Changed in taglib (Ubuntu):
status: Fix Committed → Confirmed
Revision history for this message
Flames_in_Paradise (ellisistfroh-deactivatedaccount) wrote :

@ amribrahim1987: This update-software-request was reported against XENIAL in February 2016. So if you want to set it to "fix commited" a relase-bug-task for Zesty has to be opened.

If you want it in Xenial pls.follow

https://wiki.ubuntu.com/StableReleaseUpdates

That means it first has to enter Yakkety. Simon?

Revision history for this message
Amr Ibrahim (amribrahim1987) wrote :

It does not matter which version this bug was reported. The bug status always has to follow the current development release first, which is now Zesty. This will probably never be updated in Xenial nor Yakkety since it's an invasive and feature update (version 1.11.1).

summary: - Please update to 1.11
+ Please update to 1.11.1
description: updated
Revision history for this message
Amr Ibrahim (amribrahim1987) wrote :
Changed in taglib (Ubuntu):
status: Confirmed → Fix Committed
Revision history for this message
Simon Quigley (tsimonq2) wrote :

Well the whole purpose of this bug report was to get a new version of Taglib in the archive, which has been accomplished for Zesty, so I'm putting that back.

Unfortunately, there isn't a reasonable way for this to enter Yakkety and/or Xenial Updates. Although I'm not entirely familiar with this process (and I encourage others to check this over), we need specific examples of what bugfixes exist, the regression potential for these bugfixes, and we can't add any new features. So we would have to get this into Yakkety and/or Xenial Backports.

Once this version of taglib in Zesty has been thoroughly tested, we can proceed from here. But we *need* to confirm that this works.

Thanks for your hard work, Flames_in_Paradise, and I hope this answers a few questions.

Changed in taglib (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.