Ubuntu

FFe update to 1.8

Reported by Jonathan Riddell on 2012-09-13
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
taglib (Ubuntu)
Undecided
Unassigned
Quantal
Undecided
Unassigned

Bug Description

Developers from Amarok have requested we update to taglib 1.8.

TagLib 1.8 (Sep 6, 2012)
==============================

1.8:

 * Added support for OWNE ID3 frames.
 * Changed key validation in the new PropertyMap API.
 * ID3v1::Tag::setStringHandler will no londer delete the previous handler,
   the caller is responsible for this.
 * File objects will also no longer delete the passed IOStream objects. It
   should be done in the caller code after the File object is no longer
   used.
 * Added ID3v2::Tag::setLatin1StringHandler for custom handling of
   latin1-encoded text in ID3v2 frames.
 * Fixed validation of ID3v2 frame IDs (IDs with '0' were ignored).

1.8 BETA:

 * New API for accessing tags by name.
 * New abstract I/O stream layer to allow custom I/O handlers.
 * Support for writing ID3v2.3 tags.
 * Support for various module file formats (MOD, S3M, IT, XM).
 * Support for MP4 and ASF is now enabled by default.
 * Started using atomic int operations for reference counting.
 * Added methods for checking if WMA and MP4 files are DRM-protected.
 * Added taglib_free to the C bindings.
 * New method to allow removing pictures from FLAC files.
 * Support for reading audio properties from ALAC and Musepack SV8 files.
 * Added replay-gain information to Musepack audio properties.
 * Support for APEv2 binary tags.
 * Many AudioProperties subclasses now provide information about the total number of samples.
 * Various small bug fixes.

Related branches

Jonathan Riddell (jr) wrote :

appearing soon at https://launchpad.net/~jr/+archive/ppa/+packages
ABI compatible
id3v2.3 tag writing and new format support seems to be the main features
it has a number of bug fixes

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in taglib (Ubuntu):
status: New → Confirmed
Scott Kitterman (kitterman) wrote :

What testing has been done in Ubuntu for the new version?

Jonathan Riddell (jr) wrote :

I have used it extensively with Amarok and it successfully reads and writes tags for my collection.

Scott Kitterman (kitterman) wrote :

Thanks. Approved.

Changed in taglib (Ubuntu Quantal):
status: Confirmed → Triaged
Jonathan Riddell (jr) on 2012-09-24
tags: added: kubuntu
Iain Lane (laney) wrote :

Do you plan on uploading this soon?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package taglib - 1.8-0ubuntu1

---------------
taglib (1.8-0ubuntu1) quantal; urgency=low

  * New upstream release, LP: #1050463
  * Remove backport_id3v2_null_pointer.diff now upstream
  * Update rusxmms patch
 -- Jonathan Riddell <email address hidden> Thu, 13 Sep 2012 14:13:34 +0100

Changed in taglib (Ubuntu Quantal):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers