Ubuntu

bootlogd configuration files are misleading

Reported by Antoine Delvaux on 2007-03-20
28
This bug affects 1 person
Affects Status Importance Assigned to Milestone
sysvinit (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: upstart

(not sure if I have to fill this bug against upstart or sysvinit, sorry if I guessed wrong)

Because of the migration from sysvinit to upstart, edgy does still uses the initscripts package. This one includes configuration and startup files for the bootlogd daemon. However, the daemon itself is included in the sysvinit package which will never be installed (as it conflitcts with upstart).

This is somewhat misleading, see support request #2933. Maybe a notice should be included in /etc/default/bootlogd as to warn the potential user?

Related branches

Confirmed in Fesity.

Changed in sysvinit:
status: Unconfirmed → Confirmed
Feng Chao (chaofeng) wrote :

Is there another way to see the boot message ?

/sbin/logd is supposed to log to /var/log/boot, but it's broken, more info at <https://bugs.launchpad.net/bugs/98955>.

Bogdan Butnaru (bogdanb) wrote :

Someone might want to apply this patch to the /etc/init.d/bootlogd file.

As the old one, it checks if the daemon exists. However, if it doesn't, it warns the user (the old one failed silently) and points them to this bug report, which is informative enough.

There's also a 2 sec delay there (it only occurs in the error situation) to let the user at least notice the message. (Due to these bugs, the logs are not available...)

Daniel Holbach (dholbach) wrote :

To get your fix included in Ubuntu, try transforming it into a debdiff (http://wiki.ubuntu.com/PackagingGuide/Recipes/Debdiff) and submitting it for review (http://wiki.ubuntu.com/SponsorshipProcess).

Changed in sysvinit:
status: Confirmed → Incomplete
Bogdan Butnaru (bogdanb) wrote :

The attached debdiff moves the init.d scripts related to bootlogd in the obsolete directory of the package, thus making them non-instalable. This is because bootlogd has not been installed in Ubuntu since longtime ago.

(The "obsolete" directory already existed, it contains some older files. If we add bootlogd again in the future, the scripts can be restored.)

Changed in sysvinit:
status: Incomplete → New
Daniel Holbach (dholbach) wrote :

Scott: can you take a look at it?

I'd rather the patch found a way to make bootlogd work again

Bogdan Butnaru (bogdanb) wrote :

So would I, but it's been asked for for years now, and it's an important feature, and I'm led to believe the solution is quite nontrivial. It might even be “solved” by replacing bootlogd with something different. So rather than having these files installed uselessly on several thousand computers for another couple of years, I think they'd better be disabled for now.

There are definitely people who have it working in Ubuntu - removing files would break it for them

I'm not aware of the package existing in Ubuntu, but anyway, AFAIK
it's not working in Ubuntu. So whoever has it working must have put it
there themselves and thus know how to configure their install. Doesn't
this belong in the bootlogd package anyway?

On Sat, Apr 12, 2008 at 10:38 AM, Scott James Remnant
<email address hidden> wrote:
> There are definitely people who have it working in Ubuntu - removing
> files would break it for them

--
Bogdan Butnaru — <email address hidden>
"I think I am a fallen star, I should wish on myself." – O.

Daniel Holbach (dholbach) wrote :

Unsubscribed Ubuntu Sponsors for main from this bug for now.

Daniel T Chen (crimsun) on 2008-09-27
Changed in sysvinit:
status: New → Confirmed
Launchpad Janitor (janitor) wrote :
Download full text (25.4 KiB)

This bug was fixed in the package sysvinit - 2.87dsf-4ubuntu1

---------------
sysvinit (2.87dsf-4ubuntu1) karmic; urgency=low

  * Merge from debian unstable, remaining changes:
    - Support Cell processor:
      + debian/initscripts/postinst: Create spu system group and /spu mount
        point if we are running on a Cell processor.
      + debian/initscripts/etc/init.d/mountkernfs.sh: Mount spufs if Cell
        processor is detected.
      + debian/initscripts/lib/init/mount-functions.sh: Modprobe spufs
        if not available.
      + debian/control: Add initscripts dependency 'passwd' for groupadd.
      (Forwarded to Debian #483399)
    - Use tmpfs mounts for /var/lock and /var/run:
      + debian/initscripts/share/default.rcS: Enable RAMRUN and RAMLOCK by
        default.
      + debian/initscripts.postinst: Enable RAMRUN and RAMLOCK in
        /etc/default/rcS on upgrades. This needs to be kept until the next
        LTS.
      + debian/initscripts/etc/init.d/mountkernfs.sh: Propagate files from the
        initramfs to our new /var/run, so that we can populate
        /var/run/sendsigs.omit from initramfs.
    - Boot ordering differences:
      + mountkernfs.sh: 02 -> 01
      + mountdevsubfs.sh: 04 -> 11
      + bootlogd: disabled by default
      + checkroot.sh: 10 -> 20
      + mtab.sh: 12 -> 22
    - debian/patches/91_sulogin_lockedpw.dpatch: Disable "root account is
      locked" warning, since this is the default in Ubuntu. Document this in
      sulogin.8.
    - debian/control: Drop Essential: yes from packages since we use Upstart.
    - debian/control: Conflict/Replace sysvconfig which has also previously
      provided service(8).
    - debian/control, debian/rules: Previous name for sysvinit-utils was
      'sysvutils' in Ubuntu, so Conflict/Replace/Provide it. Also create a
      dummy sysvutils package, since Hardy has reverse versioned dependencies
      to it. This needs to be kept until after the next LTS.
    - debian/control: Depend on lsb-base (>= 3.2-14) for status_of_proc()
      function.
    - debian/initscripts/etc/init.d/checkfs.sh: Don't depend on hwclockfirst
      which Ubuntu does not have.
    - debian/initscripts/etc/init.d/mountkernfs.sh: Always mount devpts, and
      do not touch /dev/ptmx (which is already managed by udev).
    - debian/initscripts/etc/init.d/mountkernfs.sh: mount fusectl if it is
      available
    - debian/initscripts/etc/init.d/mountkernfs.sh: mount securityfs if it is
      available. This allows for easier AppArmor confinement of applications
      early in the boot process. LP: #399954
    - debian/initscripts/etc/init.d/mountkernfs.sh: mount debugfs if it is
      available.
    - debian/initscripts/etc/init.d/ondemand: Sleep for 60 seconds, then
      set CPU Frequency Scaling governor to "ondemand". LP: #341573.
    - debian/initscripts/etc/init.d/umountfs: Don't unmount filesystems
      that precede root or use force for some mountpoints.
    - debian/initscripts/etc/network/if-up.d/mountnfs: Rename ifstate
      file to /var/run/network/ifstate
    - ./debian/initscripts/lib/init/usplash-fsck-functions.sh: Use blkid,
      vol_id is gone.
    - debian/initscripts.{...

Changed in sysvinit (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions