The default value of TMPTIME in /etc/default/rcS should be non-zero

Bug #58502 reported by Andrew McCarthy on 2006-09-01
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
sysvinit (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: initscripts

The default value of TMPTIME is 0, which means /tmp is cleaned during every boot. Although files in /tmp are supposed to be temporary, that doesn't mean they're worthless. In the case of a crash or power failure, useful data which could have been recovered is lost.

To cover extended outages, I suggest that the default for TMPTIME should be increased to several days. Thanks!

A fair request, however I think that the default behaviour should be that /tmp does not survive a reboot.

Changed in sysvinit:
status: Unconfirmed → Rejected
Jesse Glick (jesse-glick) wrote :

I agree that the default of zero is an unpleasant surprise. Under Fedora, I was accustomed to putting things of little value - temporary files, like software downloads or one-off test cases - in /tmp; it was fine that they got deleted after a month or so because by then I would have forgotten about them. Under Ubuntu, now any time my computer crashes (a pretty frequent occurrence, since it's a laptop), all of that is gone. Not a huge loss but certainly an annoyance. Given that most users have much more disk space than they can use, it seems unlikely that keeping /tmp files for a few days would harm anyone - and given that this is a boot job, not a cron job as in Fedora, and desktop systems could be running indefinitely without a reboot, that does not seem to be a primary motivation anyway.

This could also be seen as the "root cause" of Bug #15179, that Firefox downloads get nixed after a reboot without warning; although in that case it seems that some novice Unix users did not realize that /tmp was not for long-term storage of files and were putting valuable data (e.g. OOo documents) there.

Is there nowhere in the desktop preferences GUI to configure TMPTIME? I had some difficulty finding this setting; I had to read through bootclean to find it.

aeb (aeb-cwi) wrote :

Yes, a very unpleasant surprise. Spent several hours carefully drafting a referee report in a mutt session replying to the letter that contained the paper to referee. A power failure caused a reboot, and as I find out the default Ubuntu behavior is to delete all the user's work in /tmp, even if it is only five minutes old. TMPTIME should have a nonzero default.

Changed in sysvinit (Ubuntu):
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers