superfluous /etc/network/if-up.d/mountnfs.orig in initscripts

Bug #314772 reported by Timo Aaltonen on 2009-01-07
6
Affects Status Importance Assigned to Milestone
sysvinit (Ubuntu)
Undecided
Unassigned
Hardy
Medium
Unassigned

Bug Description

Binary package hint: sysvinit

The initscripts package has carried an extra mountnfs.orig-script in /etc/network/if-up.d/ since version 2.86.ds1-14.1ubuntu26 (gutsy). Hardy has it, intrepid-> doesn't. It should be cleaned from the package, because it's run in addition to the proper script.

Timo Aaltonen (tjaalton) wrote :

it's an embarrassing leftover which should be removed sooner than later..

Changed in sysvinit:
importance: Undecided → Medium
status: New → Confirmed
Timo Aaltonen (tjaalton) wrote :

not found on intrepid or newer

Changed in sysvinit:
status: New → Fix Released
Timo Aaltonen (tjaalton) wrote :
Timo Aaltonen (tjaalton) wrote :
Martin Pitt (pitti) wrote :

Good idea, but this isn't complete. Since this is a conffile, it will continue to stay around (as an orphaned conffile) with this update. So this additionally needs a preinst snippet to remove the .orig conffile on upgrade to that fixed version (preferably only if it is unmodified). See http://wiki.debian.org/DpkgConffileHandling for a standard recipe.

Timo Aaltonen (tjaalton) wrote :

Even though mountnfs.orig is not listed in conffiles? The preinst already has code to do that, so it's pretty easy to do anyway.

Martin Pitt (pitti) wrote :

Right, as per our discussion in IRC that's fine. Sorry for the noise. Please go ahead and upload.

Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in sysvinit:
status: Confirmed → Fix Committed

Confirming that /etc/network/if-up.d/mountnfs.orig has been successfully removed after upgrade to package from hardy-proposed.

$ LANG=C apt-cache policy initscripts
initscripts:
  Installed: 2.86.ds1-14.1ubuntu45.1
  Candidate: 2.86.ds1-14.1ubuntu45.1
  Version table:
 *** 2.86.ds1-14.1ubuntu45.1 0
        400 http://be.archive.ubuntu.com hardy-proposed/main Packages
        100 /var/lib/dpkg/status
     2.86.ds1-14.1ubuntu45 0
        500 http://be.archive.ubuntu.com hardy/main Packages

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sysvinit - 2.86.ds1-14.1ubuntu45.1

---------------
sysvinit (2.86.ds1-14.1ubuntu45.1) hardy-proposed; urgency=low

  * Remove initscripts/etc/network/if-up.d/mountnfs.orig. (LP: #314772)

 -- Timo Aaltonen <email address hidden> Wed, 07 Jan 2009 18:49:25 +0200

Changed in sysvinit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments