Bootlogd doesn't log boot messages

Bug #306998 reported by schnauzer on 2008-12-10
This bug report is a duplicate of:  Bug #328881: init: support logging of job output. Edit Remove
This bug affects 8 people
Affects Status Importance Assigned to Milestone
sysvinit (Ubuntu)

Bug Description

In Intrepid, boot logging is apparently not enabled by default. Therefore, I edited /etc/default/bootlogd and changed


However, when I rebooted, I saw no change in /var/log/boot. Also, I ran "update-rc.d -f bootlogd remove" then "update-rc.d bootlogd defaults", but there was still no boot log.

affects: upstart (Ubuntu) → sysvinit (Ubuntu)

Hello schnauzer :-)

If Intrepid is like Hardy then the issue is that bootlogd itself is not installed, despite the existence of /etc/default/bootlogd.

Have you got a /sbin/bootlogd executable? If not, see for an (unsupported) workaround that may also work on Intrepid.



Sorry -- I forgot to point out that has two workarounds, one being an (unsupported but widely used) bootlogd installation and the other being a way to stop init script processing and get a login prompt during boot that allows you to and see (and scroll back through) boot messages on console.

Carlo Gandolfo (carlo.gandolfo) wrote :

It still the same for Karmic, with a /sbin/bootlogd present and executable

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sysvinit (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers