Can not switch back to sysvinit

Bug #291613 reported by Loïc Minier on 2008-10-31
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
upstart
Undecided
Unassigned
sysvinit (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

When reinstalling sysvinit on a system running upstart, telinit can not talk to the currently running init. For the same reason, it's not possible to ask for a reboot.

This is less an use case than moving from sysvinit to upstart -- which does work fine -- but I thought it should be reported.

Bye

Loïc Minier (lool) wrote :

(Not terribly useful on an Ubuntu system, but it's easier for me to setup an Ubuntu vm right now) the exact output is:
on install:
...
Setting up sysvinit (2.86.ds1-59ubuntu13)
init: timeout opening/writing control channel /dev/initctl

on reboot:
Broadcast message from root blahblah

The system is going down for reboot NOW!
shutdown: timeout opening/writing control channel /dev/initctl
init: timeout opening/writing control channel /dev/initctl

I don't see why this is an Upstart bug.

Changed in upstart:
status: New → Won't Fix
Loïc Minier (lool) wrote :

I have no idea where the bug lies, but if we allow Debian people to opt into upstart, then we might as well want to allow them to opt out of it?

Shouldn't that be filed on Debian sysvinit?

Luke J Militello (kilahurtz) wrote :

I ran across this same problem as well with installing sysvinit on Gutsy (7.10), Hardy (8.04) and Intrepid (8.10). With all systems unresponsive to reboot (most of them remote servers) yielding the same error as stated above. Couldn't find any associated process to hup, restart or even kill. As a last resort, I ran reboot -f (force) and the problem seems to have gone away. Systems reloaded and now reboot and halt like they should. They are responding just fine and I haven't seen the 'initctl' unresponsive error since.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers