hardy->intrepid upgrade fails because of sysvinit pre-depends loop

Bug #237276 reported by cariboo on 2008-06-04
4
Affects Status Importance Assigned to Milestone
sysvinit (Ubuntu)
High
Martin Pitt

Bug Description

Binary package hint: update-manager

Sysvutils tried to upgrade and the upgrade wasn't completed

ProblemType: Package
Architecture: amd64
Date: Tue Jun 3 22:58:05 2008
DistroRelease: Ubuntu 8.10
ErrorMessage: ErrorMessage: SystemError in cache.commit(): installArchives() failed

NonfreeKernelModules: nvidia
Package: update-manager 1:0.91.2
PackageArchitecture: all
SourcePackage: update-manager
Title: package update-manager 1:0.91.2 failed to install/upgrade: ErrorMessage: SystemError in cache.commit(): installArchives() failed
Uname: Linux 2.6.24-16-generic x86_64

cariboo (cariboo) wrote :
Michael Vogt (mvo) wrote :

Here is the error message:

E:This installation run will require temporarily removing the essential package sysvutils due to a Conflicts/Pre-Depends loop. This is often bad, but if you really want to do it, activate the APT::Force-LoopBreak option
E:Internal Error, Could not early remove sysvutils

I can reproduce this in a chroot.

Changed in sysvinit:
importance: Undecided → High
milestone: none → intrepid-alpha-1
status: New → Confirmed
Martin Pitt (pitti) on 2008-06-04
Changed in sysvinit:
assignee: nobody → pitti
status: Confirmed → In Progress

You can bypass this problem by issuing the following command:

sudo aptitude -o APT::Force-LoopBreak=true dist-upgrade

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sysvinit - 2.86.ds1-56ubuntu3

---------------
sysvinit (2.86.ds1-56ubuntu3) intrepid; urgency=low

  * Let sysvinit-utils only replace the old sysvutils, do not conflict to it.
    This is a less clean way to do the transition than with a proper
    Conflicts/Replaces, but the latter induces a Pre-Depends/Conflicts loop
    which is unresolvable. (LP: #237276)

 -- Martin Pitt <email address hidden> Thu, 05 Jun 2008 08:44:44 +0200

Changed in sysvinit:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers