update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults

Bug #1369493 reported by dino99 on 2014-09-15
50
This bug affects 10 people
Affects Status Importance Assigned to Milestone
sysvinit (Ubuntu)
Low
Unassigned

Bug Description

Upgrading xorg on Utopic (booted with upstart), the install dialog-box have displayed this warning:

Setting up x11-common (1:7.7+7ubuntu2) ...
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
 * Setting up X socket directories... [ OK ]

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: sysv-rc 2.88dsf-41ubuntu18
ProcVersionSignature: Ubuntu 3.16.0-14.20-generic 3.16.2
Uname: Linux 3.16.0-14-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.14.7-0ubuntu2
Architecture: amd64
CurrentDesktop: GNOME
Date: Mon Sep 15 12:12:53 2014
PackageArchitecture: all
SourcePackage: sysvinit
UpgradeStatus: No upgrade log present (probably fresh install)

dino99 (9d9) wrote :
dino99 (9d9) wrote :

Seems a 2.89 new package is available; maybe could you set it into a ppa for testing purpose, as it have lot of bugfixes and the too old badly 'shutdown' issue disturbing the next reboot has also some workarounds/fixes.

http://lists.gnu.org/archive/html/sysvinit-devel/2014-02/msg00007.html

dino99 (9d9) wrote :

Debian 'experimental' also have that one: sysvinit (2.88dsf-55.3)

http://metadata.ftp-master.debian.org/changelogs//main/s/sysvinit/sysvinit_2.88dsf-55.3_changelog

dino99 (9d9) on 2014-09-15
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sysvinit (Ubuntu):
status: New → Confirmed
Changed in sysvinit (Ubuntu):
importance: Undecided → Medium
importance: Medium → Low
dino99 (9d9) on 2015-07-23
tags: added: vivid wily
removed: utopic
Julian Alarcon (alarconj) wrote :

This is still present in Ubuntu 16.04 Xenial Xerus

tags: added: xenial
William Geiger (whgiii-q) wrote :

I am also getting this on Xenial I found a bug report on Debian that discusses this issue and the causes. https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=718232 The last post on Debian claims that this was fixed with resolvconf (1.75). I have resolvconf (1.781.78ubuntu2) on my system and the bug is still there, don't know if there is a difference between the resolvconf on Debian and Ubuntu. Mantainer might want to take a look at what the did with the Debian package.

Hope this helps.

Symax (ayourk) on 2016-04-10
tags: added: armhf
xb5i7o (xb5i7o) wrote :

this bug is suddenly present again after doing these updates.

See attachment screenshot

xb5i7o (xb5i7o) wrote :

on Ubuntu Xenial

M. Kurt (paralaks) wrote :

I could not get plymouth-manager running. When I tried to reinstall I ran into this problem. I am on 16.04

Andrew (hospes-a) wrote :

The same bug for me. Logs:

Setting up procps (2:3.3.10-4ubuntu2.3) ...
update-rc.d: warning: start and stop actions are no longer supported; falling back to defaults
initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused
insserv: warning: script 'screen-cleanup' missing LSB tags and overrides
insserv: Default-Start undefined, assuming empty start runlevel(s) for script `screen-cleanup'
insserv: Default-Stop undefined, assuming empty stop runlevel(s) for script `screen-cleanup'

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.