wrong conffile prompt for /etc/default/rcS when UTC=no

Bug #1184006 reported by Steve Langasek on 2013-05-24
54
This bug affects 10 people
Affects Status Importance Assigned to Milestone
clock-setup (Ubuntu)
Undecided
Unassigned
Saucy
Undecided
Unassigned
sysvinit (Ubuntu)
High
Steve Langasek
Saucy
High
Steve Langasek
ubiquity (Ubuntu)
Undecided
Unassigned
Saucy
Undecided
Unassigned

Bug Description

Because we're not following Debian on the use of /etc/adjtime for UTC settings and instead keeping it in /etc/default/rcS, users who have the non-default setting of UTC=no will get inappropriate conffile prompts on upgrade to saucy.

We need to deal with this by either reverting /etc/default/rcS's conffile status, or moving this UTC setting out of /etc/default/rcS (options: /etc/default/hwclock, /etc/init/hwclock{,-save}.override).

Related branches

Steve Langasek (vorlon) on 2013-05-24
Changed in sysvinit (Ubuntu):
status: New → Triaged
importance: Undecided → High
assignee: nobody → Steve Langasek (vorlon)
Steve Langasek (vorlon) on 2013-05-25
Changed in sysvinit (Ubuntu Saucy):
status: Triaged → In Progress
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1184006

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in clock-setup (Ubuntu):
status: New → Confirmed
Changed in ubiquity (Ubuntu):
status: New → Confirmed
Scott Moser (smoser) on 2014-03-28
Changed in sysvinit (Ubuntu):
milestone: none → ubuntu-14.04
Rolf Leggewie (r0lf) wrote :

saucy has seen the end of its life and is no longer receiving any updates. Marking the saucy task for this ticket as "Won't Fix".

Changed in sysvinit (Ubuntu Saucy):
status: In Progress → Won't Fix
Rolf Leggewie (r0lf) on 2014-12-05
Changed in ubiquity (Ubuntu Saucy):
status: Confirmed → Won't Fix
Changed in clock-setup (Ubuntu Saucy):
status: Confirmed → Won't Fix
Changed in sysvinit (Ubuntu):
milestone: ubuntu-14.04 → none
status: In Progress → Confirmed
dotancohen (dotancohen) wrote :

This bug seems to have been closed WONTFIX as it affects older, unsupported Ubuntu versions. However, I have encountered this bug on an upgrade from 15.10 to 16.04, and other dupes of the bug show that other users are encountering the bug on newer Ubuntu versions as well.

Please reopen. Thank you.

On Wed, Apr 27, 2016 at 08:46:19AM -0000, dotancohen wrote:
> This bug seems to have been closed WONTFIX as it affects older,
> unsupported Ubuntu versions. However, I have encountered this bug on an
> upgrade from 15.10 to 16.04, and other dupes of the bug show that other
> users are encountering the bug on newer Ubuntu versions as well.

> Please reopen. Thank you.

There is a separate issue for 15.10 to 16.04 upgrades, which is tracked as
bug #1572752.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers