"mount: / is busy" error during shutdown (not network-manager)

Bug #1170911 reported by Laurent Bonnaud on 2013-04-20
118
This bug affects 24 people
Affects Status Importance Assigned to Milestone
sysvinit (Ubuntu)
High
Shmearl

Bug Description

When I halt Ubuntu ugly (but probably harmless) error messages about unmounting several filesystems (including the root) are displayed or the screen.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: mountall 2.48build1
ProcVersionSignature: Ubuntu 3.8.0-19.29-generic 3.8.8
Uname: Linux 3.8.0-19-generic i686
ApportVersion: 2.9.2-0ubuntu8
Architecture: i386
Date: Sat Apr 20 11:08:07 2013
InstallationDate: Installed on 2013-02-05 (73 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha i386 (20130205)
MarkForUpload: True
ProcEnviron:
 TERM=xterm
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: mountall
UpgradeStatus: No upgrade log present (probably fresh install)

Here is a screenshot of the error messages.

Steve Langasek (vorlon) wrote :

Hi Laurent,

Please note that mountall is only involved in the mounting at boot, it has nothing to do with shutdown. The messages shown here come from a sysvinit script.

The spurious messages on shutdown about unmounting not-mounted filesystems have previously been reported as bug #1097321.

The error reporting that the root filesystem is busy is a more serious issue that can have various causes. We should figure out what's holding the root filesystem open on your system and fix it.

affects: mountall (Ubuntu) → sysvinit (Ubuntu)
Changed in sysvinit (Ubuntu):
importance: Undecided → High
RichB (trash1464) wrote :

I am havint the same problem as is another person per this thread in the Ubuntu Forum:
http://ubuntuforums.org/showthread.php?t=2140104
My system hangs indefinetly at shutdown with file system unmount failures one of which is root

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sysvinit (Ubuntu):
status: New → Confirmed
Shmearl (shmearl) on 2013-05-03
Changed in sysvinit (Ubuntu):
assignee: nobody → Matthias Kremeyer (matthias-kremeyer)
Thomas U. (thomas-unterthiner) wrote :

Hi!

My main problem is that my shutdown hangs indefinitely. I came to this bug report via this forum thread: ubuntuforums.org/showthread.php?t=2140112 (if I'm not entirely wrong I've seen other "shutdown failure on 13.04" threads point to this bug report here).

In any case, my main bug is that the shutdown doesn't power of my machine. I am not conviced that this is really related to the unmount error messages. But since RichB also reported his problems here, I thought I'd add to it as well. I susptect that many of the "affected users" are actually affected by the shutdown bug. If you google for "ubuntu 13.04 shutdown" you can find several people that seem to suffer from this issue. I am happy to open another bug report by it, since I am not confinced the two are related (Especially since the initial report doesn't have shutdown problems).

I have three machines that have clean 13.04 installs. Two laptops, one desktop. All of them *sometimes* fail to shut down cleanly. It doesn't happen all the time, but about 75% of the shutdowns just "hang" without powering down the machine. I have not been able to pin down what happens the failed shutdowns.

I can think of the following similarities between the 3 machines:

* all run proprietary nvidia drivers (version 313)
* on all of them I deactivated encrypted swap (on the desktop I deactivated swap alltogether)
* all of them have encrypted filesystems that are mouned via LUKS and libpam-mount

In any case, this error is VERY annoying. Among things it stops me from remotely starting/shutting down/rebooting my machines.

Grant Sinclair (sinclairgd) wrote :

I also think there are posts for different problems pointing at this bug. I followed one of them here and added my name to the list. But now I too am not sure of this and have removed myself as being affected by it.

Here are my experiences, in case they help. I have a Core 2 Duo desktop and a GeForce GTX 640 SE video card. I initially performed a clean 13.04 64 bit install, with no encryption and no LVM. I used the NVidia driver (310 in my case, since that's the one labelled "tested") as the Nouveau driver seemed to cause system instability. I had problems with hanging, both on restart and shut down about as often as Thomas above. Sometimes, when the system failed to shut down, I had the mount errors but sometimes it would hang without them. The system was otherwise stable.

I then reinstalled Ubuntu, this time as 32 bit, just to see what happened. I was able to stay with the Nouveau driver as I had no system instability with it under 32 bit. I did not see any umount/mount errors but less logging to the screen seems to occur with the Nouveau driver, so perhaps I was getting them but was unaware of it. I had no restart/shutdown problems at all. Using the system under this configuration was great - everything seemed to "just work".

I have now tried the NVidia driver (310 again), just to see what happened with it under 32 bit. I find that under 32 bit Ubuntu, it is the NVidia driver causing system instability (reverse of my 64 bit situation), to the point where the system is not really stable enough to use. I have also experienced one hung shutdown attempt (my first since going 32 bit). I also saw cases of the umount/mount errors, though as I said above, perhaps they were also there under Nouveau but just not visible.

I also experience shutdown hanging.

In case this helps, this is what I see upon shutdown:

      Ubuntu 13.04
          . . . . [OK]
* Killing all remaining processes... [fail]
nm-dispatcher.action: Caught signal 15, shutting down...
* Deactivating swap... [OK]
umount: /run/lock: not mounted
umount /run/shm: not mounted
mount: / is busy
* Will now halt

64 bit, nvidia-304 driver (that's what nvidia-current installs)

David Kennedy (dayv227) wrote :

I am experiencing the same errors and hanging on shutdown.

Ubuntu 13.04 64-bit

I am also experiencing this issue.

I recommend that everyone who is experiencing this to enable the proposed repository in software sources. A new kernel just arrived with lots of upstream fixes from Linux 3.8.11 which I hope will solve the issue. I am going to test this one out.

Grant Sinclair (sinclairgd) wrote :

Thanks Robert, I've done a clean install of Ubuntu 13.04 64 bit and performed something like 30 shut down and restarts. I was delighted to see that there was no hanging on shutdowns or restarts at all - not even once!

Along the way, I tried the default Nouveau driver, and the nvidia-310 and -313 drivers. There were no mount/unmount messages displayed under the Nouveau driver (though it's possible they occurred and just weren't displayed on the screen). I had mount/unmount messages just about every time under the nvidia-310 and 313 drivers.

I have not tried to use the machine for anything else, so I don't know whether the new patches have introduced any new usability issues. I'll leave it on the Nouveau driver and use it for a few days and see how it goes.

It will be interesting to see how others get on.

Thanks again.

David Kennedy (dayv227) wrote :

Using the proposed repository as Robert suggested seems to have fixed the issue for me as well. Thanks!

Indeed, it appears fixed using the latest kernel from proposed. If it shuts down and boots cleanly everytime for me and other people then it is finally useable. As long as root unmounts cleanly during shutdown and does not cause corruption we are good.

Hopefully there are no other regressions introduced.

RichB (trash1464) wrote :

I have been fighting this problem for a while, applying the latest patches and kernel updates only made the system so unstable it was unusable.

Booting the base image from a USB startup disk, the system booted up and shutdown without error. That being the case, I did a complete reinstall, formatting the OS partitions. The system is now stable with error free boot and shutdown operations. The display driver in use is the Nouveau which was installed by default. By having /home on a seperate spindle, all data was preserved without loss. Like Grant, I now am a happy camper.

Steve Langasek (vorlon) on 2013-05-28
summary: - umount error messages during shutdown
+ "mount: / is busy" error during shutdown
summary: - "mount: / is busy" error during shutdown
+ "mount: / is busy" error during shutdown (not network-manager)

I am having the same problem with Ubuntu 12.04.2 LTS and on every boot it tries to recover the root directory.

Linux version 3.2.0-45-generic (buildd@panlong) (gcc version 4.6.3 (Ubuntu/Linar
o 4.6.3-1ubuntu5) ) #70-Ubuntu SMP Wed May 29 20:12:06 UTC 2013

ii initscripts 2.88dsf-13.10u

Steve Dodd (anarchetic) wrote :

Pretty sure I'm seeing this reliably on up-to-date saucy. No noticeable delay on shutdown, but a "mount: / is busy" error on the console and an unclean mount/journal replay on the next boot. Got to run now but open to any suggestions on how to debug..

Steve Dodd (anarchetic) wrote :

The patch from bug #1169614 has removed dhclient's lease file from the list of files open for writing at the end of runlevel 0 for me. upstart still has a log file for ureadahead open, though..

Roger Kauffman (roger-edna) wrote :

I am running 13.04 64 bit and using the GeForce GT430/PCle/SSe2 Nvidia driver. I am also experiencing the Hang on shutdown with messages relating to "busy" mount.

I have also installed the Linux 3.9.0-030900rc8-generic (x86_64) kernel which does not solve the hanging problem.

My install started out as an upgrade and finished up as a clean install after several problems.

The following is a snapshot of my system:

-Computer-
Processor : 4x Intel(R) Core(TM)2 Quad CPU Q6600 @ 2.40GHz
Memory : 3980MB (1038MB used)
Operating System : Ubuntu 13.04
User Name : roger (Roger Kauffman)
Date/Time : Mon 01 Jul 2013 16:31:03 EST
-Display-
Resolution : 1920x1080 pixels
OpenGL Renderer : Unknown
X11 Vendor : The X.Org Foundation
-Multimedia-
Audio Adapter : HDA-Intel - HDA Intel
Audio Adapter : HDA-Intel - HDA NVidia
Audio Adapter : USB-Audio - USB Device 0x46d
-Input Devices-
 Sleep Button
 Power Button
 HID Keyboard Device
 HID Keyboard Device
 PIXART USB OPTICAL MOUSE
 HDA Intel Line
 HDA Intel Rear Mic
 HDA Intel Front Mic
 HDA Intel Front Headphone
 HDA Intel Speaker CLFE
 HDA Intel Speaker Surround
 HDA Intel Speaker Front
 HDA NVidia HDMI/DP,pcm : 9=
 HDA NVidia HDMI/DP,pcm : 8=
 HDA NVidia HDMI/DP,pcm : 7=
 HDA NVidia HDMI/DP,pcm : 3=
 gspca_zc3xx
-Printers (CUPS)-
Brother-HL-3070CW-series : <i>Default</i>
-SCSI Disks-
ATAPI iHAS324 B
PIONEER DVD-RW DVR-215
ATA ST31000524AS
ATA ST3320620AS
Generic- Compact Flash
Generic- SM/xD-Picture
Generic- SD/MMC
Generic- MS/MS-Pro

Obviously i would appreciate any help you may be able to give.

David Kennedy (dayv227) wrote :

This issue reappeared in spite of the fact that I had the proposed updates enabled. Shutdown and suspend started working again when I changed my NVIDIA driver from nvidia-313-updates (proprietary) to nvidia-310 (proprietary, tested).

Maybe it was just a happy coincidence. Either way, I'm glad it's working now.

Steve Dodd (anarchetic) wrote :

For the record: the patches in bug #1181789 (for upstart) and bug #1169614 (for network-manager) solved my saucy shutdown problems, and at least one of these has fixed a problem in raring, too.

David Matějček (dmatej) wrote :

My experiments:
0) With 12.10 everything worked perfectly.
1) 13.04, upgraded from 12.10. Since then I cannot sleep, hibernate, or shutdown my computer. After some hard resets system starts without the X-server, sometimes with.
2) Uninstalled modem-manager, no change (except no error message about that).
3) Since I changed nvidia-304-updates to nvidia-313-updates, computer was turned off properly, but only for the first time. 310-updates - same problem.
4) Clean install of 13.04 on another partition, no nvidia driver. Tried to suspend(sleep), it worked, but after wake up the screen was only blank and I had to do hard reset again.
5) Now I am on my old partition and I have no sound. It seems there is something wrong not in nvidia, but in kernel and it is somehow related to drivers (nvidia, modem, sound, hdd ...?). And it is not fully repeatable, maybe some race condition? Is / unmounted really after all unneeded applications and drivers are stopped?

Felix Deichmann (jility09) wrote :

I also have this problem on Acer Aspire V5 573G with Ubuntu 13.04 (64bit) + Gnome 3.6.3 + nvidia-325 + kernel 3.11
tried different nvidia drivers, kernels, etc

I only have this on shutdown
umount: /run/lock: not mounted
umount /run/shm: not mounted
* Will now halt

but not mount: / is busy

suggestions?

Felix Deichmann (jility09) wrote :

after will now halt i do have something additionally

umount: /run/lock: not mounted
umount /run/shm: not mounted
* Will now halt
[ 301.609817] mei_me 0000:00:16: stop
[ 301.612052] reboot: Power down

David Matějček (dmatej) wrote :

I have uninstalled nvidia driver, but the problem is same with some small changes:
- suspend and hibernate does not hang, but ends up only in login screen
- shutdown hangs again with mount: / is busy, but not always. Some attempts were successful.

Now I see also this message when trying to suspend the computer and than shutdown:
udevd timeout: killing /sbin/modprobe -bv pci
This is reported here: https://bugs.launchpad.net/ubuntu/+source/udev/+bug/1092102

Maybe this bug depends on some ACPI event?

David Matějček (dmatej) wrote :

1) Today I have changed the file /etc/default/grub:
GRUB_CMDLINE_LINUX_DEFAULT="acpi=force reboot=acpi"
2) run update-grub2
Now I can sleep and shutdown! :-) :-) :-)
The error message "/ is busy" is still there, but computer turns off right after that.

David Matějček (dmatej) wrote :

... but it worked only twice, I don't understand why. Next three attempts ended as usual: "busy" and hang :(

Steve Langasek (vorlon) wrote :

This is most likely the same bug as #1181789, which was supposed to get an SRU into raring and hasn't yet. I'll nudge that along.

David Matějček (dmatej) wrote :

The last message from me - now everything works.
After all steps before finally I did this:
1) Removed the TV card Winfast DTV2000H, that was unused maybe two years and I forgot it is there :-) . Seems that something between the Linux and the card does not handle the ACPI events correctly.
Then I could sleep the computer, but not wake up - sometimes absolutly, sometimes it started into KDE login screen, could move with mouse, but could not write anything.
2) Upgraded kernel, now uname -a writes this:
Linux dmatej 3.8.0-31-generic #46-Ubuntu SMP Tue Sep 10 20:03:44 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
- then I could switch to another session via CTRL+ALT+F1, kill KDE and start again - sometimes it worked after three cycles of killing.
3) Installed the nvidia-current-updates package again (3.0.4). It is three days and everything works as I want. Happyend :-)

I think in my case problems was caused by several reasons, somehow related. I wrote this only to report that my problem is solved and how.

This issue is probably duplicate as the previus comment says. See https://bugs.launchpad.net/ubuntu/+source/upstart/+bug/1181789

Nikolay Morozov (nmorozov) wrote :

afecting this 14.04 beta 64bit on Dell D430 laptop

tags: added: thrusty
tags: added: trusty
removed: thrusty
Nikolay Morozov (nmorozov) wrote :

intel video no nvidia

Nikolay Morozov (nmorozov) wrote :

nothing helps

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers