umount: /run/(lock|shm): not mounted

Bug #1097321 reported by Sworddragon on 2013-01-08
46
This bug affects 9 people
Affects Status Importance Assigned to Milestone
sysvinit (Ubuntu)
Medium
Shmearl

Bug Description

I'm using Ubuntu 13.04 dev with mountall 2.46 and shuting down or rebooting the system I'm seeing ~1 second before the system shuts down the 2 messages "umount: /run/lock: not mounted" and "umount: /run/shm: not mounted".

Steve Langasek (vorlon) wrote :

This probably comes from /etc/init.d/umountroot, in the initscripts package. Could you check whether commenting out the 'umount -l /var/lock' and 'umount -l /dev/shm' lines cause the errors to go away?

affects: mountall (Ubuntu) → sysvinit (Ubuntu)
Changed in sysvinit (Ubuntu):
status: New → Incomplete
Sworddragon (sworddragon) wrote :

After commenting the lines "umount -l /var/lock || true" and "umount -l /dev/shm || true" the errors doesn't appear anymore.

Changed in sysvinit (Ubuntu):
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in sysvinit (Ubuntu):
status: New → Confirmed
Thomas (tom-rosary) wrote :

Same for me. Using 12.04.2 with an encrypted home folder.
Last week I changed my crypted swap to a usual swap for being able to use hibernate. After that I realised it the first time.

Thomas (tom-rosary) on 2013-02-26
Changed in sysvinit (Ubuntu):
assignee: nobody → Thomas (tom-rosary)
assignee: Thomas (tom-rosary) → nobody
Steve Langasek (vorlon) on 2013-04-20
Changed in sysvinit (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
Shmearl (shmearl) on 2013-05-03
Changed in sysvinit (Ubuntu):
assignee: nobody → Matthias Kremeyer (matthias-kremeyer)
Steve Langasek (vorlon) on 2013-05-17
Changed in sysvinit (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (31.3 KiB)

This bug was fixed in the package sysvinit - 2.88dsf-41ubuntu1

---------------
sysvinit (2.88dsf-41ubuntu1) saucy; urgency=low

  * Merge from Debian unstable:
    - fixes typo in /lib/init/vars.sh. LP: #1146047.
  * Remaining changes:
    - Remove various initscripts (and an ifupdown hook) that have been
      replaced by upstart jobs shipped in other packages.
    - debian/sysvinit-utils.links: Compat symlink from /usr/bin/service to
      /usr/sbin/service
    - If /var/run/init.upgraded exists, call telinit u before unmounting
      the root filesystem.
    - Support Cell processor:
      + debian/initscripts.postinst: Create spu system group and /spu mount
        point if we are running on a Cell processor.
      + debian/control: Add initscripts dependency 'passwd' for groupadd.
    - debian/patches/91_sulogin_lockedpw.dpatch: Disable "root account is
      locked" warning, since this is the default in Ubuntu. Document this in
      sulogin.8.
    - debian/patches/92_sulogin_support_static_sh.patch: add support for
      /bin/static-sh as fallback if the regular shell fails to execute
    - debian/control: Drop Essential: yes from packages since we use Upstart.
    - debian/control: Do not build the sysvinit binary package any more. It
      conflicts with upstart, which is required, so it is uninstallable.
    - remove debian/postinst: this is supposed to go into the sysvinit
      package in Debian, but we don't ship that.
    - debian/control: sysvinit-utils recommends the upstart that provides
      the reload action
    - Mark all binary packages as Multi-Arch: foreign to allow for upstart
      to be installable with multi-arch (needed for armhf containers on x86)
    - Add a versioned depends to initscripts of mountall (>= 2.28), since
      everything else depends on initscripts for /run and the boot-time
      implementation is in mountall for us.
    - Drop /etc/default/tmpfs, and drop mention of it from
      debian/src/initscripts/man/rcS.5.
    - Added debian/src/initscripts/etc/init.d/ondemand: Sleep for 60 seconds,
      then set CPU Frequency Scaling governor to "ondemand" (or to
      "interactive" on systems that support it).
    - Remove mention of RAMLOCK, RAMSHM, and RAMTMP from the rcS(5) manual
      page.
    - When /dev/shm and /run/shm are both directories (not mounts), make
      /dev/shm a symlink to /run/shm.
    - d/service/service: Use 'stop/start' instead of passing restart
      directly through to upstart.
    - d/service/service.8: Document handling of upstart jobs.
    - Fix documentation for other things handled by mountall instead of
      initscripts: tmpfs, /sys (mountall lets you specify options in
      /etc/fstab), and ASYNCMOUNTNFS.
    - debian/src/initscripts/etc/init.d/sendsigs:
      + sendsigs: OMITPIDS needs to be reinitalized for every loop iteration
        before concatenating pids of upstart jobs to it.
      + only omit jobs that are in the 'start' goal or that are in state
        'stop/killed'. Those that are destined for 'stop' are waited on and
        killed like all other processes.
      + make report_unkillable use apport instead of echoing to console; but
        disable...

Changed in sysvinit (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers