FFe: please sync systemtap 1.3-1 from experimental to maverick

Bug #645200 reported by Nicolas Dechesne on 2010-09-22
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
systemtap (Ubuntu)
Undecided
Unassigned

Bug Description

The current package in maverick is incompatible with the kernel shipped in maverick, as such the package is fundamentally broken.

< lool> apparently there was an incompatible change in the tracing interface of the kernel
< lool> basically the current version doesn't work with .35 kernels which is what we have in maverick; the new version is confirmed as fixed

systemtap v1.3 is adding support for kernel up to 2.6.35-rc4, whereas 1.2 which is actually in the archive, supports up to 2.6.34.

1.3 is available in deiban experimental.

we are seeing problems with 10.10 daily image on OMAP4. it used to work with .34 kernel, we are still investigating if the problems are related to systemtap version or with our scripts, but I am opening this bug to open the discussion.

will report the testing with debian experiemental in the coming hours.

Nicolas Dechesne (ndec) wrote :

@steeve: thx for quick answer. feel free to contact Xavier Boudet if you need and for the testing.

Nicolas Dechesne (ndec) wrote :

@ogra, @lool: with debian experimental 1.3 systemtap, we are able to compile our scripts again. so the problem is really related to systemtap incompatibilities with .35 kernel. it's probably broken on x86 too... we had to pull the following .deb from debian:

systemtap-common_1.3-1_all.deb
systemtap-runtime_1.3-1_armel.deb
systemtap_1.3-1_armel.deb

they are all generated from the systemtap source package.

can you pull this into 10.10?

the package currently has no ubuntu changes and it should be possible to just sync it right away from experimental. the above descritption and tests justify a freeze exception i think (since we ship a 2.6.35 kernel in maverick).

summary: - System 1.3 adds supports for 2.6.35 kernel
+ please sync systemtap 1.3 from debian experimental
Paul Sladen (sladen) on 2010-09-22
summary: - please sync systemtap 1.3 from debian experimental
+ FFe: please sync systemtap 1.3-1 from experimental
summary: - FFe: please sync systemtap 1.3-1 from experimental
+ FFe: please sync systemtap 1.3-1 from experimental to maverick
Changed in systemtap (Ubuntu):
milestone: none → ubuntu-10.10
status: New → Triaged
description: updated
Scott Kitterman (kitterman) wrote :

Ack. FFe approved.

Please don't set FFe requests to Confirmed/Triaged. We use the status to track which ones need review and confirmed is meant to mean approved.

Changed in systemtap (Ubuntu):
status: Triaged → Confirmed
tags: added: omap4
Loïc Minier (lool) on 2010-09-23
tags: removed: omap4
tags: removed: armel
Jamie Strandboge (jdstrand) wrote :

[Updating] systemtap (1.2-1 [Ubuntu] < 1.3-1 [Debian])
 * Trying to add systemtap...
2010-09-24 15:51:13 INFO - <systemtap_1.3-1.dsc: downloading from http://ftp.debian.org/debian/>
2010-09-24 15:51:13 INFO - <systemtap_1.3-1.debian.tar.gz: downloading from http://ftp.debian.org/debian/>
2010-09-24 15:51:13 INFO - <systemtap_1.3.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
I: systemtap [universe] -> systemtap_1.2-1 [universe].
I: systemtap [universe] -> systemtap-common_1.2-1 [universe].
I: systemtap [universe] -> systemtap-runtime_1.2-1 [universe].
I: systemtap [universe] -> systemtap-doc_1.2-1 [universe].
I: systemtap [universe] -> systemtap-server_1.2-1 [universe].
I: systemtap [universe] -> systemtap-client_1.2-1 [universe].
I: systemtap [universe] -> systemtap-sdt-dev_1.2-1 [universe].
I: systemtap [universe] -> systemtap-grapher_1.2-1 [universe].

Changed in systemtap (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers