Feature request to enable systemtap on ubuntu 14.04.04.

Bug #1511347 reported by bugproxy on 2015-10-29
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
systemtap (Ubuntu)
Medium
Steve Langasek
Trusty
Medium
Steve Langasek

Bug Description

systemtap package was absent from the ubuntu 14.04.03 repos. This is a feature request to include systemtap in ubuntu 14.04.04.

bugproxy (bugproxy) on 2015-10-29
tags: added: architecture-ppc64le bugnameltc-131220 severity-high targetmilestone-inin14044
Changed in ubuntu:
assignee: nobody → Taco Screen team (taco-screen-team)

Thank you for taking the time to report this bug and helping to make Ubuntu better. It seems that your bug report is not filed about a specific source package though, rather it is just filed against Ubuntu in general. It is important that bug reports be filed about source packages so that people interested in the package can find the bugs about it. You can find some hints about determining what package your bug might be about at https://wiki.ubuntu.com/Bugs/FindRightPackage. You might also ask for help in the #ubuntu-bugs irc channel on Freenode.

To change the source package that this bug is filed about visit https://bugs.launchpad.net/ubuntu/+bug/1511347/+editstatus and add the package name in the text box next to the word Package.

[This is an automated message. I apologize if it reached you inappropriately; please just reply to this message indicating so.]

tags: added: bot-comment
Steve Langasek (vorlon) wrote :

The attached patch is sufficient to let the systemtap package build on ppc64el in Ubuntu 14.04. Can anyone confirm if systemtap 2.3 upstream includes support for ppc64el?

affects: ubuntu → systemtap (Ubuntu)
Changed in systemtap (Ubuntu):
assignee: Taco Screen team (taco-screen-team) → Steve Langasek (vorlon)
importance: Undecided → Medium
milestone: none → ubuntu-14.04.4
status: New → Incomplete
Changed in systemtap (Ubuntu Trusty):
status: New → Incomplete
Changed in systemtap (Ubuntu):
status: Incomplete → Fix Released
Changed in systemtap (Ubuntu Trusty):
assignee: nobody → Steve Langasek (vorlon)
milestone: none → ubuntu-14.04.4
Changed in systemtap (Ubuntu):
milestone: ubuntu-14.04.4 → none
Changed in systemtap (Ubuntu Trusty):
importance: Undecided → Medium

------- Comment From <email address hidden> 2015-11-23 08:51 EDT-------
(In reply to comment #5)
> The attached patch is sufficient to let the systemtap package build on
> ppc64el in Ubuntu 14.04. Can anyone confirm if systemtap 2.3 upstream
> includes support for ppc64el?

Upstream systemtap 2.3 does not include support for ppc64le. Hemant is putting together a patch that enables ppc64le support in systemtap 2.3

------- Comment (attachment only) From <email address hidden> 2016-01-06 06:15 EDT-------

------- Comment (attachment only) From <email address hidden> 2016-01-06 06:16 EDT-------

------- Comment (attachment only) From <email address hidden> 2016-01-06 06:17 EDT-------

Steve Langasek (vorlon) on 2016-01-06
Changed in systemtap (Ubuntu Trusty):
status: Incomplete → Triaged
Steve Langasek (vorlon) wrote :

Thanks for these patches. Can you please also describe a simple test case we can run to confirm that the new package is working as intended?

Hello bugproxy, or anyone else affected,

Accepted systemtap into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/systemtap/2.3-1ubuntu1.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in systemtap (Ubuntu Trusty):
status: Triaged → Fix Committed
tags: added: verification-needed

------- Comment From <email address hidden> 2016-01-08 09:16 EDT-------
Tested systemtap from trusty-proposed and it seems to work.

System tap version :
# stap --version
Systemtap translator/driver (version 2.3/0.158, Debian version 2.3-1ubuntu1.3 (trusty))
Copyright (C) 2005-2013 Red Hat, Inc. and others
This is free software; see the source for copying conditions.
enabled features: AVAHI LIBSQLITE3 NSS TR1_UNORDERED_MAP NLS

Here is how I tested :
For uprobes :
# cat test_prog.c

#include <stdio.h>

void foo(void)
{
printf("Inside foo\n");
}
int main(void)
{
return foo();
}

# gcc test_prog.c -g -o test_prog

# stap -ve 'probe process("./test_prog").function("foo") { printf("hit\n"); }' -c ./test_prog
Pass 1: parsed user script and 95 library script(s) using 42112virt/32064res/5952shr/25344data kb, in 150usr/30sys/181real ms.
Pass 2: analyzed script: 2 probe(s), 0 function(s), 0 embed(s), 0 global(s) using 42880virt/33920res/6720shr/25984data kb, in 0usr/0sys/7real ms.
Pass 3: translated to C into "/tmp/stapT5MpEn/stap_712b2bd0a7f7d10866d5e1187590250b_1091_src.c" using 66560virt/35072res/7744shr/26112data kb, in 20usr/170sys/193real ms.
Pass 4: compiled C into "stap_712b2bd0a7f7d10866d5e1187590250b_1091.ko" in 6730usr/1710sys/8514real ms.
Pass 5: starting run.
Inside foo
hit

This shows that it hits the probe point "foo". I also verified the address and found that it places the probe at intended location which is at the Local Entry Point of "foo".

Similarly, to test kprobes :
# stap -ve 'probe kernel.function("do_fork") { printf("hit\n"); }'

And it showed "hit" upon executing a program from shell. Please note that kernel debuginfo (debugsym) package is needed to test kprobes.

So, from the above tests it looks like systemtap is able to put the probes at the right places.

tags: added: verification-done
removed: verification-needed
Steve Langasek (vorlon) wrote :

Bug #1537125 has been filed separately showing that systemtap does not work with the 14.04.4 kernel (Linux 4.2). Unfortunately, the tests shown there weren't included as part of the test case for this SRU, but should have been.

The systemtap test suite can't be run on a buildd because of its intrusiveness. It should be included as an autopkgtest for this package.

tags: added: verification-failed
removed: verification-done
bugproxy (bugproxy) on 2016-01-25
tags: added: verification-done
removed: verification-failed
Steve Langasek (vorlon) wrote :

Per discussion on bug #1537125, it is still useful to have systemtap on ppc64el for trusty compatible with older kernels.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package systemtap - 2.3-1ubuntu1.3

---------------
systemtap (2.3-1ubuntu1.3) trusty; urgency=medium

  * debian/patches/0001-Fix-dwarfless-probes.patch,
    debian/patches/0002-Test-dwarfless-probes.patch:
    debian/patches/0003-prioritze-symbol-table-lookup-for-ppc64le.patch:
    backport of architecture support for ppc64el. LP: #1511347.

systemtap (2.3-1ubuntu1.2) trusty; urgency=medium

  [ Chris J Arges ]
  * Build ppc64el architecture (LP: #1513227).

  [ Dimitri John Ledkov ]
  * Now that systemtap-sdt-dev is arch:all, it also needs to be
    Multi-Arch:foreign to unbreak cross-builds (otherwise M-A:same ->
    A:all dep, tries to pull A:any).

 -- Steve Langasek <email address hidden> Wed, 06 Jan 2016 16:35:38 -0800

Changed in systemtap (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for systemtap has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers