sidebar view - second subcategory list you navigate to has incorrect colors for the top entry

Bug #1766652 reported by Rik Mills
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Systemsettings
Fix Released
Medium
systemsettings (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

From upstream KDE bug report:

This issue was discovered during Kubuntu 18.04 beta testing, and I as well as several others were all able to reproduce it.

Steps to reproduce:
1. Install Kubuntu 18.04 beta or nightly, or boot into a live session (http://cdimage.ubuntu.com/kubuntu/daily-live/current/)
2. Open System Settings
3. make the window wide such that the subcategory list will be visible
4. Click on Workspace Theme
4. Then click on Application Style

The first item in the subcategory list has no selection color and no text color. It appears invisible save for the icon. You can still navigate there, it just doesn't look like it.

Reproducibility:
- Unable to reproduce in Kubuntu 17.10 with Plasma 5.12.4 from the Kubuntu backports PPA
- Reproduces for other subcategory lists, too. The first one you click on looks fine, then any subsequent ones exhibit the bug.
- The colors return if you click on a main category list bold header.
- Reproduces with all look-and-feel packages shipped on the live ISO (Breeze, Breeze Dark, and Kubuntu).
- Reproduces with all color schemes.

**** end ****

Note: this also occurs in fedora, and other cases building from upstream git

Revision history for this message
In , Nate-b (nate-b) wrote :

Created attachment 111858
Screen recording depicting the issue

This issue was discovered during Kubuntu 18.04 beta testing, and I as well as several others were all able to reproduce it.

Steps to reproduce:
1. Install Kubuntu 18.04 beta or nightly, or boot into a live session (http://cdimage.ubuntu.com/kubuntu/daily-live/current/)
2. Open System Settings
3. make the window wide such that the subcategory list will be visible
4. Click on Workspace Theme
4. Then click on Application Style

The first item in the subcategory list has no selection color and no text color. It appears invisible save for the icon. You can still navigate there, it just doesn't look like it.

Screen recording attached.

Reproducibility:
- Unable to reproduce in Kubuntu 17.10 with Plasma 5.12.4 from the Kubuntu backports PPA
- Reproduces for other subcategory lists, too. The first one you click on looks fine, then any subsequent ones exhibit the bug.
- The colors return if you click on a main category list bold header.
- Reproduces with all look-and-feel packages shipped on the live ISO (Breeze, Breeze Dark, and Kubuntu).
- Reproduces with all color schemes.

Revision history for this message
In , G-scott-1 (g-scott-1) wrote :

Same here, with Plasma 5.12.80 and KF 5.45, compiled from git yesterday.

Revision history for this message
In , Rik Mills (rikmills) wrote :
Revision history for this message
In , Cfeck (cfeck) wrote :

*** Bug 392547 has been marked as a duplicate of this bug. ***

Changed in systemsettings:
importance: Unknown → Medium
Revision history for this message
In , Cfeck (cfeck) wrote :

*** Bug 395176 has been marked as a duplicate of this bug. ***

Revision history for this message
In , Marco Martin (notmart) wrote :

does this still happen with Kirigmai master from 20th july 2018 or more recent?

Revision history for this message
In , Nate-b (nate-b) wrote :

Nope, seems fixed now. Thanks!

Changed in systemsettings:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.