The airplane hotkey has no function on a HP platform

Bug #1955997 reported by jeremyszu
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
Fix Released
Critical
jeremyszu
systemd (Ubuntu)
Fix Released
Undecided
Unassigned
Focal
Fix Released
Undecided
Unassigned
Impish
Fix Released
Undecided
Unassigned
Jammy
Fix Released
Undecided
Unassigned

Bug Description

[Impact]
The airplane hokey doesn't work on HP new generation machines.

[Test Plan]
Press airplane hokey.

Before the patch, nothing happens.
After the patch, the rfkill works as expected.

In some old HP platforms (contains Intel-HID and HPQ6001 in same machine), the user will aware the airplane mode toggled very quickly e.g. turn-on and turn-off immediately (or works good without problem, depends on how DM handles multiple rfkill events).

In this case, you could check:
1. sudo evtest
# You probably could see
# ...
# /dev/input/event8: Intel HID events
# ...
# /dev/input/event11: Wireless hotkeys
# or "HP Wireless hotkeys" depends on your kernel version

2. try to listen these events when pressing airplane key, you will probably see these two events will send the keycode out.

3. check the components own this event
$ sudo udevadm info -a /dev/input/event11
# ...
# ATTRS{phys}=="hpq6001/input0"

$ sudo udevadm info -a /dev/input/event8
# ...
# DRIVERS=="intel-hid"

4. check your hwdb is affect.
$ grep -rn "Intel HID" /lib/udev/hwdb.d/60-keyboard.hwdb
# If you didn't see anything then it means your intel-hid is unmask.

5. You could report a bug to your DM for dealing with two rfkill events (same as g-s-d[3]). Before your DM solves this issue, you could mask intel-hid as workaround (but it will be overwritten in next upgrade) by adding:
```
evdev:name:Intel HID events:dmi:bvn*:bvr*:bd*:svnHP*:pn*:pvr*
```
to /lib/udev/hwdb.d/60-keyboard.hwdb

then
$ systemd-hwdb update
$ udevadm trigger

[Where problems could occur]
In non-gnome ubuntu, if the specific dmi contains HPQ6001, then airplane will not work but HP confirmed the new HP generation won't contain the HPQ6001 and also each DM still need to deal with multi-rfkill events because upstream changes[2].

---

In the last year, HP mentions HP machines need to use hp-wireless (HPQ6001) as the rfkill source[1].

However, HP confirms the HPQ6001 has been retired in the platforms since 2022.

In the platforms after 2022, there are two sources of rkfill events (intel-hid, atkbd) and HP only guarantee the intel-hid works.
Therefore, the upstream already accept the patch[2] to unmask intel-hid and mention this big change in the NEWS.

This change makes the pre-2022 HP platforms meet the regression since they have two rfkill events (HPQ6001 and intel-hid) be triggered if pressing function key.
Thus, there is a patch[3] to make sure the GNOME could deal with this case smoothly.
However, the systemd change will still cause other DEs meet the regression (xfce, KDE, lxde, etc..).
Backport systemd change to make HP 2022 platforms work is not the best choice on stable version (focal in this case).

We still need a solution to make airplane key works on 2022 HP platforms (intel-hid and atkbd only).
The potential solution from my mind that is to maintain a whitelist to unmask intel-hid in ubuntu-patch in focal, something like:
```
evdev:name:Intel HID events:dmi:bvn*:bvr*:bd*:svnHP*:pnHPZBookFury16inchG9*:*
 KEYBOARD_KEY_8=wlan # Use hp-wireless instead
```
after "KEYBOARD_KEY_8=unkown".

[1] https://bugs.launchpad.net/bugs/1883846
[2] https://github.com/systemd/systemd/pull/20219
[3] https://gitlab.gnome.org/GNOME/gnome-settings-daemon/-/commit/f4dbcf3d7b0f951fe44b29229206c97b625dbfda

jeremyszu (os369510)
tags: added: oem-priority originate-from-1955457 stella
Changed in oem-priority:
assignee: nobody → jeremyszu (os369510)
importance: Undecided → Critical
status: New → In Progress
jeremyszu (os369510)
tags: added: originate-from-1955896
jeremyszu (os369510)
description: updated
Revision history for this message
jeremyszu (os369510) wrote :

btw, there is the other HP platform need the to be added in this whitelist but still confirming with HP about the correct dmi string.

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "lp1955997-add-a-whitelist-to-unblock-intel-hid-on-HP-machines.debdiff" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Revision history for this message
jeremyszu (os369510) wrote (last edit ):

This patch is for focal

New version which supporting for two HP new machines.

Please ignore comment#1. (deleted previous version - comment#1 to prevent confuse)
This patch contains the platform I mentioned on comment#3.

Changed in oem-priority:
status: In Progress → Triaged
Revision history for this message
Lukas Märdian (slyon) wrote :

What series is this needed for? Does it already work as expected in Jammy?

Revision history for this message
jeremyszu (os369510) wrote :

Hi Lukas,

The jammy and impish do have this issue and will be fixed in v250[1], FWIK, we will upgrade to v250 soon? let me know if you think I should still prepare the workaround for impish and jammy.

[1] https://github.com/systemd/systemd/pull/20219

Revision history for this message
Lukas Märdian (slyon) wrote :

Okay, so the current patch is for Focal? Please also provide debdiffs for Jammy and Impish, as we'll stick with v249 (in Jammy) for the LTS and Impish will not see a systemd update either. We need to fix it in Jammy first, before we can start SRUing the change.

jeremyszu (os369510)
Changed in oem-priority:
status: Triaged → In Progress
Revision history for this message
jeremyszu (os369510) wrote :

Based on the discussion on https://chat.canonical.com/canonical/pl/ywmmrm9d9j8cdkcwbyx6rkwqgh.

We will solve this issue by
1) maintain a whitelist on focal and impish
2) backport unmast intel-hid[1] on jammy

[1] https://github.com/systemd/systemd/pull/20219

Revision history for this message
jeremyszu (os369510) wrote :

This patch is for impish.
Verified pass on both HP new platforms.

Revision history for this message
jeremyszu (os369510) wrote :

for jammy, and verified pass on both platforms.

BTW, for jammy.

The intel-hid driver doesn't load probably caused by acpi device not found or other kernel/driver related issue.
FWIK, 5.13 is not final kernel for jammy.
I tried this patch with 5.14.0-oem-1018 kernel and it works as expected.

Changed in oem-priority:
status: In Progress → Confirmed
jeremyszu (os369510)
Changed in oem-priority:
status: Confirmed → Triaged
Lukas Märdian (slyon)
Changed in systemd (Ubuntu Jammy):
status: New → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package systemd - 249.9-0ubuntu2

---------------
systemd (249.9-0ubuntu2) jammy; urgency=medium

  * Skip flaky 55-OOMD test on ppc64el
    File: debian/patches/deny-list-TEST-55-OOMD-on-ppc64el.patch
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=211f8962ce89d416c2866444e0e2da794ecd5dd1

 -- Lukas Märdian <email address hidden> Fri, 28 Jan 2022 10:46:41 +0100

Changed in systemd (Ubuntu Jammy):
status: In Progress → Fix Released
Revision history for this message
Lukas Märdian (slyon) wrote :

Thank you for providing the "safe" patches for the stable series, implementing an allowlist instead of following the upstream change.

I've updated the wording a bit on the patch to account for a "whitelist" -> "allowlist" rename, other than that those LGTM!

I've uploaded the package into impish (this is awaiting SRU review):
https://launchpad.net/ubuntu/impish/+queue?queue_state=1

For focal I've staged the changes, as there is more to be added to the next focal upload:
https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?h=ubuntu-focal&id=88a859eaddb6c9a611fcbc44edab441aef4c4355

Changed in systemd (Ubuntu Impish):
status: New → In Progress
Changed in systemd (Ubuntu Focal):
status: New → In Progress
Revision history for this message
Robie Basak (racb) wrote :

Is there a risk here that on other desktop environments on Ubuntu, there will be a duplicate event that will not be debounced, and therefore regress users? I'm not sure if this is what you're already stating in "Where problems could occur". If this is a risk, then could you include it in your Test Plan please? If not, then maybe I misunderstand why and I would appreciate clarification.

Revision history for this message
jeremyszu (os369510) wrote :

Hi Robie,

I think we are talking about Jammy as comment#11.
and yes, as I mentioned in "Where problems could occur":
>also each DM still need to deal with multi-rfkill events because upstream changes[2].

From what I learned from HP, there are some old platforms have both Intel-HID and HPQ6001 components but I don't have the one in my side.

I have
1. HPQ6001 HP laptop
2. Intel-HID HP laptop

I shared what I can imaged when problems will occur, some check points and workaround in the bug description.
Hope it can cover what you concerning.

description: updated
Revision history for this message
Robie Basak (racb) wrote :

OK, so if this is the risk, then I think we should consider what mitigation might be appropriate at least.

There are many desktop environments packaged in Ubuntu, and some of them may regress. I'm not sure it's practical to test them all, especially if you don't have the hardware that might trigger the issue.

But perhaps we should at least contact the Ubuntu Flavors to see if they have any opinion, since they are directly spending effort maintaining some of those environments.

I'll send them an email so that they have an opportunity to comment. If they'd like to make suggestions on how to mitigate this risk then they can do that here. If they don't see any reason to object or make any suggestions then I'll accept this SRU.

Revision history for this message
jeremyszu (os369510) wrote :

Hi Robie,

Thanks for sharing the changes with other flavors.
Just want to clarify the comment#14-16 are talking about Jammy which shouldn't blocking Focal#5 and Impish#10 SRU.

Revision history for this message
Lukas Märdian (slyon) wrote :

Hi Robie, any update on this?

As Jeremy described earlier, we choose to implement the safe way for the SRUs by keeping an allow-list of supported devices, instead of switching over to the upstream solution.

Revision history for this message
Bill Yu (billchyu) wrote :

Hi Robie,

May we have your comment on this. Since we would like to have this solution in the latest kernel, need you help to check on this. Thank you.

Revision history for this message
Robie Basak (racb) wrote :

Sorry I'm having problems getting my email to them - it's stuck in moderation on the ubuntu-flavors@ ML. I have asked again to try and find who moderates it.

Revision history for this message
jeremyszu (os369510) wrote :

Hi Robie, Lukas,

As I mentioned on comment#17, impish and focal are using allowing-list to add two HP new products. I don't think it will cause the regression, could we please let impish and focal get the patch?

The unblock intel-hid is in Jammy and it's not yet release, we can negotiate it before Jammy release, does it makes sense?

Revision history for this message
Bill Yu (billchyu) wrote :

Hi Robie and Lukas,

From our understanding, the concern is only related to Jammy, not focal.
Is that OK to change to fix released on focal.
This is one of the blocking issue for Stella Magneta platform.
We need your help to comment on this. Thank you.

Revision history for this message
Bill Yu (billchyu) wrote :

@Robie and @Lukas

Sorry for pushing. May I have your comments on this. Thank you.

Andy Chi (andch)
tags: added: originate-from-1966014
tags: added: originate-from-1965898
tags: added: originate-from-1964913
Andy Chi (andch)
tags: removed: originate-from-1964913 originate-from-1965898 originate-from-1966014
Revision history for this message
Lukas Märdian (slyon) wrote :

I still agree that this should be landed as-is (cf. comment #18).
Also, I've just sponsored a new version of systemd for Impish, that contains this plus additional fixes.

Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello jeremyszu, or anyone else affected,

Accepted systemd into impish-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/systemd/248.3-1ubuntu8.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-impish to verification-done-impish. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-impish. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in systemd (Ubuntu Impish):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-impish
Revision history for this message
Brian Murray (brian-murray) wrote :

Hello jeremyszu, or anyone else affected,

Accepted systemd into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/systemd/245.4-4ubuntu3.16 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in systemd (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed-focal
Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (systemd/245.4-4ubuntu3.16)

All autopkgtests for the newly accepted systemd (245.4-4ubuntu3.16) for focal have finished running.
The following regressions have been reported in tests triggered by the package:

gvfs/1.44.1-1ubuntu1 (arm64, ppc64el, amd64)
linux-aws-5.13/5.13.0-1019.21~20.04.1 (arm64)
snapd/2.54.3+20.04.1ubuntu0.2 (arm64, ppc64el, s390x)
docker.io/20.10.7-0ubuntu5~20.04.2 (s390x)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/focal/update_excuses.html#systemd

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (systemd/248.3-1ubuntu8.4)

All autopkgtests for the newly accepted systemd (248.3-1ubuntu8.4) for impish have finished running.
The following regressions have been reported in tests triggered by the package:

systemd/248.3-1ubuntu8.4 (arm64, ppc64el)
debspawn/0.5.0-1 (s390x)
diaspora-installer/0.7.15.0+debian1 (s390x, arm64)
swupdate/2020.11-2 (ppc64el)
snapd/2.54.3+21.10.1ubuntu0.2 (s390x, ppc64el)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/impish/update_excuses.html#systemd

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

jeremyszu (os369510)
tags: added: verification-done verification-done-focal verification-done-impish
removed: verification-needed verification-needed-focal verification-needed-impish
Changed in oem-priority:
status: Triaged → Fix Committed
Revision history for this message
Nick Rosbrook (enr0n) wrote :

The autopkgtest regressions blocking systemd 245.4-4ubuntu3.16 in focal-proposed have been resolved. The regressions appear to have been related to recent autopkgtest infrastructure issues, and retrying the tests resolved the issues.

Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello jeremyszu, or anyone else affected,

Accepted systemd into impish-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/systemd/248.3-1ubuntu8.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-impish to verification-done-impish. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-impish. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-impish
removed: verification-done verification-done-impish
Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (systemd/248.3-1ubuntu8.4)

All autopkgtests for the newly accepted systemd (248.3-1ubuntu8.4) for impish have finished running.
The following regressions have been reported in tests triggered by the package:

systemd/248.3-1ubuntu8.4 (arm64, ppc64el)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/impish/update_excuses.html#systemd

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (systemd/248.3-1ubuntu8.5)

All autopkgtests for the newly accepted systemd (248.3-1ubuntu8.5) for impish have finished running.
The following regressions have been reported in tests triggered by the package:

snapd/2.54.3+21.10.1ubuntu0.2 (s390x, ppc64el, arm64, amd64)
casper/1.465 (amd64)
tpm2-abrmd/unknown (ppc64el)
corosync-qdevice/unknown (ppc64el)
nftables/unknown (ppc64el)
udisks2/2.9.4-1 (arm64)
diaspora-installer/0.7.15.0+debian1 (arm64, s390x)
systemd/248.3-1ubuntu8.5 (armhf)
swupdate/2020.11-2 (s390x)
munin/2.0.57-1ubuntu1 (arm64, amd64)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/impish/update_excuses.html#systemd

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Nick Rosbrook (enr0n) wrote :

The autopkgtest regressions blocking systemd 248.3-1ubuntu8.5 in impish-proposed have been resolved. The regressions were caused either by (1) network/infrastructure issues and succeeded on retry, or by (2) unrelated snapd regressions. The systemd 248.3-1ubuntu8.5 upload added an autopkgtest change for systemd to ignore failed snap mount units which are caused by unrelated snapd issues.

Given the nature of the 248.3-1ubuntu8.5 upload, the previous verification for 248.3-1ubuntu8.4 is still valid.

tags: added: verification-done-impish
removed: verification-needed-impish
Nick Rosbrook (enr0n)
tags: added: verification-done
removed: verification-needed
Revision history for this message
Brian Murray (brian-murray) wrote :

Please add some verification details in addition to changing the tag from v-needed to v-done. I'm setting this back to v-needed until a comment is made about the verification testing that was performed.

tags: added: verification-needed verification-needed-focal verification-needed-impish
removed: verification-done verification-done-focal verification-done-impish
Revision history for this message
jeremyszu (os369510) wrote :

Hi Nick and Brian,

When I verified this ticket,
I did upgrade systemd to proposed version on the target machines. (245.4-4ubuntu3.16 and 248.3-1ubuntu8.4)
I can see the airplane mode toggled when pressing the airplane function key.

I saw the targeted version now is "248.3-1ubuntu8.5".
Let me give it a try.

The 245.4-4ubuntu3.16 works on focal.

tags: added: verification-done-focal
removed: verification-needed-focal
Revision history for this message
Nick Rosbrook (enr0n) wrote :

Hi Jeremy,

Thank you for clarifying how you performed the verification testing. Since the 248.3-1ubuntu8.5 upload only contained an autopkgtest fix, your verification against 248.3-1ubuntu8.4 still stands.

tags: added: verification-done verification-done-impish
removed: verification-needed verification-needed-impish
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package systemd - 248.3-1ubuntu8.5

---------------
systemd (248.3-1ubuntu8.5) impish; urgency=medium

  * debian/tests/boot-and-services: Ignore failed snap mount units in test_no_failed (LP: #1967576)

systemd (248.3-1ubuntu8.4) impish; urgency=medium

  [ Lukas Märdian ]
  * Fix deadlock between pid1 and dbus-daemon (LP: #1871538)
    Author: Lukas Märdian
    File: debian/patches/pid1-set-SYSTEMD_NSS_DYNAMIC_BYPASS-1-env-var-for-dbus-da.patch
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=f79535077473902bad911dc2652a2fff4066fa30
  * Don't override Ubuntu's default sysctl values (LP: #1962038)
    Author: Lukas Märdian
    File: debian/patches/debian/UBUNTU-Don-t-override-Ubuntu-s-default-sysctl-values-LP-1962038.patch
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=3ba2764d8f77e616461c9722923f685fad79f8c6

systemd (248.3-1ubuntu8.3) impish; urgency=medium

  [ Jeremy Szu ]
  * Add a allowlist to unblock intel-hid on new HP machines (LP: #1955997)
    Author: Jeremy Szu
    File: debian/patches/lp1955997-add-a-allowlist-to-unblock-intel-hid-on-HP-mach.patch
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=554d46e6a6ab80befd424ead7ffa8e6f993b5f66

 -- Nick Rosbrook <email address hidden> Fri, 01 Apr 2022 16:39:25 -0400

Changed in systemd (Ubuntu Impish):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Update Released

The verification of the Stable Release Update for systemd has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package systemd - 245.4-4ubuntu3.16

---------------
systemd (245.4-4ubuntu3.16) focal; urgency=medium

  [ Dan Streetman ]
  * d/p/lp1946388-sd-journal-don-t-check-namespaces-if-we-have-no-name.patch:
    Avoid journalctl segfault (LP: #1946388)

  [ Jeremy Szu ]
  * Add a allowlist to unblock intel-hid on new HP machines (LP: #1955997)
    Author: Jeremy Szu
    File: debian/patches/lp1955997-add-a-allowlist-to-unblock-intel-hid-on-HP-mach.patch
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=88a859eaddb6c9a611fcbc44edab441aef4c4355

  [ Nick Rosbrook ]
  * Prevent arguments from being overwritten with defaults at shutdown (LP: #1958284)
    File: debian/patches/lp1958284-core-move-reset_arguments-to-the-end-of-main-s-finish.patch
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=e61052bd1f20bcc54e7417542c6d445cf5040f56

  [ Lukas Märdian ]
  * Fix deadlock between pid1 and dbus-daemon (LP: #1871538)
    Author: Lukas Märdian
    File: debian/patches/pid1-set-SYSTEMD_NSS_DYNAMIC_BYPASS-1-env-var-for-dbus-da.patch
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=e3aacfa26e3fc6df369e6f28e740389ae0020907

 -- Nick Rosbrook <email address hidden> Wed, 23 Mar 2022 09:29:33 -0400

Changed in systemd (Ubuntu Focal):
status: Fix Committed → Fix Released
jeremyszu (os369510)
tags: added: originate-from-1968990
jeremyszu (os369510)
Changed in oem-priority:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers