Activity log for bug #1890448

Date Who What changed Old value New value Message
2020-08-05 14:12:08 Kai-Heng Feng bug added bug
2020-08-05 14:13:01 Kai-Heng Feng bug added subscriber Canonical Hardware Enablement
2020-08-05 14:13:07 Kai-Heng Feng tags oem-priority originate-from-1883044 stella
2020-08-06 03:10:43 hugh chao bug added subscriber hugh chao
2020-08-07 15:24:44 Dan Streetman bug added subscriber Dan Streetman
2020-12-11 18:11:04 Dan Streetman description [Impact] Micmute hotkey on many HP EliteBooks don't work. [Fix] Commit b6eb208b29ae ("hwdb: Add EliteBook to use micmute hotkey"), to map AT keyboard's scancode to micmute hotkey. [Test] With the one-liner fix, micmute hotkey works on all the EliteBooks I tested. [Regression Potential] The hwdb originally only matches a few EliteBook, and fix changes that to match all EliteBook models. So if there's an EliteBook that uses the scancode for other purpose, there will be a regression. However, the risk is rather slim because HP is confident that all EliteBooks use the same scancode for mic mute hotkey. [Impact] Micmute hotkey on many HP EliteBooks don't work. [Fix] Commit b6eb208b29ae ("hwdb: Add EliteBook to use micmute hotkey"), to map AT keyboard's scancode to micmute hotkey. [Test] With the one-liner fix, micmute hotkey works on all the EliteBooks I tested. [Regression Potential] The hwdb originally only matches a few EliteBook, and fix changes that to match all EliteBook models. So if there's an EliteBook that uses the scancode for other purpose, there will be a regression. However, the risk is rather slim because HP is confident that all EliteBooks use the same scancode for mic mute hotkey. [scope] this is needed for f and earlier. this is fixed upstream by commit b6eb208b29ae which is included starting in v246, so g and later are already fixed.
2020-12-11 18:11:13 Dan Streetman nominated for series Ubuntu Bionic
2020-12-11 18:11:13 Dan Streetman bug task added systemd (Ubuntu Bionic)
2020-12-11 18:11:13 Dan Streetman nominated for series Ubuntu Focal
2020-12-11 18:11:13 Dan Streetman bug task added systemd (Ubuntu Focal)
2020-12-11 18:14:29 Dan Streetman systemd (Ubuntu): status New Fix Released
2020-12-11 18:14:34 Dan Streetman systemd (Ubuntu Bionic): assignee Dan Streetman (ddstreet)
2020-12-11 18:14:38 Dan Streetman systemd (Ubuntu Focal): importance Undecided Medium
2020-12-11 18:14:40 Dan Streetman systemd (Ubuntu Bionic): importance Undecided Medium
2020-12-11 18:14:44 Dan Streetman systemd (Ubuntu Focal): status New In Progress
2020-12-11 18:14:47 Dan Streetman systemd (Ubuntu Bionic): status New In Progress
2020-12-11 18:15:51 Dan Streetman systemd (Ubuntu Focal): assignee Dan Streetman (ddstreet)
2021-01-11 22:04:56 Chris Halse Rogers systemd (Ubuntu Focal): status In Progress Fix Committed
2021-01-11 22:04:59 Chris Halse Rogers bug added subscriber Ubuntu Stable Release Updates Team
2021-01-11 22:05:02 Chris Halse Rogers bug added subscriber SRU Verification
2021-01-11 22:05:11 Chris Halse Rogers tags oem-priority originate-from-1883044 stella oem-priority originate-from-1883044 stella verification-needed verification-needed-focal
2021-01-14 05:41:09 Kai-Heng Feng tags oem-priority originate-from-1883044 stella verification-needed verification-needed-focal oem-priority originate-from-1883044 stella verification-done verification-done-focal
2021-01-18 09:48:38 Launchpad Janitor systemd (Ubuntu Focal): status Fix Committed Fix Released
2021-01-18 09:49:04 Łukasz Zemczak removed subscriber Ubuntu Stable Release Updates Team
2021-03-08 09:53:07 Łukasz Zemczak systemd (Ubuntu Bionic): status In Progress Fix Committed
2021-03-08 09:53:09 Łukasz Zemczak bug added subscriber Ubuntu Stable Release Updates Team
2021-03-08 09:53:13 Łukasz Zemczak tags oem-priority originate-from-1883044 stella verification-done verification-done-focal oem-priority originate-from-1883044 stella verification-done-focal verification-needed verification-needed-bionic
2021-03-10 03:55:49 Kai-Heng Feng tags oem-priority originate-from-1883044 stella verification-done-focal verification-needed verification-needed-bionic oem-priority originate-from-1883044 stella verification-done verification-done-bionic verification-done-focal
2021-03-18 13:52:29 Launchpad Janitor systemd (Ubuntu Bionic): status Fix Committed Fix Released