systemctl crashed with SIGSEGV

Bug #1870930 reported by Gunnar Hjalmarsson on 2020-04-05
84
This bug affects 9 people
Affects Status Importance Assigned to Milestone
systemd (Ubuntu)
High
Balint Reczey
Focal
High
Balint Reczey

Bug Description

Logged in to an updated focal, entered a few unrelated commands in gnome-terminal, and then the crash message showed up.

ProblemType: Crash
DistroRelease: Ubuntu 20.04
Package: systemd 245.2-1ubuntu2
ProcVersionSignature: Ubuntu 5.4.0-21.25-generic 5.4.27
Uname: Linux 5.4.0-21-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.11-0ubuntu22
Architecture: amd64
CurrentDesktop: Unity:Unity7:ubuntu
Date: Sun Apr 5 16:26:11 2020
Disassembly: => 0x0: Cannot access memory at address 0x0
ExecutablePath: /usr/bin/systemctl
InstallationDate: Installed on 2019-11-10 (147 days ago)
InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
MachineType: Notebook P64_HJ,HK1
ProcCmdline: systemctl --user start --wait unity-session.target
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-5.4.0-21-generic root=UUID=a8fd6652-86e7-4e1a-8259-809e0a4abd2b ro quiet splash
SegvAnalysis:
 Segfault happened at: 0x0: Cannot access memory at address 0x0
 PC (0x00000000) not located in a known VMA region (needed executable region)!
SegvReason: executing NULL VMA
Signal: 11
SourcePackage: systemd
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()
SystemdDelta:
 [EXTENDED] /usr/lib/systemd/system/rc-local.service → /usr/lib/systemd/system/rc-local.service.d/debian.conf
 [EXTENDED] /usr/lib/systemd/system/systemd-timesyncd.service → /usr/lib/systemd/system/systemd-timesyncd.service.d/disable-with-time-daemon.conf
 [EXTENDED] /usr/lib/systemd/system/user@.service → /usr/lib/systemd/system/user@.service.d/timeout.conf

 3 overridden configuration files found.
Title: systemctl crashed with SIGSEGV
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin lxd plugdev sambashare sudo
dmi.bios.date: 07/06/2017
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1.05.08
dmi.board.asset.tag: Tag 12345
dmi.board.name: P64_HJ,HK1
dmi.board.vendor: Notebook
dmi.board.version: Not Applicable
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Notebook
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1.05.08:bd07/06/2017:svnNotebook:pnP64_HJ,HK1:pvrNotApplicable:rvnNotebook:rnP64_HJ,HK1:rvrNotApplicable:cvnNotebook:ct10:cvrN/A:
dmi.product.family: Not Applicable
dmi.product.name: P64_HJ,HK1
dmi.product.sku: Not Applicable
dmi.product.version: Not Applicable
dmi.sys.vendor: Notebook
separator:

Related branches

Gunnar Hjalmarsson (gunnarhj) wrote :

StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
 ?? ()

tags: added: apport-failed-retrace
tags: removed: need-amd64-retrace
Gunnar Hjalmarsson (gunnarhj) wrote :

Hmm.. I did enter Unity sessions a couple of times, but if I recall it correctly, this crash happened in a standard Ubuntu session. Not 100% sure, though...

information type: Private → Public

StacktraceTop:
 ?? ()
 bus_wait_for_units_clear (d=0x565151b0be80) at ../src/shared/bus-wait-for-units.c:94
 bus_wait_for_units_clear (d=d@entry=0x565151b0be80) at ../src/shared/bus-wait-for-units.c:83
 match_disconnected (m=0x565151b11ae0, userdata=0x565151b0be80, error=<optimized out>) at ../src/shared/bus-wait-for-units.c:109
 bus_match_run (bus=bus@entry=0x565151b07c10, node=0x565151b0bf40, m=m@entry=0x565151b11ae0) at ../src/libsystemd/sd-bus/bus-match.c:319

Changed in systemd (Ubuntu):
importance: Undecided → Medium
tags: removed: apport-failed-retrace
Changed in systemd (Ubuntu):
importance: Medium → High
tags: added: rls-ff-incoming
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in systemd (Ubuntu):
status: New → Confirmed
Balint Reczey (rbalint) wrote :

@gunnarhj The crashes happen when exiting Unity the collection happended in the standard Ubuntu session AFAICT.
All similar crashes I saw crashed waiting for the unity-session.target.

Gunnar Hjalmarsson (gunnarhj) wrote :

Thanks for letting me know, Balint. Then it was no confusion on my side, after all. :)

Balint Reczey (rbalint) wrote :

This can be triggered from the Ubuntu session, too, by running 'systemctl --user start --wait unity-session.target' a few times. Usually it crashes the third time.

Changed in systemd (Ubuntu Focal):
assignee: nobody → Balint Reczey (rbalint)
dinamic (dinamic6661) wrote :

same here, i use unity, systemctl crashes every time

Balint Reczey (rbalint) wrote :

A test build of systemd with the fix is building in:
https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/3801

tags: added: id-5e988b1f5904c96643cb5442
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package systemd - 245.4-4ubuntu3

---------------
systemd (245.4-4ubuntu3) focal; urgency=medium

  * dhcp: Allow setting request options again
    link_configure() may be called multiple times on a link causing request options
    set multiple times. (LP: #1870410)
    File: debian/patches/dhcp-Allow-setting-request-options-again.patch
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=4c48893eb04b01a2ec62d2d2823a79a9f5cb2b80
  * Don't try calling NULL callback in bus_wait_for_units_clear.
    This fixes a crash most frequently occurring in the Unity session
    (LP: #1870930)
    File: debian/patches/shared-Don-t-try-calling-NULL-callback-in-bus_wait_for_un.patch
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=b2ec1a3367cef401f8de745fecc9c385f020be78

 -- Balint Reczey <email address hidden> Wed, 22 Apr 2020 11:04:26 +0200

Changed in systemd (Ubuntu Focal):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers