namespace: make MountFlags=shared work again

Bug #1843007 reported by Harri-afaics
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
systemd (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

Systemd in Bionic fails to handle MountFlags correctly. Would you mind to include https://github.com/systemd/systemd/commit/37ed15d7edaf59a1fc7c9e3552cd93a83f3814ef into Bionic? This bug seriously affects Docker > 18.6, see the Docker release notes for 18.09.1 (https://docs.docker.com/engine/release-notes/#18091).

tags: added: id-5d7225829edbf089d659f6d9
Dan Streetman (ddstreet)
Changed in systemd (Ubuntu):
status: New → Fix Released
tags: added: next-ddstreet
Dan Streetman (ddstreet)
tags: added: ddstreet
removed: next-ddstreet
Revision history for this message
Dan Streetman (ddstreet) wrote :

> Would you mind to include https://github.com/systemd/systemd/commit/37ed15d7edaf59a1fc7c9e3552cd93a83f3814ef into Bionic?

this commit claims to fix a problem introduced by commit 0722b359342d2a9f9e0d453875624387a0ba1be2, but that commit isn't in Bionic, unless I'm missing something.

Can you provide steps for reproducing your problem?

Changed in systemd (Ubuntu Bionic):
status: New → Incomplete
Revision history for this message
Dan Streetman (ddstreet) wrote :

@harri-afaics I tried the test service from the upstream bug, but I couldn't reproduce the problem - please let me know if you are able to repro and what steps and/or config file you use to repro this on Bionic.

tags: removed: ddstreet
Dan Streetman (ddstreet)
Changed in systemd (Ubuntu Bionic):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers