Dell system takes a long time to connect network with external dock

Bug #1837700 reported by You-Sheng Yang on 2019-07-24
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Undecided
Unassigned
OEM Priority Project
Critical
Che Cheng
systemd (Ubuntu)
Status tracked in Eoan
Bionic
Medium
Shih-Yuan Lee
Disco
Medium
Shih-Yuan Lee
Eoan
Medium
Dimitri John Ledkov

Bug Description

update for SRU process:

[Impact]
1. On system featured mac passthrough, e.g., Dell/Lenovo laptop, or system occasionally install two USB ethernet with same MAC address, the system will suffer 90 seconds for network interface renaming mechanism before the last USB ethernet interface to activate.

[Test Case]
1. Install ubuntu on Dell laptop.
2. Connect the Dell laptop with two Realtek 8153 USB ethernet dongle. Users can observe the last one will take 90 seconds for renaming to rename0.
3. Users can also find that the two USB ethernet have the same MAC address.

[Regression Potential]
To resolve the issue, drop a debian patch from systemd package. The debian patch is to revert an upstream commit to support 75-persistent-net-generator.rules udev rule. Since the udev rule is deprecated, the regression potential should be relatively low.

-----------------------------------

Dell has a feature called MAC addrss passthrough[1] that would force usb ethernet adapters to be assigned with a predefined MAC address stored in BIOS or so. This feature has been landed to mainline kernel in driver r8152[2]. So whenever a r8152 managed device is plugged into Dell devices with MAC addrss passthrough enabled, this driver will set NIC MAC to a predefined one.

And some Dell devices have already one built-in r8152 NIC port. On these devices, when a second r8152 NIC is plugged in, a Debian originated udev rules file 73-usb-net-by-mac.rules[3] will invoke udev built-in command `net_id` to give a persistent name, and that will be based on MAC address. However, since the system has already initialized the built-in r8152 NIC with that name, renaming the second interface with this name will always fail.

While Debian still carries a patch called "Revert-udev-network-device-renaming-immediately-give.patch"[4] that tries to keep support of already deprecated "75-persistent-net-generator.rules" based interface renaming mechanism, this patch also propagated into Ubuntu[5]. This patch will retry renaming with a 90 seconds timeout when the error code is -EEXIST, so the uevent processing will always be blocked in the last ifrename step in the victim system.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: udev 237-3ubuntu10.24 [modified: lib/udev/rules.d/50-firmware.rules lib/udev/rules.d/50-udev-default.rules lib/udev/rules.d/73-special-net-names.rules lib/udev/rules.d/73-usb-net-by-mac.rules]
ProcVersionSignature: Ubuntu 4.15.0-1043.48-oem 4.15.18
Uname: Linux 4.15.0-1043-oem x86_64
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
CustomUdevRuleFiles: 70-snap.core.rules 95-oem-hotkey-osd.rules
Date: Wed Jul 24 15:30:59 2019
DistributionChannelDescriptor:
 # This is the distribution channel descriptor for the OEM CDs
 # For more information see http://wiki.ubuntu.com/DistributionChannelDescriptor
 canonical-oem-somerville-bionic-amd64-20180608-47+beaver-jorah+X90
InstallationDate: Installed on 2019-07-03 (20 days ago)
InstallationMedia: Ubuntu 18.04 "Bionic" - Build amd64 LIVE Binary 20180608-09:38
MachineType: Dell Inc. Latitude 7424 Rugged Extreme
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-1043-oem.efi.signed root=UUID=5da90c85-3500-49a2-b989-71a604f9eec4 ro mem_sleep_default=deep quiet splash systemd.log_level=debug udev.log-priority=debug log_buf_len=8M vt.handoff=1
SourcePackage: systemd
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/27/2019
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 1.5.0
dmi.board.name: 0Y7FK3
dmi.board.vendor: Dell Inc.
dmi.board.version: X03
dmi.chassis.type: 10
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr1.5.0:bd05/27/2019:svnDellInc.:pnLatitude7424RuggedExtreme:pvr:rvnDellInc.:rn0Y7FK3:rvrX03:cvnDellInc.:ct10:cvr:
dmi.product.family: Latitude
dmi.product.name: Latitude 7424 Rugged Extreme
dmi.sys.vendor: Dell Inc.

[1]: https://www.dell.com/support/article/tw/zh/twdhs1/sln301147/what-is-mac-address-pass-through?lang=en
[2]: https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/drivers/net/usb/r8152.c
[3]: https://salsa.debian.org/systemd-team/systemd/blob/master/debian/extra/rules/73-usb-net-by-mac.rules
[4]: https://salsa.debian.org/systemd-team/systemd/blob/master/debian/patches/debian/Revert-udev-network-device-renaming-immediately-give.patch
[5]: https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/tree/debian/patches/debian/Revert-udev-network-device-renaming-immediately-give.patch?h=ubuntu-bionic

Related branches

You-Sheng Yang (vicamo) wrote :
You-Sheng Yang (vicamo) on 2019-07-24
description: updated
You-Sheng Yang (vicamo) wrote :
tags: added: oem-priority originate-from-1835860 somerville
You-Sheng Yang (vicamo) wrote :

Above MR to Debian closed because that's already in experimental branch[1] for v242.

[1]: https://salsa.debian.org/systemd-team/systemd/commit/3d45a7af959cf260bffcb1ad0262973b5750ae36

You-Sheng Yang (vicamo) on 2019-07-25
Changed in systemd (Ubuntu Bionic):
status: New → In Progress
assignee: nobody → You-Sheng Yang (vicamo)
Che Cheng (cktenn) on 2019-07-31
affects: systemd → oem-priority
Changed in oem-priority:
importance: Undecided → Critical
assignee: nobody → cktenn (cktenn)
Che Cheng (cktenn) on 2019-07-31
Changed in oem-priority:
status: New → In Progress
You-Sheng Yang (vicamo) on 2019-07-31
Changed in systemd (Ubuntu Bionic):
status: In Progress → Fix Committed
Changed in systemd (Ubuntu):
importance: Undecided → Medium
Changed in systemd (Ubuntu Bionic):
importance: Undecided → Medium
Changed in systemd (Ubuntu Disco):
importance: Undecided → Medium
Che Cheng (cktenn) on 2019-08-01
description: updated
Che Cheng (cktenn) wrote :

Need fix landing in bionic before 31st of August.

Dimitri John Ledkov (xnox) wrote :

Fix committed status is only for SRU team to set on the distro tasks, when an SRU upload is accepted.

Changed in systemd (Ubuntu Bionic):
status: Fix Committed → New
Changed in systemd (Ubuntu):
status: New → Fix Committed
status: Fix Committed → New
Changed in oem-priority:
assignee: Che Cheng (cktenn) → Shih-Yuan Lee (fourdollars)
Rex Tsai (chihchun) on 2019-08-22
Changed in systemd (Ubuntu Bionic):
assignee: You-Sheng Yang (vicamo) → Shih-Yuan Lee (fourdollars)
Changed in systemd (Ubuntu Disco):
assignee: nobody → Shih-Yuan Lee (fourdollars)
Changed in systemd (Ubuntu Bionic):
status: New → In Progress
Changed in systemd (Ubuntu Disco):
status: New → In Progress
Changed in systemd (Ubuntu):
assignee: nobody → Shih-Yuan Lee (fourdollars)
Changed in systemd (Ubuntu Eoan):
status: New → Fix Committed
assignee: Shih-Yuan Lee (fourdollars) → Dimitri John Ledkov (xnox)

Hello You-Sheng, or anyone else affected,

Accepted systemd into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/systemd/240-6ubuntu5.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in systemd (Ubuntu Disco):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-disco
Changed in systemd (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed-bionic
Chris Halse Rogers (raof) wrote :

Hello You-Sheng, or anyone else affected,

Accepted systemd into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/systemd/237-3ubuntu10.26 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Alex Tu (alextu) on 2019-08-23
Changed in oem-priority:
assignee: Shih-Yuan Lee (fourdollars) → Che Cheng (cktenn)
Che Cheng (cktenn) wrote :

I can confirm that systemd 237-3ubuntu10.26 fixes this issue for me on bionic.

tags: added: verification-done-bionic
removed: verification-needed-bionic
Che Cheng (cktenn) wrote :

I can confirm that systemd 240-6ubuntu5.4 fixes this issue for me on disco.

tags: added: verification-done-disco
removed: verification-needed-disco
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package systemd - 240-6ubuntu13

---------------
systemd (240-6ubuntu13) eoan; urgency=medium

  * Drop s390x seccomp fix causing regression on s390x
    Files:
    - debian/patches/src-shared-seccomp-util.c-Add-mmap-definitions-for-s390.patch
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=da95e1d022e94a4d3ce0b69bd6eb398c95d09f24

 -- Balint Reczey <email address hidden> Mon, 26 Aug 2019 17:02:54 +0200

Changed in systemd (Ubuntu Eoan):
status: Fix Committed → Fix Released
Che Cheng (cktenn) on 2019-08-29
tags: added: verification-done
removed: verification-needed

All autopkgtests for the newly accepted systemd (237-3ubuntu10.26) for bionic have finished running.
The following regressions have been reported in tests triggered by the package:

network-manager/1.10.6-2ubuntu1.1 (arm64)
dovecot/1:2.2.33.2-1ubuntu4.3 (armhf)
systemd/237-3ubuntu10.26 (ppc64el)
gvfs/1.36.1-0ubuntu1.3.3 (ppc64el, i386)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/bionic/update_excuses.html#systemd

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

All autopkgtests for the newly accepted systemd (240-6ubuntu5.4) for disco have finished running.
The following regressions have been reported in tests triggered by the package:

ndctl/unknown (armhf)
tinyssh/unknown (armhf)
munin/2.0.47-1ubuntu3 (armhf)
polkit-qt-1/0.112.0-6 (armhf)
gvfs/1.40.1-1ubuntu0.1 (amd64, i386)
systemd/240-6ubuntu5.4 (amd64, s390x, i386, ppc64el)
php7.2/7.2.19-0ubuntu0.19.04.2 (armhf)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/disco/update_excuses.html#systemd

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package systemd - 237-3ubuntu10.26

---------------
systemd (237-3ubuntu10.26) bionic; urgency=medium

  [ You-Sheng Yang ]
  * d/p/d/Revert-udev-network-device-renaming-immediately-give.patch:
    - udev: drop Revert-udev-network-device-renaming-immediately-give.patch
      The removing patch was for the already deprecated
      "75-persistent-net-generator.rules" based interface renaming mechanism,
      and it's causing unnecessary problem when a system happends to NICs with
      same MAC address, e.g. Dell's MAC address pass-thru. (LP: #1837700)

  [ Shih-Yuan Lee (FourDollars) ]
  * d/p/hwdb-revert-airplane-mode-keys-handling-on-Dell.patch:
    - hwdb: revert airplane mode keys handling on Dell
      That reverts some commits those created double key events issues on some
      Dell laptops. (LP: #1740894)

 -- Shih-Yuan Lee (FourDollars) <email address hidden> Wed, 07 Aug 2019 17:56:02 +0800

Changed in systemd (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for systemd has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package systemd - 240-6ubuntu5.4

---------------
systemd (240-6ubuntu5.4) disco; urgency=medium

  [ You-Sheng Yang ]
  * d/p/d/Revert-udev-network-device-renaming-immediately-give.patch:
    - udev: drop Revert-udev-network-device-renaming-immediately-give.patch.
      The removing patch was for the already deprecated
      "75-persistent-net-generator.rules" based interface renaming mechanism,
      and it's causing unnecessary problem when a system happends to NICs with
      same MAC address, e.g. Dell's MAC address pass-thru. (LP: #1837700)

 -- Shih-Yuan Lee (FourDollars) <email address hidden> Wed, 21 Aug 2019 16:15:23 +0800

Changed in systemd (Ubuntu Disco):
status: Fix Committed → Fix Released
Che Cheng (cktenn) on 2019-09-02
Changed in oem-priority:
status: In Progress → Fix Released
Changed in hwe-next:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers