tmpfiles.d files pointing to legacy directory /var/run

Bug #1817123 reported by Andre Ruiz on 2019-02-21
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
speech-dispatcher (Debian)
Fix Released
Unknown
spice-vdagent (Debian)
Fix Released
Unknown
systemd (Ubuntu)
Undecided
Unassigned

Bug Description

Just updated cosmic and got:

Setting up systemd (239-7ubuntu10.8) ...
[/usr/lib/tmpfiles.d/speech-dispatcher.conf:1] Line references path below legacy directory /var/run/, updating /var/run/speech-dispatcher → /run/speech-dispatcher; please update the tmpfiles.d/ drop-in file accordingly.
[/usr/lib/tmpfiles.d/speech-dispatcher.conf:2] Line references path below legacy directory /var/run/, updating /var/run/speech-dispatcher/.cache → /run/speech-dispatcher/.cache; please update the tmpfiles.d/ drop-in file accordingly.
[/usr/lib/tmpfiles.d/speech-dispatcher.conf:3] Line references path below legacy directory /var/run/, updating /var/run/speech-dispatcher/.speech-dispatcher → /run/speech-dispatcher/.speech-dispatcher; please update the tmpfiles.d/ drop-in file accordingly.
[/usr/lib/tmpfiles.d/speech-dispatcher.conf:4] Line references path below legacy directory /var/run/, updating /var/run/speech-dispatcher/.cache/speech-dispatcher → /run/speech-dispatcher/.cache/speech-dispatcher; please update the tmpfiles.d/ drop-in file accordingly.
[/usr/lib/tmpfiles.d/speech-dispatcher.conf:5] Line references path below legacy directory /var/run/, updating /var/run/speech-dispatcher/log → /run/speech-dispatcher/log; please update the tmpfiles.d/ drop-in file accordingly.
[/usr/lib/tmpfiles.d/spice-vdagentd.conf:2] Line references path below legacy directory /var/run/, updating /var/run/spice-vdagentd → /run/spice-vdagentd; please update the tmpfiles.d/ drop-in file accordingly.

andre@thinkpad:~$ lsb_release -rd
Description: Ubuntu 18.10
Release: 18.10

andre@thinkpad:~$ apt-cache policy systemd
systemd:
  Installed: 239-7ubuntu10.8
  Candidate: 239-7ubuntu10.8
  Version table:
 *** 239-7ubuntu10.8 500
        500 http://br.archive.ubuntu.com/ubuntu cosmic-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu cosmic-security/main amd64 Packages
        100 /var/lib/dpkg/status
     239-7ubuntu10 500
        500 http://br.archive.ubuntu.com/ubuntu cosmic/main amd64 Packages

Andre Ruiz (andre-ruiz) on 2019-02-21
summary: - tmpfiles.d files poiting to legacy directory /var/run
+ tmpfiles.d files pointing to legacy directory /var/run
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in systemd (Ubuntu):
status: New → Confirmed
Changed in spice-vdagent (Debian):
status: Unknown → New
Changed in speech-dispatcher (Debian):
status: Unknown → New
oldfred (oldfred) wrote :

Apr 28 18:34:20 fred-Z170N-disco systemd-tmpfiles[615]: [/usr/lib/tmpfiles.d/speech-dispatcher.conf:1] Line references path below legacy directory /var/run/, updating /var/run/speech-dispatcher → /run/speech-dispatcher; please update the tmpfiles.d/ drop-in file accordingly.
Apr 28 18:34:20 fred-Z170N-disco systemd-tmpfiles[615]: [/usr/lib/tmpfiles.d/speech-dispatcher.conf:2] Line references path below legacy directory /var/run/, updating /var/run/speech-dispatcher/.cache → /run/speech-dispatcher/.cache; please update the tmpfiles.d/ drop-in file accordingly.
Apr 28 18:34:20 fred-Z170N-disco systemd-tmpfiles[615]: [/usr/lib/tmpfiles.d/speech-dispatcher.conf:3] Line references path below legacy directory /var/run/, updating /var/run/speech-dispatcher/.speech-dispatcher → /run/speech-dispatcher/.speech-dispatcher; please update the tmpfiles.d/ drop-in file accordingly.
Apr 28 18:34:20 fred-Z170N-disco systemd-tmpfiles[615]: [/usr/lib/tmpfiles.d/speech-dispatcher.conf:4] Line references path below legacy directory /var/run/, updating /var/run/speech-dispatcher/.cache/speech-dispatcher → /run/speech-dispatcher/.cache/speech-dispatcher; please update the tmpfiles.d/ drop-in file accordingly.
Apr 28 18:34:20 fred-Z170N-disco systemd-tmpfiles[615]: [/usr/lib/tmpfiles.d/speech-dispatcher.conf:5] Line references path below legacy directory /var/run/, updating /var/run/speech-dispatcher/log → /run/speech-dispatcher/log; please update the tmpfiles.d/ drop-in file accordingly.
Apr 28 18:34:20 fred-Z170N-disco systemd-tmpfiles[615]: [/usr/lib/tmpfiles.d/spice-vdagentd.conf:2] Line references path below legacy directory /var/run/, updating /var/run/spice-vdagentd → /run/spice-vdagentd; please update the tmpfiles.d/ drop-in file accordingly.

Related:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=902413
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=912749
https://bugzilla.redhat.com/show_bug.cgi?id=1658487

Andre Ruiz (andre-ruiz) wrote :

Just got the same bug again in Disco Dingo.

Setting up systemd (240-6ubuntu5.1) ...
[/usr/lib/tmpfiles.d/speech-dispatcher.conf:1] Line references path below legacy directory /var/run/, updating /var/run/speech-dispatcher → /run/speech-dispatcher; please update the tmpfiles.d/ drop-in file accordingly.
[/usr/lib/tmpfiles.d/speech-dispatcher.conf:2] Line references path below legacy directory /var/run/, updating /var/run/speech-dispatcher/.cache → /run/speech-dispatcher/.cache; please update the tmpfiles.d/ drop-in file accordingly.
[/usr/lib/tmpfiles.d/speech-dispatcher.conf:3] Line references path below legacy directory /var/run/, updating /var/run/speech-dispatcher/.speech-dispatcher → /run/speech-dispatcher/.speech-dispatcher; please update the tmpfiles.d/ drop-in
 file accordingly.
[/usr/lib/tmpfiles.d/speech-dispatcher.conf:4] Line references path below legacy directory /var/run/, updating /var/run/speech-dispatcher/.cache/speech-dispatcher → /run/speech-dispatcher/.cache/speech-dispatcher; please update the tmpfile
s.d/ drop-in file accordingly.
[/usr/lib/tmpfiles.d/speech-dispatcher.conf:5] Line references path below legacy directory /var/run/, updating /var/run/speech-dispatcher/log → /run/speech-dispatcher/log; please update the tmpfiles.d/ drop-in file accordingly.
[/usr/lib/tmpfiles.d/spice-vdagentd.conf:2] Line references path below legacy directory /var/run/, updating /var/run/spice-vdagentd → /run/spice-vdagentd; please update the tmpfiles.d/ drop-in file accordingly.

Changed in spice-vdagent (Debian):
status: New → Fix Released
Changed in speech-dispatcher (Debian):
status: New → Fix Committed
Changed in speech-dispatcher (Debian):
status: Fix Committed → Fix Released
Kai Kasurinen (kai-kasurinen) wrote :

Fixed in version speech-dispatcher/0.9.1-4
Fixed in version spice-vdagent/0.19.0-1

Changed in systemd (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.