The wlan/bt hotkey doesn't work for all Dell Latitude and Precision computers

Bug #1799364 reported by Shih-Yuan Lee on 2018-10-23
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
Undecided
Unassigned
Bionic
Undecided
Unassigned
systemd (Ubuntu)
Status tracked in Disco
Bionic
Medium
Unassigned
Cosmic
Medium
Unassigned
Disco
Medium
Unassigned

Bug Description

[Impact]

 * All Dell Latitude and Precision computer users can not use the wlan/bt hotkey.

[Test Case]

 * Use any Dell Latitude and Precision computer to check the wlan/bt hotkey.

 * If you don't have the computer above, you can use the following command to check, and the expected output is "KEYBOARD_KEY_88=!wlan" instead of "KEYBOARD_KEY_88=!".

 `systemd-hwdb query evdev:atkbd:dmi:bvnDellInc.:bvr0.0.24:bd10/05/2018:svnDellInc.:pnLatitude3300:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct10:cvr: | grep KEYBOARD_KEY_88`

[Regression Potential]

 * No regression

[Other Info]

 * None

Just install the official Ubuntu 18.10 on any Dell Latitude or Precision computer and press wlan/bt hotkey on the keyboard.

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: systemd 239-7ubuntu10
ProcVersionSignature: Ubuntu 4.18.0-10.11-generic 4.18.12
Uname: Linux 4.18.0-10-generic x86_64
ApportVersion: 2.20.10-0ubuntu13
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Tue Oct 23 15:37:41 2018
InstallationDate: Installed on 2018-10-23 (0 days ago)
InstallationMedia: Ubuntu 18.10 "Cosmic Cuttlefish" - Release amd64 (20181017.3)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 003: ID 8087:0a2a Intel Corp.
 Bus 001 Device 002: ID 0bda:5520 Realtek Semiconductor Corp.
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Dell Inc. Latitude 3300
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.18.0-10-generic root=UUID=be88d6f2-7d21-4a3c-b384-0c5356fb9220 ro quiet splash vt.handoff=1
SourcePackage: systemd
SystemdDelta:
 [EXTENDED] /lib/systemd/system/rc-local.service → /lib/systemd/system/rc-local.service.d/debian.conf
 [EXTENDED] /lib/systemd/system/user@.service → /lib/systemd/system/user@.service.d/timeout.conf

 2 overridden configuration files found.
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 10/05/2018
dmi.bios.vendor: Dell Inc.
dmi.bios.version: 0.0.24
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 10
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvr0.0.24:bd10/05/2018:svnDellInc.:pnLatitude3300:pvr:rvnDellInc.:rn:rvr:cvnDellInc.:ct10:cvr:
dmi.product.family: Latitude
dmi.product.name: Latitude 3300
dmi.product.sku: 08BB
dmi.sys.vendor: Dell Inc.

Shih-Yuan Lee (fourdollars) wrote :
tags: added: bionic
Shih-Yuan Lee (fourdollars) wrote :

Ubuntu 18.04 has the same problem.

description: updated

The attachment "0001-d-p-hwdb-Fix-wlan-keycode-for-all-Dell-Latitude-and-.patch" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
description: updated
tags: added: somerville
tags: added: seomrville-1784329
tags: added: rls-cc-incoming
Changed in systemd (Ubuntu Disco):
status: New → Fix Committed
Dimitri John Ledkov (xnox) wrote :

In disco-proposed

systemd (239-7ubuntu11) disco; urgency=medium

  * hwdb: Fix wlan keycode for all Dell Latitude and Precision systems
    (LP: #1799364)
    Author: Shih-Yuan Lee (FourDollars)
    File: debian/patches/hwdb-Fix-wlan-keycode-for-all-Dell-Latitude-and-Precision.patch
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=d8ac9a5640be39ede9cebcd8c4cc44e8811e0e49

  * hwdb: Update PNP IDs of Goldstar (now: LG Electronics) (LP: #1804584)
    File: debian/patches/hwdb-Update-PNP-IDs-of-Goldstar-now-LG-Electronics-.-1005.patch
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=10204fb5761c759be6ddf27dc43c851ef24c96cb

  * btrfs-util: unbreak tmpfiles' subvol creation
    File: debian/patches/btrfs-util-unbreak-tmpfiles-subvol-creation.patch
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=4ab5b8275a0487e301553fb6de6a905abb7ea833

 -- Dimitri John Ledkov <email address hidden> Thu, 22 Nov 2018 16:30:28 +0000

Sebastien Bacher (seb128) wrote :

the patch created issues (see the comments on bug #1740894 and https://github.com/systemd/systemd/issues/10704) and was reverted upstream in https://github.com/systemd/systemd/pull/10709 , please don't backport that change to older series but rather the revert/more recent upstream changes

Dimitri John Ledkov (xnox) wrote :

@seb128

Ok, let's sync tomorrow. I thought we already took parts of these patches in =/

Changed in systemd (Ubuntu Bionic):
importance: Undecided → Medium
Changed in systemd (Ubuntu Cosmic):
importance: Undecided → Medium
Changed in systemd (Ubuntu Disco):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package systemd - 239-7ubuntu14

---------------
systemd (239-7ubuntu14) disco; urgency=medium

  * Fix compat with new meson.
    File: debian/patches/meson-rename-Ddebug-to-Ddebug-extra.patch
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=3b764ec1b76768a8c40635019fa5a8acb81b223e

 -- Dimitri John Ledkov <email address hidden> Thu, 29 Nov 2018 16:53:00 +0000

Changed in systemd (Ubuntu Disco):
status: Fix Committed → Fix Released
Changed in systemd (Ubuntu Cosmic):
status: New → In Progress

Hello Shih-Yuan, or anyone else affected,

Accepted systemd into cosmic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/systemd/239-7ubuntu10.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-cosmic to verification-done-cosmic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-cosmic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in systemd (Ubuntu Cosmic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-cosmic
Shih-Yuan Lee (fourdollars) wrote :

I have verified systemd/239-7ubuntu10.5 but it doesn't fix this problem alone.
It also needs to install xkb-data/2.23.1-1ubuntu1.18.10.1 to fix the problem.

tags: added: verification-done-cosmic
removed: verification-needed-cosmic
Shih-Yuan Lee (fourdollars) wrote :

cosmic works fine without this problem.

tags: added: verification-done
removed: verification-needed
Shih-Yuan Lee (fourdollars) wrote :

Sorry, I mean disco works fine without this problem.
Please ignore comment #12.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.