do-release-upgrade failed to update to systemd 229-4ubuntu21

Bug #1733468 reported by Jacob Godserv on 2017-11-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
systemd (Ubuntu)
Undecided
Unassigned

Bug Description

This is going from Ubuntu 14 to 16 LTS via do-release-upgrade on DigitalOcean.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: systemd 229-4ubuntu21
ProcVersionSignature: Ubuntu 3.13.0-32.57-generic 3.13.11.4
Uname: Linux 3.13.0-32-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.25
Architecture: amd64
Date: Mon Nov 20 22:08:04 2017
DuplicateSignature: package:systemd:229-4ubuntu21:subprocess installed post-installation script returned error exit status 1
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2014-04-18 (1312 days ago)
InstallationMedia:

Lsusb: Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: DigitalOcean Droplet
ProcKernelCmdLine: root=LABEL=DOROOT ro
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.2
 apt 1.0.1ubuntu2.17
SourcePackage: systemd
SystemdDelta:
 [EXTENDED] /lib/systemd/system/rc-local.service → /lib/systemd/system/rc-local.service.d/debian.conf
 [EXTENDED] /lib/systemd/system/systemd-resolved.service → /lib/systemd/system/systemd-resolved.service.d/resolvconf.conf
 [EXTENDED] /lib/systemd/system/systemd-timesyncd.service → /lib/systemd/system/systemd-timesyncd.service.d/disable-with-time-daemon.conf

 3 overridden configuration files found.
Title: package systemd 229-4ubuntu21 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to xenial on 2017-11-21 (0 days ago)
dmi.bios.date: 11/03/2016
dmi.bios.vendor: DigitalOcean
dmi.bios.version: 20161103
dmi.chassis.type: 1
dmi.chassis.vendor: Bochs
dmi.modalias: dmi:bvnDigitalOcean:bvr20161103:bd11/03/2016:svnDigitalOcean:pnDroplet:pvr20161103:cvnBochs:ct1:cvr:
dmi.product.name: Droplet
dmi.product.version: 20161103
dmi.sys.vendor: DigitalOcean

Jacob Godserv (fun2program8) wrote :
tags: removed: need-duplicate-check
Dimitri John Ledkov (xnox) wrote :

This is very odd:

Initializing machine ID from D-Bus machine ID.
Adding group `systemd-journal' (GID 120) ...
Done.
You are required to change your password immediately (root enforced)
chfn: PAM: Authentication token is no longer valid; new one required
adduser: `/usr/bin/chfn -f systemd Time Synchronization systemd-timesync' returned error code 1. Exiting.
dpkg: error processing package systemd (--configure):
 subprocess installed post-installation script returned error exit status 1

I'm not sure if digitalocean images are customized, in a way that prevent upgrades. Can you try creating system systemd-timesync user, and re-attempting the upgrade?

$ sudo adduser --quiet --system --group --no-create-home --home /run/systemd \
    --gecos "systemd Time Synchronization" systemd-timesync

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers