Kernel 4.9+ regression: Suspend - Freezing of tasks failed

Bug #1676912 reported by Daniel Holz on 2017-03-28
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Undecided
Unassigned
systemd (Ubuntu)
Undecided
Unassigned

Bug Description

Recently I replaced Ubuntu 16.04 on my Lenovo Yoga 3 11 with Ubuntu Gnome 17.04 and since then sometimes my Laptop won't suspend when I close the lid. The power led does not blink like it is supposed to do and when I open the Laptop the lockscreen appears but freezes after a short time, followed by a blackscreen until eventually it reappears and allows me to unlock it. After that certain application can not be started anymore and would freeze if they were running before. These include Chrome, Gedit and Gnome System Monitor for example. Also my Laptop will not connect to my WLAN until I restart it.

In syslog I found the line:

"Freezing of tasks failed after 20.005 seconds (18 tasks refusing to freeze, wq_busy=0):"

According to syslog

network-nanaeger
whoopsie
cups-browsed
wpa-supplicant
geoclue
packagekitd
several evolution-related processes
goa-daemon
gnome-software
geary
dropbox
deja-dup-monitor

are responsible.
I tried disabling some of them, but it did not solve the problem.

Update: I tested different Kernel versions in the last days. So far there were no issues with suspend/resume using Kernel 4.8 and 4.9. The problem is present in 4.10 and 4.11.

Update 2: I just encountered this issue with Kernel 4.9.

ProblemType: Bug
DistroRelease: Ubuntu 17.04
Package: systemd 232-19
ProcVersionSignature: Ubuntu 4.10.0-14.16-generic 4.10.3
Uname: Linux 4.10.0-14-generic x86_64
ApportVersion: 2.20.4-0ubuntu2
Architecture: amd64
CurrentDesktop: GNOME
Date: Tue Mar 28 16:27:34 2017
InstallationDate: Installed on 2017-03-24 (3 days ago)
InstallationMedia: Ubuntu-GNOME 17.04 "Zesty Zapus" - Beta amd64 (20170321)
MachineType: LENOVO 80J8
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.10.0-14-generic.efi.signed root=UUID=8c63f102-527f-412a-bafe-7b9075ea6b56 ro quiet splash vt.handoff=7
SourcePackage: systemd
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/15/2015
dmi.bios.vendor: LENOVO
dmi.bios.version: B8CN31WW(V2.09)
dmi.board.asset.tag: NO Asset Tag
dmi.board.name: Paganini
dmi.board.vendor: LENOVO
dmi.board.version: 31900058 WIN
dmi.chassis.asset.tag: NO Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo Yoga 3 11
dmi.modalias: dmi:bvnLENOVO:bvrB8CN31WW(V2.09):bd07/15/2015:svnLENOVO:pn80J8:pvrLenovoYoga311:rvnLENOVO:rnPaganini:rvr31900058WIN:cvnLENOVO:ct10:cvrLenovoYoga311:
dmi.product.name: 80J8
dmi.product.version: Lenovo Yoga 3 11
dmi.sys.vendor: LENOVO

Daniel Holz (daniel-holz91) wrote :
tags: added: suspend-resume
removed: wayland-session

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

This problem also appears whenn using Kernel 4.11 from the mainline ppa.

Daniel Holz (daniel-holz91) wrote :

I had some similar suspend/resume issues when trying mainline Kernels in 16.04. Every Kernel since 4.9 would cause terribly slow system after resuming.
I will test Kernel 4.8 in next days to see if this problem is present there too.

description: updated
summary: - Suspend - Freezing of tasks failed
+ Kernel 4.10+ regression: Suspend - Freezing of tasks failed
summary: - Kernel 4.10+ regression: Suspend - Freezing of tasks failed
+ Kernel 4.9+ regression: Suspend - Freezing of tasks failed
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in systemd (Ubuntu):
status: New → Confirmed
Emile Heitor (imilnb) wrote :

Same issue with kernel 4.9+ on a Macbook Pro on suspend from resume, either with lid or suspend from shutdown menu.

Paul S. Strauss (pss959) wrote :

I have the same issue on an MSI GS70 running kernel 4.10.0-33.

BUT I found a pretty easy workaround: If I turn off wifi in NetworkManager, not only does it always suspend successfully, it suspends very quickly. Thought maybe this would be helpful for others.

jzacsh (jzacsh) wrote :

fwiw, this has been happening to my laptop for a couple months (i just now had the time to look into the logs). i've had the laptop for a year (samsung ativ book 9) without problems before this.

I get continuous log output from the kernel for as long as the lid is closed, and my laptop is unrecoverable until hard rebooted (eg: close my laptop, stick in bag, then 4 hours later I'll have 16M of logs[1]; 400+ log-lines a second).

It seems everything[2] failing -- NetworkManager, sd-resolve, syncthing -- to shutdown is networking related, at least today. I'll start looking at this more in the future, as this happens to me (6 boots ago was only `cups-browsed`).

I'm on 4.10.0-34-generic, and Ubuntu 16.04.1.

Please let me know if I can add anything useful to this thread.

[1]: measuring the output of: journalctl --catalog --boot -1 | sed -n '/kernel:\ Freezing\ of\ tasks\ failed\ after/,$p'
[2]: i'm guessing here; not much experience reading these logs. this is based on the output of: journalctl --catalog --boot -1 | grep -A 1 -E 'kernel:\ *Freezing\ of\ tasks\ failed\ after' | grep -v 'Freezing.of.tasks.failed' | cut -f 6 -d ' ' | sort | uniq # (ie: looking at the reported process just after the kernel "freezing failed" line).

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers