init.d scripts loop between cups and plymouth

Bug #1628868 reported by Crisp on 2016-09-29
68
This bug affects 11 people
Affects Status Importance Assigned to Milestone
cups (Ubuntu)
Undecided
Unassigned
plymouth (Ubuntu)
Undecided
Unassigned
systemd (Ubuntu)
High
Unassigned

Bug Description

Устанавливал Kodi. После этого попытался его обновить. И при обновлении ошибки сыплются.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: udev 229-4ubuntu10
ProcVersionSignature: Ubuntu 4.4.0-38.57-generic 4.4.19
Uname: Linux 4.4.0-38-generic x86_64
NonfreeKernelModules: nvidia_uvm nvidia
ApportVersion: 2.20.1-0ubuntu2.1
Architecture: amd64
Date: Thu Sep 29 11:17:56 2016
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2016-09-10 (18 days ago)
InstallationMedia: Ubuntu 16.04.1 LTS "Xenial Xerus" - Release amd64 (20160719)
MachineType: LENOVO 80HW
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.4.0-38-generic.efi.signed root=/dev/mapper/ubuntu--vg-root ro quiet splash vt.handoff=7
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1.1
 apt 1.2.12~ubuntu16.04.1
SourcePackage: systemd
Title: package udev 229-4ubuntu10 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/20/2015
dmi.bios.vendor: LENOVO
dmi.bios.version: B6CN16WW
dmi.board.asset.tag: No Asset Tag
dmi.board.name: Lenovo G70-70
dmi.board.vendor: LENOVO
dmi.board.version: NANANANANO DPK
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Lenovo G70-70
dmi.modalias: dmi:bvnLENOVO:bvrB6CN16WW:bd07/20/2015:svnLENOVO:pn80HW:pvrLenovoG70-70:rvnLENOVO:rnLenovoG70-70:rvrNANANANANODPK:cvnLENOVO:ct10:cvrLenovoG70-70:
dmi.product.name: 80HW
dmi.product.version: Lenovo G70-70
dmi.sys.vendor: LENOVO

Crisp (savin-alexey-by) wrote :
tags: removed: need-duplicate-check
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in systemd (Ubuntu):
status: New → Confirmed
Changed in systemd (Ubuntu):
importance: Undecided → High
Dimitri John Ledkov (xnox) wrote :

There appears to be an init.d scripts loop between cups & plymouth

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cups (Ubuntu):
status: New → Confirmed
Changed in plymouth (Ubuntu):
status: New → Confirmed
era (era) on 2018-08-03
summary: - package udev 229-4ubuntu10 failed to install/upgrade: subprocess
- installed post-installation script returned error exit status 1
+ init.d scripts loop between cups and plymouth

I am out of the office until 27.08.2018.

Note: This is an automated response to your message "[Bug 1628868] Re:
init.d scripts loop between cups and plymouth [{EXTERNAL}]" sent on
03.08.2018 06:43:20.

This is the only notification you will receive while this person is away.
---------------------------------------------------------------------
Ultima Holding GmbH
Sitz: Münster Westfalen - HRB 16045 Amtsgericht Münster
Geschäftsführer: Dr. Max Padberg

Steve Langasek (vorlon) wrote :

This is not a bug in plymouth's init script; it is intentional that plymouth depends on '$all', since this script runs to stop the plymouth frontend after the rest of the init scripts have run.

It is a bug in the cups init script on the original user's system; however, that init script was not the init script included in the cups-daemon package in Ubuntu 16.04. The cups-daemon package ships a /etc/init.d/cups which does not depend on plymouth. So this is also invalid for cups.

It is still a bug in the part of the system that enforced insserv.

Changed in plymouth (Ubuntu):
status: Confirmed → Invalid
Changed in cups (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers