Stopped (with error) ... messages on encrypted LVM shutdown

Bug #1627950 reported by Stefan Bader on 2016-09-27
68
This bug affects 13 people
Affects Status Importance Assigned to Milestone
systemd
Unknown
Unknown
systemd (Ubuntu)
High
Unassigned

Bug Description

Install (Default + crypted LVM) in Ubuntu Server s390x in Yakkety Daily

Everything seems to work only on shutdown there is a bunch of "fail" messages related to the disks from systemd:

[ OK ] Stopped Network Time Synchronization.
[ 33.971312] systemd[1]: Stopped (with error) /dev/disk/by-id/dm-name-vda2_crypt.
[FAILED] Stopped (with error) /dev/disk/by-id/dm-name-vda2_crypt.
[ 33.971469] systemd[1]: Stopped (with error) /dev/disk/by-id/dm-uuid-CRYPT-LUKS1-ef8aced3ceb640fe80c2c700c4504ccb-vda2_crypt.
[FAILED] Stopped (with error) /dev/disk/by-i...40fe80c2c700c4504ccb-vda2_crypt.
[ 33.971595] systemd[1]: Stopped (with error) /dev/disk/by-id/lvm-pv-uuid-9hfIOG-dPqq-MpWQ-DzEr-njkh-t2LD-XT3kxq.
[FAILED] Stopped (with error) /dev/disk/by-i...dPqq-MpWQ-DzEr-njkh-t2LD-XT3kxq.
[FAILED] Stopped (with error) /dev/mapper/vda2_crypt.
[FAILED] Stopped (with error) /dev/dm-0.
[FAILED] Stopped (with error) /sys/devices/virtual/block/dm-0.
[ OK ] Stopped Create Volatile Files and Directories.
[ OK ] Stopped Raise network interfaces.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1627950

tags: added: iso-testing
tags: added: yakkety
Changed in systemd (Ubuntu):
importance: Undecided → Medium
importance: Medium → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in systemd (Ubuntu):
status: New → Confirmed
Sky (sky-lake) wrote :

Also affected by this.

This bug is possibly related to systemd bug #1620: https://github.com/systemd/systemd/issues/1620

asgard2 (kamp000x) wrote :

Same error at xubuntu 16.10 (yakkety) clean install with lvm, luks and current updates.

Should I worry about this message?

asgard2 (kamp000x) wrote :

If I use the device /dev/sdaX at /etc/crypttab unstead of uuid, the error is gone.

Nazar Mokrynskyi (nazar-pc) wrote :

Same here, but without LVM.
Just plain LUKS on /dev/sdx, BTRFS inside without any partitioning.

tags: added: zesty
tq0 (tq0) wrote :

I tried replacing device uuid with /dev/sdx in /etc/crypttab as "asgard2 (kamp000x)" suggested, but the problem persists. I'm using plain LUKS.

tq0 (tq0) wrote :

As a consequence File System Check runs on every boot. It could result in corrupted (encrypted) file system.

tags: added: sts
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.