systemctl crashed with SIGSEGV in bus_deserialize_and_dump_unit_file_changes() after clicking Prepare for shipping to end user following an oem install

Bug #1597248 reported by Martin Wimpress on 2016-06-29
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
systemd (Ubuntu)
Medium
Unassigned

Bug Description

I install Ubuntu MATE 16.10 Alpha 1 (i386) using the oem installer. After a reboot and clicked "Prepare for shipping to end user" which did request a password but not display the usual confirmation. Shortly after apport trapped the attached systemctl segfault.

ProblemType: Crash
DistroRelease: Ubuntu 16.10
Package: systemd 230-3git1
ProcVersionSignature: Ubuntu 4.4.0-28.47-generic 4.4.13
Uname: Linux 4.4.0-28-generic i686
ApportVersion: 2.20.2-0ubuntu1
Architecture: i386
Date: Wed Jun 29 10:21:18 2016
ExecutablePath: /bin/systemctl
InstallationDate: Installed on 2016-06-29 (0 days ago)
InstallationMedia: Ubuntu-MATE 16.10 "Yakkety Yak" - Alpha i386 (20160628)
Lsusb:
 Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: innotek GmbH VirtualBox
ProcCmdline: /bin/systemctl set-default oem-config.target
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, no user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.4.0-28-generic root=UUID=3b560509-0256-4556-aabc-589041fa643c ro quiet splash
Signal: 11
SourcePackage: systemd
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 __libc_start_main (main=0x800a34b0, argc=3, argv=0xbfee37f4, init=0x80113870, fini=0x801138d0, rtld_fini=0xb7738780 <_dl_fini>, stack_end=0xbfee37ec) at ../csu/libc-start.c:291
 ?? ()
SystemdDelta:
 [EXTENDED] /lib/systemd/system/systemd-timesyncd.service → /lib/systemd/system/systemd-timesyncd.service.d/disable-with-time-daemon.conf
 [REDIRECTED] /etc/systemd/system/default.target → /lib/systemd/system/default.target
 [EXTENDED] /lib/systemd/system/rc-local.service → /lib/systemd/system/rc-local.service.d/debian.conf

 3 overridden configuration files found.
Title: systemctl crashed with SIGSEGV in __libc_start_main()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.board.name: VirtualBox
dmi.board.vendor: Oracle Corporation
dmi.board.version: 1.2
dmi.chassis.type: 1
dmi.chassis.vendor: Oracle Corporation
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:rvnOracleCorporation:rnVirtualBox:rvr1.2:cvnOracleCorporation:ct1:cvr:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH

Martin Wimpress (flexiondotorg) wrote :
information type: Private → Public

StacktraceTop:
 bus_deserialize_and_dump_unit_file_changes (m=0x81c2b4d0, quiet=<optimized out>, changes=0x0, n_changes=0x0) at ../src/shared/bus-unit-util.c:893
 set_default.lto_priv.408 (argc=2, argv=0xbfee37f8, userdata=0x0) at ../src/systemctl/systemctl.c:2101
 dispatch_verb (verbs=0x80147380 <verbs>, userdata=0x0, argv=<optimized out>, argc=<optimized out>) at ../src/basic/verbs.c:92
 systemctl_main () at ../src/systemctl/systemctl.c:7473
 main (argc=3, argv=0xbfee37f4) at ../src/systemctl/systemctl.c:7742

Changed in systemd (Ubuntu):
importance: Undecided → Medium
summary: - systemctl crashed with SIGSEGV in __libc_start_main() after clicking
- Prepare for shipping to end user following an oem install
+ systemctl crashed with SIGSEGV in
+ bus_deserialize_and_dump_unit_file_changes() after clicking Prepare for
+ shipping to end user following an oem install
tags: removed: need-i386-retrace
Martin Wimpress (flexiondotorg) wrote :

I was able to produce the same segfault using an amd64 install:

  * https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1597258

The above is now marked as a duplicate of this bug.

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1597248

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers