package udev 229-4ubuntu4 failed to install/upgrade: /var/log/udev is a directory

Bug #1574004 reported by Erich Palan on 2016-04-23
50
This bug affects 11 people
Affects Status Importance Assigned to Milestone
systemd (Ubuntu)
Undecided
Unassigned
Xenial
Medium
Unassigned

Bug Description

upgrade to 16.04 failed

SRU INFORMATION
---------------
Fix: http://anonscm.debian.org/cgit/pkg-systemd/systemd.git/commit/?h=ubuntu-xenial&id=d133b04

Test case: Install 15.10, remove the /var/log/udev file, and make it a directory (sudo mkdir -p /var/log/udev). Upgrade to 16.04 (at least udev). This will fail on this error with the xenial version, but should succeed with this fix.

Regression potential: practically zero. This only ignores errors on the rm of the old log file.

ProblemType: Package
DistroRelease: Ubuntu 16.04
Package: udev 229-4ubuntu4
ProcVersionSignature: Ubuntu 4.2.0-36.41-generic 4.2.8-ckt8
Uname: Linux 4.2.0-36-generic x86_64
ApportVersion: 2.20.1-0ubuntu2
Architecture: amd64
Date: Sat Apr 23 14:34:45 2016
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationDate: Installed on 2015-07-16 (281 days ago)
InstallationMedia: Ubuntu 15.04 "Vivid Vervet" - Release amd64 (20150422)
MachineType: LENOVO 4174P5G
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.2.0-36-generic root=UUID=6d33134c-01af-4ee9-ad9e-afe117f0cff4 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 dpkg 1.18.4ubuntu1
 apt 1.2.10ubuntu1
SourcePackage: systemd
Title: package udev 229-4ubuntu4 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to xenial on 2016-04-23 (0 days ago)
dmi.bios.date: 04/11/2013
dmi.bios.vendor: LENOVO
dmi.bios.version: 8CET57WW (1.37 )
dmi.board.asset.tag: Not Available
dmi.board.name: 4174P5G
dmi.board.vendor: LENOVO
dmi.board.version: Not Available
dmi.chassis.asset.tag: No Asset Information
dmi.chassis.type: 10
dmi.chassis.vendor: LENOVO
dmi.chassis.version: Not Available
dmi.modalias: dmi:bvnLENOVO:bvr8CET57WW(1.37):bd04/11/2013:svnLENOVO:pn4174P5G:pvrThinkPadT420s:rvnLENOVO:rn4174P5G:rvrNotAvailable:cvnLENOVO:ct10:cvrNotAvailable:
dmi.product.name: 4174P5G
dmi.product.version: ThinkPad T420s
dmi.sys.vendor: LENOVO

Erich Palan (erich-palan) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in systemd (Ubuntu):
status: New → Confirmed
Davide Alberelli (dadexix86) wrote :

I have a workaround for this.

Since the error is "rm: cannot remove '/var/log/udev': Is a directory" what I did was to manually remove the folder

    sudo rm -r /var/log/udev
and then restart the configuration of the packages with

    sudo dpkg --configure -a

This led to a successfull upgrade to 16.04.

Martin Pitt (pitti) wrote :

We don't really expect /var/log/udev to be a directory (nothing in Ubuntu creates it like that), but we should of course not fail the upgrade due to that. I committed a simple fix to http://anonscm.debian.org/cgit/pkg-systemd/systemd.git/commit/?h=ubuntu-xenial&id=d133b04 .

This is only relevant for xenial, this transitional code will be dropped entirely in yakkety.

Changed in systemd (Ubuntu Xenial):
importance: Undecided → Medium
status: New → In Progress
Changed in systemd (Ubuntu):
status: Confirmed → Invalid
Martin Pitt (pitti) on 2016-05-02
summary: - package udev 229-4ubuntu4 failed to install/upgrade: subprocess
- installed post-installation script returned error exit status 1
+ package udev 229-4ubuntu4 failed to install/upgrade: /var/log/udev is a
+ directory
description: updated

Hello Erich, or anyone else affected,

Accepted systemd into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/systemd/229-4ubuntu5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in systemd (Ubuntu Xenial):
status: In Progress → Fix Committed
tags: added: verification-needed
Martin Pitt (pitti) wrote :

I launched a wily container, mkdir'ed /var/log/udev, installed udev from xenial and got the udev failure. I did the same procedure again, installed udev from xenial-proposed, and udev installed correctly.

description: updated
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package systemd - 229-4ubuntu5

---------------
systemd (229-4ubuntu5) xenial-proposed; urgency=medium

  * debian/udev.postinst: Don't fail if /var/log/udev is a directory.
    (LP: #1574004)
  * Set MAC based name for USB network interfaces only for universally
    administered (i. e. stable) MACs, not for locally administered (i. e.
    randomly generated) ones. Drop /lib/systemd/network/90-mac-for-usb.link
    (as link files don't currently support globs for MACAddress=) and replace
    with an udev rule in /lib/udev/rules.d/73-special-net-names.rules.
    (Closes: #812575, LP: #1574483)
  * debian/extra/init-functions.d/40-systemd: Invoke status command with
    --no-pager, to avoid blocking scripts that call an init.d script with
    "status" with an unexpected pager process. (Closes: #765175, LP: #1576409)
  * Add debian/extra/rules/70-debian-uaccess.rules: Make FIDO U2F dongles
    accessible to the user session. This avoids having to install libu2f-host0
    (which isn't discoverable at all) to make those devices work.
    (LP: #1387908)
  * On shutdown, unmount /tmp before disabling swap. (Closes: #788303)

 -- Martin Pitt <email address hidden> Mon, 02 May 2016 15:04:42 -0500

Changed in systemd (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for systemd has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers