Inconsistency in /usr/share/initramfs-tools/hooks/udev file causes configuration failure

Bug #1535255 reported by wayne on 2016-01-18
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
systemd (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Martin Pitt

Bug Description

I'm running udev build 205 and /usr/share/initramfs-tools/hooks/udev seems to have a typo. In the snippet below the check is on the file in the /sbin dir and the copy is on the file in /bin. The latter doesn't exist.

if [ -x /sbin/udevadm.upgrade ]; then
    copy_exec /bin/udevadm.upgrade /bin/udevadm

This is what is should be from build 175

if [ -x /bin/udevadm.upgrade ]; then
    copy_exec /bin/udevadm.upgrade /bin/udevadm

This bug is quite important as when update-initramfs -u fails the system can be left in an unbootable state.

Martin Pitt (pitti) wrote :

This has been dropped entirely after 14.04, but is still an issue in 14.04 LTS.

Changed in udev (Ubuntu):
status: New → Fix Released
affects: udev (Ubuntu) → systemd (Ubuntu)
summary: Inconsistency in /usr/share/initramfs-tools/hooks/udev file causes
- configuration fali
+ configuration failure
Changed in systemd (Ubuntu Trusty):
status: New → Triaged
wayne (wayne-flashmedia) wrote :

Sorry, yes, I'm running 14.04 LTS.

Martin Pitt (pitti) on 2016-02-11
Changed in systemd (Ubuntu Trusty):
assignee: nobody → Martin Pitt (pitti)
Martin Pitt (pitti) on 2016-02-25
Changed in systemd (Ubuntu Trusty):
status: Triaged → In Progress
description: updated

Hello wayne, or anyone else affected,

Accepted systemd into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/systemd/204-5ubuntu20.19 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in systemd (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed

That fixes the problem. Thanks

On Thu, Feb 25, 2016 at 8:57 PM, Brian Murray <email address hidden> wrote:

> Hello wayne, or anyone else affected,
>
> Accepted systemd into trusty-proposed. The package will build now and be
> available at
> https://launchpad.net/ubuntu/+source/systemd/204-5ubuntu20.19 in a few
> hours, and then in the -proposed repository.
>
> Please help us by testing this new package. See
> https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to
> enable and use -proposed. Your feedback will aid us getting this update
> out to other Ubuntu users.
>
> If this package fixes the bug for you, please add a comment to this bug,
> mentioning the version of the package you tested, and change the tag
> from verification-needed to verification-done. If it does not fix the
> bug for you, please add a comment stating that, and change the tag to
> verification-failed. In either case, details of your testing will help
> us make a better decision.
>
> Further information regarding the verification process can be found at
> https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in
> advance!
>
> ** Changed in: systemd (Ubuntu Trusty)
> Status: In Progress => Fix Committed
>
> ** Tags added: verification-needed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1535255
>
> Title:
> Inconsistency in /usr/share/initramfs-tools/hooks/udev file causes
> configuration failure
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1535255/+subscriptions
>

Martin Pitt (pitti) on 2016-02-26
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package systemd - 204-5ubuntu20.19

---------------
systemd (204-5ubuntu20.19) trusty-proposed; urgency=medium

  * Add upstream-uaccess-Add-new-DRM-render-nodes.patch: Add uaccess tag for
    "renderD*" devices for AMD GPUs. (LP: #1536438)
  * libpam-systemd: Don't restart logind on upgrades, this confuses too many
    clients and causes effects like screen blanking. (LP: #1473800)
  * debian/extra/initramfs.hook: Fix typo in path of udevadm.upgrade : The
    binary is /bin/udevadm.upgrade while udev is unpacked and not configured
    (see debian/udev.{pre,post}inst. (LP: #1535255)

 -- Martin Pitt <email address hidden> Thu, 25 Feb 2016 16:49:20 +0100

Changed in systemd (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for systemd has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers