Entry in fstab with x-initrd.mount not mounted at boot

Bug #1521744 reported by Andrew Tribick on 2015-12-01
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
systemd (Ubuntu)
Undecided
Unassigned

Bug Description

I am running a system with a separate /var partition - this causes errors due to various services being started before the /var partition is mounted. As an attempt to fix this, I have tried adding the x-initrd.mount option to the entry in /etc/fstab for the /var partition, according to http://www.freedesktop.org/software/systemd/man/systemd.special.html this should add the partition to the sysroot-usr.mount target.

Example fstab entry

UUID={*irrelevant to bug report*} /var ext4 defaults,x-initrd.mount 0 2

What actually happens is that this causes the partition not to be mounted at all after boot. Using sudo mount -a does nevertheless successfully mount the partition.

Reproducible: always

In searching for information about this issue, I came across the following in the Red Hat Bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=1249513

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: systemd 225-1ubuntu9
ProcVersionSignature: Ubuntu 4.2.0-18.22-generic 4.2.3
Uname: Linux 4.2.0-18-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.19.1-0ubuntu5
Architecture: amd64
CurrentDesktop: KDE
Date: Tue Dec 1 20:46:20 2015
EcryptfsInUse: Yes
InstallationDate: Installed on 2015-10-31 (31 days ago)
InstallationMedia: Kubuntu 15.10 "Wily Werewolf" - Release amd64 (20151021)
MachineType: ASUSTeK COMPUTER INC. CG8270
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.2.0-18-generic.efi.signed root=UUID=15dd477c-fc5c-42ba-a9b1-54282be263ad ro quiet splash vt.handoff=7
SourcePackage: systemd
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/29/2012
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 0607
dmi.board.asset.tag: To be filled by O.E.M.
dmi.board.name: CG8270
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: Rev X.0x
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr0607:bd08/29/2012:svnASUSTeKCOMPUTERINC.:pnCG8270:pvrSystemVersion:rvnASUSTeKCOMPUTERINC.:rnCG8270:rvrRevX.0x:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: CG8270
dmi.product.version: System Version
dmi.sys.vendor: ASUSTeK COMPUTER INC.

Andrew Tribick (ajtribick) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in systemd (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers