Failed to parse ACL "d:group:adm:r-x,d": Invalid argument. Ignoring

Bug #1480552 reported by dino99 on 2015-08-01
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
NULL Project
Undecided
Unassigned
systemd (Debian)
Fix Released
Unknown
systemd (Ubuntu)
Undecided
Unassigned

Bug Description

Get that error logged into journalctl

......
systemd[1]: Started Apply Kernel Variables.
systemd-tmpfiles[273]: Failed to parse ACL "d:group:adm:r-x,d": Invalid argument. Ignoring
kernel: ip6_tables: (C) 2000-2006 Netfilter Core Team
......
(repeated three other times at different places, each time systemd-tmpfiles is called)

installed acl is 2.2.52-2 : last upgrade of Sep 2014; maybe it needs a new version or a fix.

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: systemd 223-1ubuntu1
ProcVersionSignature: Ubuntu 4.1.0-3.3-generic 4.1.3
Uname: Linux 4.1.0-3-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.18-0ubuntu5
Architecture: i386
CurrentDesktop: GNOME
Date: Sat Aug 1 14:22:35 2015
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 003 Device 002: ID 046d:c50e Logitech, Inc. Cordless Mouse Receiver
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: ASUSTEK COMPUTER INC P5W DH Deluxe
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.1.0-3-generic root=UUID=7b1f4a51-558f-468f-85e0-f815d2f791e1 ro
SourcePackage: systemd
UdevLog: Error: [Errno 2] No such file or directory: '/var/log/udev'
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 07/22/2010
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 3002
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: P5W DH Deluxe
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr3002:bd07/22/2010:svnASUSTEKCOMPUTERINC:pnP5WDHDeluxe:pvrSystemVersion:rvnASUSTeKComputerINC.:rnP5WDHDeluxe:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: P5W DH Deluxe
dmi.product.version: System Version
dmi.sys.vendor: ASUSTEK COMPUTER INC

dino99 (9d9) wrote :
dino99 (9d9) on 2015-08-01
description: updated
dino99 (9d9) wrote :

Comment from https://bugzilla.redhat.com/show_bug.cgi?id=1241997

This happens in the initramfs, where some groups are not defined, and acl parsing fails. Unfortunately the parsing code (libacl) does not return meaningful error codes, so we don't have a way to differentiate between a "non-error" like missing groups, which we would simply ignore, and other errors. Some solution will have to be implemented in systemd upstream to deal with this properly.

dino99 (9d9) wrote :

systemctl status systemd-tmpfiles-setup.service
● systemd-tmpfiles-setup.service - Create Volatile Files and Directories
   Loaded: loaded (/lib/systemd/system/systemd-tmpfiles-setup.service; static; vendor preset: enabled)
   Active: active (exited) since dim. 2015-08-02 07:01:54 CEST; 1h 45min ago
     Docs: man:tmpfiles.d(5)
           man:systemd-tmpfiles(8)
  Process: 588 ExecStart=/bin/systemd-tmpfiles --create --remove --boot --exclude-prefix=/dev (code=exited, status=0/SUCCESS)
 Main PID: 588 (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/systemd-tmpfiles-setup.service

août 02 07:01:52 u32 systemd[1]: Starting Create Volatile Files and Directories...
août 02 07:01:52 u32 systemd-tmpfiles[588]: Failed to parse ACL "d:group:adm:r-x,d": Invalid argument. Ignoring
août 02 07:01:52 u32 systemd-tmpfiles[588]: [/usr/lib/tmpfiles.d/var.conf:14] Duplicate line for path "/var/log", ignoring.
août 02 07:01:54 u32 systemd[1]: Started Create Volatile Files and Directories.

dino99 (9d9) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in systemd (Ubuntu):
status: New → Confirmed

The removal of the faulty ",d" should fix this issue.

--- debian/patches/Fix-up-tmpfiles.d-permissions-properly.patch.orig 2015-08-04 15:28:25.000000000 +0200
+++ debian/patches/Fix-up-tmpfiles.d-permissions-properly.patch 2015-08-08 19:06:27.066553978 +0200
@@ -48,7 +48,7 @@
  m4_ifdef(`HAVE_ACL',``
 -a+ /var/log/journal/%m - - - - d:group:adm:r-x,d:group:wheel:r-x
 -a+ /var/log/journal/%m - - - - group:adm:r-x,group:wheel:r-x
-+a+ /var/log/journal/%m - - - - d:group:adm:r-x,d
++a+ /var/log/journal/%m - - - - d:group:adm:r-x
 +a+ /var/log/journal/%m - - - - group:adm:r-x
  '')m4_dnl

Changed in systemd (Debian):
status: Unknown → New
Martin Pitt (pitti) wrote :

Thanks Thaddaeus! Committed.

Changed in systemd (Ubuntu):
status: Confirmed → Fix Committed
affects: initramfs-tools → null-and-void
Changed in null-and-void:
status: New → Invalid
Changed in systemd (Debian):
status: New → Fix Committed
dino99 (9d9) wrote :

systemd (224-1ubuntu3) wily; urgency=medium

  * Skip systemd-fsckd autopkgtest if /run/initramfs/fsck-root exists, i. e.
    the initramfs already ran fsck.
  * Fix broken ACL in tmpfiles.d/systemd.conf. (Closes: #794645, LP: #1480552)
  * Add debian/tests/unit-config: Test "systemctl link"; reproduces LP#1480310.
  * Add a hack to unbreak "systemctl link". (LP: #1480310)

 -- Martin Pitt <email address hidden> Wed, 12 Aug 2015 15:21:19 +0200

Changed in systemd (Ubuntu):
status: Fix Committed → Fix Released
Changed in systemd (Debian):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.