[udev] Shows "starting version 219" boot message even with "quiet"

Bug #1432171 reported by Aaron Honeycutt on 2015-03-14
246
This bug affects 53 people
Affects Status Importance Assigned to Milestone
systemd (Ubuntu)
Low
Unassigned

Bug Description

Everytime the system is booted up I get a "Starting version 219" which it seems is the version number for systemd.

udev version: 219-4ubuntu5

tags: added: systemd-boot
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in systemd (Ubuntu):
status: New → Confirmed
dino99 (9d9) wrote :

This is not a bug; it's simply the plymooth comment due to the 'quiet splash' boot options
When these options are removed from grub, and then grub updated, that comment is replaced by the full booting process.

That is, some user says 'hey what is this ?' while some osthers are scared when nothing is displayed. That's life !!!

Changed in systemd (Ubuntu):
status: Confirmed → Incomplete

We shouldn't scare our users. I have not chosen quiet splash, I've chosen the standard bootsplash. There is no reason for 40 seconds of black screen rather than the chosen splash image.

There should be plymouth and direct transition to sddm. This certainly IS a bug which should be fixed before launch.

Valorie

Changed in systemd (Ubuntu):
status: Incomplete → Confirmed
Didier Roche (didrocks) wrote :

Quite agree this is a bug (low priority though). We'll give it a look.

However, it seems you have another bug, you shouldn't get 40s of black screen and be transitionned quickly to plymouth (as with upstart). Mind filing another bug report with additional debug information (let's keep this bug separated)? Attaching the journal (journactl -b) output would be helpful on this bug report.

Changed in systemd (Ubuntu):
importance: Undecided → Low
status: Confirmed → Triaged
Didier Roche (didrocks) wrote :

Would be interesting to know why ddms wasn't enabled for you automatically, if you can provide some details, like did you get other display-manager installed, that would helpful.

Happy that you have a booting machine again though :)

Sherif (ali-sherif10) wrote :

Distribution: Kubuntu 15.04.
This bug affects me. I can only boot by Ubuntu...(Upstart).
This bug should have been critical. It must be fixed, before the final release.

tags: added: vivid

Keeping this bug for the message. This is just cosmetical, and entirely independent of sddm not starting. Please file a bug against sddm for that. Thanks!

summary: - Starting version 219 "systemd-boot"
+ Shows "starting version 219" boot message even with quiet
summary: - Shows "starting version 219" boot message even with quiet
+ Shows "starting version 219" boot message even with "quiet"
summary: - Shows "starting version 219" boot message even with "quiet"
+ [udev] Shows "starting version 219" boot message even with "quiet"
description: updated
Sherif (ali-sherif10) wrote :

I could boot with systemd, after installing Kubuntu 15.04 Beta 2. Is it fixed?

@sherif it never stopped the system from booting just did not want that to show up and scare the user.

Martin Pitt (pitti) wrote :

It's also not that easy to reproduce -- I don't see that string on either my laptop nor my VMs, as plymouth makes that invisible. I don't even see it when I boot without plymouth, i. e. drop "splash" from the kernel command line.

Sherif (ali-sherif10) wrote :

@Aaron, it showed and boot never was correct on my previous installation. Anyway, I can boot well now and I don't mind the text.

Thomas Andersen (phomes) wrote :

I see this message as well. It is shown together with an error from dmesg. My screen just says the following for most of the boot:

[0.9] ACPI PCC probe failed
Starting version 219

Martin Pitt (pitti) wrote :

Dropping systemd-boot tag as that happens with upstart too. The message is from udev in initramfs-tools, thus unrelated to pid 1 in the actual system.

tags: removed: systemd-boot
cro (cro) wrote :

I get this error as well, and I do NOT have sddm installed, so the provided "fixes" don't work. I cannot boot to a graphical user interface by waiting, I don't have "quiet" enabled and I'm using mdm.

The only way to boot is to switch to another tty (F1 - the only one available) and execute "sudo mdm restart" manually.

This is a critical error, not a trivial one, as i has completely broken the boot process on my laptop.

"Failed to start sddm.service: Unit sddm.service failed to load: No such file or directory."

Martin Pitt (pitti) wrote :

This is *not* a report about sddm misbehaving, please file troubles with sddm against the sddm package. This bug is exclusively for the "starting version 219" message that is printed during booting, which is just cosmetical.

cro (cro) wrote :

Well, I resolved the error - by installing `upstart-sys` (which replaces `systemd` with upstart)

So it appears this is an issue where the removal of `upstart` breaks startup of some display managers and prevents the running of login scripts. The workaround is to manually start your chosen display manager from a cli.

Reconfiguring (dpkg-reconfigure) doesn't work, and on this basis, `mdm` works, `lightdm` crashes to low-graphics mode and `sddm` (if manually installed) shows a plain white screen.

So no, it's not related to `sddm`, it is directly related to the implementation and use of `systemd` as a replacement to `upstart`.

It may or may not be "cosmetic" (the display of the message) but the overall effect of installing systemd in this instance has the net result of causing user systems to fail to boot into a graphical display manager, without a relevant or informative notice.

So, if you see "starting version 219" and your display manager (login window) doesn't run, but you *can* load it by manually starting it form the console, you most likely have a problem with your display manager startup script(s). Either replace the display manager startup scripts to work with `systemd`, or remove `systemd` and replace it with `upstart-sys`.

anavarre (aurelien.navarre) wrote :

Tried several solutions above (not upstart-sys) but nothing worked for me. I could only get into a graphical session by typing startx from a TTY. Logs didn't output anything that I was able to make sense of, so, for the time being I've uninstalled sddm and have replaced it with slim. Now I can log in via slim and get to my plasma 5 session just fine. FTR I did try to install lightdm before I tried slim but this one seemed like it was frozen always on the login prompt.

I get the "starting version 219" message and can't boot into graphical mode. I'm going to try some of the solutions above, but please don't say it's just cosmetical or trivial. If I boot from recovery mode and then choose resume normal boot I can login straight into graphical mode. If I don't, then I have to login into a tty and try to start it manually from there. Running Ubuntu 15.04 here. Thanks

I solve problem following advice about upstart from cro. Didnt find upstart-sys package, but following solution works fine:

apt-get install upstart-sysv

Now can login to gui. Have no sound (the only sound device us Dummy output), but seems it is another bug :)

Jakub Klecki (jabuk) wrote :

Hello.

I'm experiencing exactly the same problem. I have freshly installed Ubuntu 15.04 with Gnome. When I was upgrading Gnome 3.14 to 3.16 I was asked to upgrade what I believe to be the kernel (? - I'm a Linux newcomer, I'm not 100% sure what am I even doing) from 3.19.0-15 to 3.19.0-16. I installed also proprietary NVidia Drivers. Now, using the advanced options in GRUB I managed to boot 3.19.0-15. I installed upstart-sysv and rebooted my computer. Something changed, I got some flashes of Gnome and got

Ubuntu 15.04 ComputerName
ComputerName log-in

printed on my screen. Then everything disappeared and the screen remain black. I booted 3.19.0-15 again and reactivated Nouveau driver. Then I rebooted again and... everything is fine.

Conclusion - the error is related to the combination Nvidia driver - version 346.59 and 3.19.0-15 kernel version.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
dino99 (9d9) on 2015-05-13
affects: nvidia-graphics-drivers-346-updates (Ubuntu) → ubuntu
Martin Pitt (pitti) wrote :

Please report bugs with the nvidia graphics driver separately -- for the third time or so, this report *purely* concerns the cosmetical problem of printing "starting version 219" at boot, but not any graphics issues.

no longer affects: ubuntu
wateenellende (fpbeekhof) wrote :

ok, see bug 1454817 for graphics issues

Martin Pitt (pitti) on 2015-05-21
Changed in systemd (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (5.2 KiB)

This bug was fixed in the package systemd - 219-10ubuntu1

---------------
systemd (219-10ubuntu1) wily; urgency=medium

  * Merge with Debian experimental branch. Remaining Ubuntu changes:
    - Hack to support system-image read-only /etc, and modify files in
      /etc/writable/ instead.
    - Keep our much simpler udev maintainer scripts (all platforms must
      support udev, no debconf).
    - initramfs init-top: Drop $ROOTDELAY, we do that in a more sensible way
      with wait-for-root. Will get applicable to Debian once Debian gets
      wait-for-root in initramfs-tools.
    - initramfs init-bottom: If LVM is installed, settle udev,
      otherwise we get missing LV symlinks. Workaround for LP #1185394.
    - Add debian/udev.lvm2.init: Dummy SysV init script to satisfy insserv
      dependencies to "lvm2" which is handled with udev rules in Ubuntu.
    - Add debian/udev.lvm2.service to avoid running the dummy lvm2 init
      script.
    - Provide shutdown fallback for upstart. (LP: #1370329)
    - debian/extra/ifup@.service: Additionally run for "auto" class. We don't
      really support "allow-hotplug" in Ubuntu at the moment, so we need to
      deal with "auto" devices appearing after "/etc/init.d/networking start"
      already ran. (LP: #1374521) Also run ifup in the background during boot,
      to avoid blocking network.target. (LP: #1425376)
    - ifup@.service: Drop dependency on networking.service (i. e.
      /etc/init.d/networking), and merely ensure that /run/network exists.
      This avoids unnecessary dependencies/waiting during boot and dependency
      cycles if hooks wait for other interfaces to come up (like ifenslave
      with bonding interfaces). (LP: #1414544)
    - Add Get-RTC-is-in-local-time-setting-from-etc-default-rc.patch: In
      Ubuntu we currently keep the setting whether the RTC is in local or UTC
      time in /etc/default/rcS "UTC=yes|no", instead of /etc/adjtime.
      (LP: #1377258)
    - Put session scopes into all cgroup controllers. This makes unprivileged
      user LXC containers work under systemd. (LP: #1346734)
    - systemctl: Don't forward telinit u to upstart. This works around
      upstart's Restart() always reexec'ing /sbin/init on Restart(), even if
      that changes to point to systemd during the upgrade. This avoids running
      systemd during a dist-upgrade. (LP: #1430479)
    - Drop hwdb-update dependency from udev-trigger.service, which got
      introduced in v219-stable. This causes udev and plymouth to start too
      late and isn't really needed in Ubuntu yet as we don't support stateless
      systems yet and handle hwdb.bin updates through dpkg triggers. This can
      be dropped again with initramfs-tools 0.117.
    - Lower Breaks: to plymouth version which has the udev inotify fix in
      Ubuntu.
    - Lower libappamor dep to the Ubuntu version where it moved to /lib.
    - Lower apparmor Breaks: to the Ubuntu version that dropped $remote_fs.
    - Change systemd-sysv's conflicts to upstart-sysv. (LP: #1422681)
    - Make failure of boot-and-services NSpawn.test_boot non-fatal for now.
      This currently fails when being triggered by Jenkins, but is totally
     ...

Read more...

Changed in systemd (Ubuntu):
status: Fix Committed → Fix Released
Baburao (baburao-narra) wrote :

Everytime the system is booted up I get a "Starting version 219" which it seems is the version number for systemd.

I've been running 15.04 happily for a few months, and suddenly I'm hit by this bug too. Presumably the 2015-05-21 fix has been broken by a subsequent upgrade?

I can't get to a GUI by waiting, nor by resuming in Advanced Mode. I don't know if I have sddm... probably not, since the "sudo systemctl enable sddm.service -f" fix didn't work. I'll try the "upstart-sysv" fix tonight.

I've got the same problem.
the unit:
UbuntuMate 15.04
HP G62 laptop
4 Gb ram 1.5Ghz quad core
APU w/ radeon graphics
Performed updates Aug18th. doesn't boot into DE( no GUI).

I only get the text "starting version 219" on the screen. then nothing. left the room for ten minutes to make a coffee and still the same thing upon return.
so, I can still tty however that is all I can do.
I have only just tried the upstart-sysv fix however still no x session.
I've tried command line to initiate X however now the following is just some of the message.

modprobe: ERROR: could not insert 'fglrx': Function not implemented
(EE) fatal server error:(EE) no screens found(EE)

What is going on?
Whilst this has mostly broken the GUI side of the system, I'm able to get the data off the machine, reformat, reinstall and see what happens..... but I'd far rather just fix it.

Linux reliant since 2008 but still a newbie.

Matt R (matt-routley) wrote :

i had the same problem with simply a black screen and 'starting version 219'

This is how i fixed it hope it works for others...

I think the problem happened during the orginal update so i rebooted and went into my bootloader (got there by pressing f12 but for some it may be shift'), chose advanced options and loaded an earlier version of ubuntu. Then i did the usual sudo apt-get update && upgrade which fixed the problem.

A very simple fix but hopefully it will help others out

cris (cris-s1979) wrote :

it's happening to me too,
since installing Ubuntu 15.04
Everytime the system is booted up I get a "Starting version 219" which it seems is the version number for systemd.

happening on kubuntu 15.04, installed with some problems.

since it's cosmetic I wait for next upgrade...

axel (aekroft) wrote :

I ran into this bug after a successfully logged in, could be a few hours or days latter without restarting, but suddenly session stop and I can see the black screen with "starting version 219" after that login screen appears again and I can start a new session but opened programs in the previous session still are running and I need to reboot to do a clean close of the applications left open in the former session.
I'm using Ubuntu Gnome 15.04 updated to the last software update message. Is there a way to solve this?. As additional info I could said that I boot from disk drive, without a proper UEFI boot because does not work(grub error) when I install it. At the beginning I need to select the drive boot but after a while I load without that step, maybe I select it as default but I don't remember.

Michael (michael-pronath) wrote :

Having the same issue with a fresh install of Kubuntu 15.04 today.

Workaround: Ctrl+Alt+F2 , log in,
find the X process with "ps axuw | grep X ", then sudo kill it.

It's annoying to do that after every reboot, is there any permanent workaround?

with my Kubuntu 15.04 this message doesn't preclude the KDE session to start......so I don't need to kill any process.

Michael (michael-pronath) wrote :

Found out some more. When it hangs with this message "...219", the sddm.service is actually running, and an X-server is running, but no other process that sddm should start (sddm-helper, kdeinit, ...). Restarting sddm.service with systemctl doesn't help. See this:

mcp@pronath3:~$ ps axuw|grep sddm
root 1948 0.0 0.0 162660 12276 ? Ssl 10:12 0:00 /usr/bin/sddm
root 1952 0.5 0.1 150288 22748 tty7 Ssl+ 10:12 0:00 /usr/bin/X :0 -auth /var/run/sddm/:0 -nolisten tcp -background none -noreset vt7
mcp 1961 0.0 0.0 10960 2364 tty1 S+ 10:12 0:00 grep --color=auto sddm

mcp@pronath3:~$ sudo kill 1952

# now, after killing the X server, sddm restarts the X server and does everything else correctly.
# Login screen shows up, and the other processes get started:

mcp@pronath3:~$ ps axuw|grep sddm
root 1948 0.0 0.0 162764 12612 ? Ssl 10:12 0:00 /usr/bin/sddm
root 1974 1.4 0.1 312352 23004 tty7 Ssl+ 10:12 0:00 /usr/bin/X :0 -auth /var/run/sddm/:0 -nolisten tcp -background none -noreset vt7
root 1979 0.0 0.0 207484 11312 ? Sl 10:12 0:00 /usr/lib/x86_64-linux-gnu/sddm/sddm-helper --socket /tmp/sddm-auth4adac78c-54aa-464b-a4ea-e61b1d7c0713 --id 3 --start /usr/bin/sddm-greeter --socket /tmp/sddm-:0-NeRRRP --theme /usr/share/sddm/themes/breeze --user sddm --greeter
sddm 1980 0.0 0.0 42620 4480 ? Ss 10:12 0:00 /lib/systemd/systemd --user
sddm 1981 0.0 0.0 85588 2056 ? S 10:12 0:00 (sd-pam)
sddm 1984 4.9 0.6 706380 105736 ? Sl 10:12 0:00 /usr/bin/sddm-greeter --socket /tmp/sddm-:0-NeRRRP --theme /usr/share/sddm/themes/breeze
sddm 1990 0.0 0.0 24484 1888 ? S 10:12 0:00 /usr/bin/dbus-launch --autolaunch f44736d423c844fda071826d3e14927d --binary-syntax --close-stderr
sddm 1991 0.0 0.0 42256 2600 ? Ss 10:12 0:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
sddm 1993 0.3 0.1 350716 21188 ? Sl 10:12 0:00 /usr/bin/kded5
sddm 1997 0.1 0.0 149296 10120 ? Ss 10:12 0:00 kdeinit5: Running...
sddm 1998 0.1 0.1 312084 19972 ? Sl 10:12 0:00 klauncher [kdeinit5] --fd=8
mcp 2062 0.0 0.0 10960 2632 tty1 S+ 10:12 0:00 grep --color=auto sddm

Michael (michael-pronath) wrote :

found the reason ... it's about sddm autologin to a user that doesn't exist anymore. The login fails, but then sddm doesn't report an error message but simply hangs.

The condition is visible from /var/log/sddm.log
[09:42:47.765] (II) DAEMON: Display server started.
[09:42:47.785] (II) HELPER: [PAM] Starting...
[09:42:47.785] (II) HELPER: [PAM] Authenticating...
[09:42:47.795] (II) HELPER: [PAM] returning.
[09:42:47.811] (WW) HELPER: [PAM] acctMgmt: Authentication failure
[09:42:47.811] (WW) DAEMON: Authentication error: "Authentication failure"
[09:42:47.812] (II) HELPER: [PAM] Ended.
[09:42:47.815] (WW) DAEMON: Auth: sddm-helper exited with 1

Solution: disable sddm autologin or set it to a user that exists.

For sddm it would be nice if it reported the condition as an error message instead of "Starting version 219".

Kari Haapanen (karsta62) wrote :

Fix released?
Again today one of my kubuntu 15.04 installations stopped logging in and none of the workarounds work.
15.10 is almost here and this bug is still alive and kicking.

Martin Pitt (pitti) wrote :

Pretty please read the title, description, and first comments -- This report is about showing the "starting version 219" text message during early boot. This is purely cosmetical, has been silenced in 15.10, and for sure does not actually break boot, logging in, etc. These effects are much more likely to be failures of sddm, so please report bugs against that. Thanks!

Kari Haapanen (karsta62) wrote :

Correct. Sorry.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions