no plymouth confirmation for fixing file system errors

Bug #1431138 reported by Thiago Martins on 2015-03-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
systemd (Ubuntu)
Medium
Unassigned

Bug Description

Guys,

I started to use Vivid with systemd yesterday, and today, my system froze due to lack of ram memory (my problem, obviously).

I tried to "reboot" it, without success... The reboot command did not succeed. I tried to reboot by clicking on Unity menu, didn't worked either.

So, I pressed the power button to turn my machine off.

Then, the Ubuntu did not booted anymore... I know that systemd boot takes ages to boot (upstart boots in a 2 seconds) but, this time, 5 minutes passed and nothing.

I rebooted my machine again, now, using upstart (Grub -> Advanced Options -> Upstart) and guess what? The plymouth screen (I think), was asking me to "press F" to fix file system errors!

That message did not appeared when booting with systemd. Removing "quiet splash" did not helped, I saw only a black screen (when with systemd).

Definitively systemd isn't ready for prime time on Ubuntu. I'm using Jessie on another machine, systemd runs just fine there.

Regards,
Thiago

Thiago Martins (martinx) wrote :

BTW, I just upgraded my Vivid running on top of a Macbook Air, with systemd again, it booted really fast! now!

Systemd boot isn't slow anymore.

I'll try to push my system to a "out of arm" state again, to see what happens.

Thanks!

Martin Pitt (pitti) wrote :

> I know that systemd boot takes ages to boot

That's certainly not "known". If you use ecryptfs, you were most likely affected by bug 953875 which got only fixed yesterday. That would have caused a 90 second boot delay. It's likely that this was the issue (check if you have a commented out cryptswap in /etc/crypttab).

We actually do show progress on file system checks, but it seems we are missing the part for fixing errors.

summary: - [systemd] Unbootable Vivid after poweroutage + file system with errors
+ no plymouth confirmation for fixing file system errors
Changed in systemd (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
tags: added: vivid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers