systemd-journal: Failed to join audit multicast group: Operation not permitted

Bug #1411112 reported by Steve Langasek on 2015-01-15
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
systemd (Ubuntu)
Undecided
Unassigned

Bug Description

After upgrading a snappy system from 211 to 219, I'm seeing the following errors at boot:

[ 88.772405] systemd-journald[704]: Failed to join audit multicast group: Operation not permitted
[ 88.777304] systemd[1]: Started User Manager for UID 1000.
[ 88.778311] systemd[1]: systemd-journald.service: main process exited, code=exited, status=1/FAILURE
[ 88.778667] systemd[1]: Failed to start Journal Service.

I've confirmed that a rollback to 211 fixes the problem.

This makes it impossible to debug changes to snappy itself, since snappy logs to syslog which is only available via journalctl.

Steve Langasek (vorlon) wrote :

after a reinstall and upgrade to version 221, I'm not seeing this problem now.

Martin Pitt (pitti) wrote :

I just booted the current devel-proposed, and it works fine there:

$ snappy versions
Part Tag Installed Available Fingerprint Active
ubuntu-core edge 251 - 718fc709559b0b *

I also tried this with rev 219:

sudo ubuntu-device-flash --verbose --revision=219 core --output=/tmp/snappy219.img --developer-mode --channel=ubuntu-core/devel-proposed

But this still works -- "sudo journalctl" shows me the logs, and neither dmesg, nor /var/log/, nor the journal mention "multicast". What kind of snappy system did you use, if not a VM one from ubuntu-device-flash? Do you still remember if you modified anything there?

Martin Pitt (pitti) wrote :

I installed 211 with

  sudo ubuntu-device-flash --verbose --revision=211 core --output=/tmp/snappy211.img --developer-mode --channel=ubuntu-core/devel-proposed

booted it, then run "snappy update". There doesn't seem to be a parameter to specify the version, so I can't upgrade to 219; it starts to upgrade straight to 251:

$ sudo snappy versions
Part Tag Installed Available Fingerprint Active
ubuntu-core edge 211 251 441933324acfd9 *

However, "snappy update" has spun at "applying [/]" for over half an hour now. Once it finally succeeds, I'll test the behaviour on the upgraded image again.

Martin Pitt (pitti) wrote :

I'm running the complete image on tmpfs so it shoudl be lightning fast. Michael says that the upgrader has crashed, so I can't test an upgrade from 211 to 251. Does it happen to work for you? Did you still see this on current images? If so, do you get any apparmor violations or similar?

Changed in systemd (Ubuntu):
status: New → Incomplete
Martin Pitt (pitti) wrote :

I filed the upgrade hang as bug 1414009.

Steve Langasek (vorlon) wrote :

this hasn't been reproducible for me since a reinstall.

Changed in systemd (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers