hwdb.bin does not exist during live system boot

Bug #1401677 reported by Bruce Pieterse on 2014-12-11
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
systemd (Ubuntu)
Low
Martin Pitt

Bug Description

Using the current daily build of vivid for Ubuntu Gnome in Virtualbox, after the welcome screen is displayed and switching to tty1 on the live CD I see:

starting version 217
hwdb.bin does not exist, please run udevadm hwdb --update
Network interface NamePolicy= disabled on kernel commandline, ignoring.
invalid key/value pair in file /lib/udev/rules.d/97-dmraid.rules on line 8, starting at character 95 ('a')
[45.279072] systemd-logind[3430]: Failed to start user service: Unknown unit: user@999.service

Welcome to Ubuntu Vivid Vervet (development branch)
...snip...

Last week the above output was present post-installation. Currently this is not present post-installation with the current daily build.

However the system-logind error (Unknown init) persists and is currently present post-installation with slight difference of user@999 becoming user@1000.

I found this bug report which has been marked as "Fix released" but not sure if these are related or not: https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1190947.

I have a screenshot from last week which I installed a daily build image on physical hardware. Some of the errors in that screenshot are no longer present (whoopsie & basename). If you need it please let me know.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: udev 217-3ubuntu1
ProcVersionSignature: Ubuntu 3.16.0-25.33-generic 3.16.7
Uname: Linux 3.16.0-25-generic x86_64
ApportVersion: 2.14.7-0ubuntu10
Architecture: amd64
CurrentDesktop: GNOME
Date: Thu Dec 11 23:32:03 2014
InstallationDate: Installed on 2014-12-11 (0 days ago)
InstallationMedia: Ubuntu-GNOME 15.04 "Vivid Vervet" - Alpha amd64 (20141211)
Lsusb:
 Bus 001 Device 002: ID 80ee:0021 VirtualBox USB Tablet
 Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: innotek GmbH VirtualBox
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-25-generic root=UUID=c0cdf4f1-f502-41e5-8d1f-26b30d67242d ro quiet splash vt.handoff=7
SourcePackage: systemd
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 12/01/2006
dmi.bios.vendor: innotek GmbH
dmi.bios.version: VirtualBox
dmi.board.name: VirtualBox
dmi.board.vendor: Oracle Corporation
dmi.board.version: 1.2
dmi.chassis.type: 1
dmi.chassis.vendor: Oracle Corporation
dmi.modalias: dmi:bvninnotekGmbH:bvrVirtualBox:bd12/01/2006:svninnotekGmbH:pnVirtualBox:pvr1.2:rvnOracleCorporation:rnVirtualBox:rvr1.2:cvnOracleCorporation:ct1:cvr:
dmi.product.name: VirtualBox
dmi.product.version: 1.2
dmi.sys.vendor: innotek GmbH

Bruce Pieterse (octoquad) wrote :
Bruce Pieterse (octoquad) wrote :
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1401677

tags: added: iso-testing
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in systemd (Ubuntu):
status: New → Confirmed
Erick Brunzell (lbsolost) wrote :

I get the same error message during boot after upgrading Ubuntu GNOME from Utopic to Vivid, and running the suggested command makes no difference.

Martin Pitt (pitti) wrote :

Trivially reproducible on booting current live CD. I hope this will go away with http://anonscm.debian.org/cgit/pkg-systemd/systemd.git/commit/?h=ubuntu&id=9f79e0b541 , otherwise I need to debug more deeply.

Thanks for reporting!

Changed in systemd (Ubuntu):
assignee: nobody → Martin Pitt (pitti)
importance: Undecided → Low
status: Confirmed → Triaged
summary: - hwdb.bin does not exist
+ hwdb.bin does not exist during live system boot
Changed in systemd (Ubuntu):
status: Triaged → In Progress
Martin Pitt (pitti) wrote :
Changed in systemd (Ubuntu):
status: In Progress → Fix Released
tags: removed: iso-testing
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1401677

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers