[Dell Latitude 12 Rugged Extreme 7204] Microphone mute key does not work

Bug #1339998 reported by Po-Hsu Lin
22
This bug affects 1 person
Affects Status Importance Assigned to Milestone
HWE Next
Fix Released
Medium
Hui Wang
Trusty
Fix Released
Medium
Unassigned
Utopic
Fix Released
Medium
Hui Wang
OEM Priority Project
Fix Released
Undecided
Unassigned
Trusty
Fix Released
Undecided
Hui Wang
linux (Ubuntu)
Fix Released
Undecided
Unassigned
Trusty
Won't Fix
Undecided
Unassigned
systemd (Ubuntu)
Fix Released
Medium
Hui Wang
Trusty
Fix Released
Undecided
Unassigned

Bug Description

CID: 201402-14663 Dell Latitude 12 Rugged Extreme

The microphone mute key does not work on this system, so as its LED

Steps:
1. Install 14.04 + update (3.13.0-30), boot to desktop
2. Try to mute the microphone with the hotkey (fn+F4)

Expected results:
* Mic mute key should work, its LED should be lit and the "Mute" option for input device should be ticked after you press the mic mute key.

Actual result:
* Nothing happened.

Debugging information:
ubuntu@201402-14663:~$ sudo showkey -k
kb mode was ?UNKNOWN?
[ if you are trying this under X, it might not work
since the X server is also reading /dev/console ]

press any key (program terminates 10s after last keypress)...
keycode 28 release
keycode 248 press
keycode 248 release
keycode 248 press
keycode 248 release
keycode 248 press
keycode 248 release
keycode 29 press
^Ccaught signal 2, cleaning up...

xev cannot detect any microphone mute key event

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: linux-image-3.13.0-30-generic 3.13.0-30.55
ProcVersionSignature: Ubuntu 3.13.0-30.55-generic 3.13.11.2
Uname: Linux 3.13.0-30-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: ubuntu 1501 F.... pulseaudio
 /dev/snd/controlC0: ubuntu 1501 F.... pulseaudio
CRDA:
 country TW:
  (2402 - 2472 @ 40), (3, 27)
  (5270 - 5330 @ 40), (3, 17), DFS
  (5735 - 5815 @ 40), (3, 30)
CurrentDesktop: Unity
Date: Wed Jul 9 23:57:11 2014
HibernationDevice: RESUME=UUID=b68f02ad-f5e4-4eb9-b88d-e85f60666734
InstallationDate: Installed on 2014-07-10 (0 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Release amd64 (20140417)
MachineType: Dell Inc. Latitude 12 Rugged Extreme (7204)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.13.0-30-generic.efi.signed root=UUID=bdd00fe9-0df9-4b71-92c5-5f94c533f725 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 linux-restricted-modules-3.13.0-30-generic N/A
 linux-backports-modules-3.13.0-30-generic N/A
 linux-firmware 1.127.4
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 05/12/2014
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A00
dmi.board.name: 0TH1GJ
dmi.board.vendor: Dell Inc.
dmi.board.version: X02
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA00:bd05/12/2014:svnDellInc.:pnLatitude12RuggedExtreme(7204):pvr01:rvnDellInc.:rn0TH1GJ:rvrX02:cvnDellInc.:ct9:cvr:
dmi.product.name: Latitude 12 Rugged Extreme (7204)
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.

Revision history for this message
Po-Hsu Lin (cypressyew) wrote :
Revision history for this message
Brad Figg (brad-figg) wrote : Status changed to Confirmed

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Po-Hsu Lin (cypressyew)
summary: - [Dell Latitude XFR 12] Microphone mute key does not work
+ [Dell Latitude 12 Rugged Extreme] Microphone mute key does not work
description: updated
Revision history for this message
Christopher M. Peñalver (penalvch) wrote : Re: [Dell Latitude 12 Rugged Extreme] Microphone mute key does not work

Po-Hsu Lin / Anthony Wong, could you please test the latest upstream kernel available from the very top line at the top of the page (not the daily folder) following https://wiki.ubuntu.com/KernelMainlineBuilds ? It will allow additional upstream developers to examine the issue. Once you've tested the upstream kernel, please comment on which kernel version specifically you tested. If this bug is fixed in the mainline kernel, please add the following tags:
kernel-fixed-upstream
kernel-fixed-upstream-VERSION-NUMBER

where VERSION-NUMBER is the version number of the kernel you tested. For example:
kernel-fixed-upstream-3.16-rc4

This can be done by clicking on the yellow circle with a black pencil icon next to the word Tags located at the bottom of the bug description. As well, please remove the tag:
needs-upstream-testing

If the mainline kernel does not fix this bug, please add the following tags:
kernel-bug-exists-upstream
kernel-bug-exists-upstream-VERSION-NUMBER

As well, please remove the tag:
needs-upstream-testing

Once testing of the upstream kernel is complete, please mark this bug's Status as Confirmed. Please let us know your results. Thank you for your understanding.

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Incomplete
tags: added: latest-bios-a00 needs-upstream-testing
summary: - [Dell Latitude 12 Rugged Extreme] Microphone mute key does not work
+ [Dell Latitude 12 Rugged Extreme 7204] Microphone mute key does not work
Revision history for this message
Po-Hsu Lin (cypressyew) wrote :

Verified with 3.16rc5 on this system, this bug still exist
It behaves just like what I described in the bug description.

tags: added: kernel-bug-exists-upstream-3.16-rc5
removed: needs-upstream-testing
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Christopher M. Peñalver (penalvch) wrote :

Po-Hsu Lin, the issue you are reporting is an upstream one. Could you please report this problem through the appropriate channel by following the instructions _verbatim_ at https://wiki.ubuntu.com/Bugs/Upstream/kernel ?

Please provide a direct URL to your e-mail to the mailing list once you have made it so that it may be tracked.

Thank you for your understanding.

Changed in linux (Ubuntu):
status: Confirmed → Triaged
Changed in linux (Ubuntu):
assignee: Anthony Wong (anthonywong) → Hui Wang (hui.wang)
Changed in hwe-next:
assignee: nobody → Hui Wang (hui.wang)
importance: Undecided → Medium
Revision history for this message
Hui Wang (hui.wang) wrote :

Please do the test under ubuntu-14.04 as below:

generate a file named 60-dell-mic-mute-hotkey.hwdb and place the file at /etc/udev/hwdb.d/

add the content below into the 60-dell-mic-mute-hotkey.hwdb:
# Dell platform kernel driver
keyboard:name:Dell WMI hotkeys:dmi:bvn*:bvr*:bd*:svnDell*:pn*
 KEYBOARD_KEY_150=f20 # Mic mute toggle

Then run the command below to update the udev database:
sudo udevadm hwdb -u

then re-test mic mute function on this machine or use showkey -k to test

This should fix the mic mute hotkey problem, but it can't help to fix the mic mute led problem, to fix mic mute led problem, it needs kernel driver modification. Let's look at if the above fix can fix the hotkey problem or not.

Revision history for this message
Po-Hsu Lin (cypressyew) wrote :

Tweak in comment #6 works on 14.04 (3.13.0-30)

And yes, microphone mute LED still not working

Revision history for this message
Po-Hsu Lin (cypressyew) wrote :
Revision history for this message
Hui Wang (hui.wang) wrote :

Please install this alsa audio dkms, to see if it can fix the mic mute led problem or not?

Revision history for this message
Po-Hsu Lin (cypressyew) wrote :

Hello,
With the deb file provided in comment #9 installed, it made audio mute LED work.
Therefore, this bug could be solved with tweak in comment #6 and the package in comment #9
Thanks!

Revision history for this message
Martin Pitt (pitti) wrote :
affects: linux (Ubuntu) → systemd (Ubuntu)
Changed in systemd (Ubuntu):
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package systemd - 208-7ubuntu4

---------------
systemd (208-7ubuntu4) utopic; urgency=medium

  * Lower Breaks: to lvm2 again. Our lvm2 package has always used udev for
    device setup, and thus should be compatible with systemd, too.
 -- Martin Pitt <email address hidden> Thu, 07 Aug 2014 07:11:28 +0200

Changed in systemd (Ubuntu):
status: Fix Committed → Fix Released
Changed in hwe-next:
status: New → Triaged
Changed in linux (Ubuntu):
status: New → Fix Released
Changed in hwe-next:
status: Triaged → Fix Released
Revision history for this message
Martin Pitt (pitti) wrote :

Does this actually need to be fixed on the kernel side in Trusty? I'm a bit confused by the "fix released" status of linux in utopic, as far as I know most issues can be fixed in udev's keymaps alone?

Changed in linux (Ubuntu Trusty):
status: New → Incomplete
Revision history for this message
Martin Pitt (pitti) wrote :

I uploaded an SRU to the trusty review queue with the latest upstream keymaps which include the fix for this bug. Note that accepting the SRU is currently blocked on verifying the current SRU in trusty-proposed (bug 1367883).

Changed in systemd (Ubuntu Trusty):
status: New → In Progress
Revision history for this message
Hui Wang (hui.wang) wrote :

The kernel change for Trusty is to control the mute led status, It is difficult to backport the dell mute led controlling patch to trusty kernel since the driver framework has greatly changed. But fortunately we have alsa daily dkms, this fix was already in the alsa daily dkms for Trusty.

Changed in linux (Ubuntu Trusty):
status: Incomplete → Won't Fix
Revision history for this message
Chris J Arges (arges) wrote : Please test proposed package

Hello Po-Hsu, or anyone else affected,

Accepted systemd into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/systemd/204-5ubuntu20.9 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in systemd (Ubuntu Trusty):
status: In Progress → Fix Committed
tags: added: verification-needed
Revision history for this message
Shih-Yuan Lee (fourdollars) wrote :

I have verified systemd 204-5ubuntu20.9 and it does fix the problem.

tags: added: verification-done
removed: verification-needed
Revision history for this message
Scott Kitterman (kitterman) wrote : Update Released

The verification of the Stable Release Update for systemd has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package systemd - 204-5ubuntu20.9

---------------
systemd (204-5ubuntu20.9) trusty; urgency=medium

  * Pull latest keymaps from trunk, as per standing microrelease exception.
    Amongst others, this also fixes the "micmute" key on Dell Latitudes.
    (LP: #1339998)
 -- Martin Pitt <email address hidden> Wed, 12 Nov 2014 11:16:26 +0100

Changed in systemd (Ubuntu Trusty):
status: Fix Committed → Fix Released
Changed in oem-priority:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers