upgrades to 18.04 fail

Bug #1773859 reported by Kees Cook on 2018-05-29
584
This bug affects 238 people
Affects Status Importance Assigned to Milestone
systemd (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned
systemd-shim (Ubuntu)
High
Steve Langasek
Bionic
Undecided
Unassigned
Cosmic
High
Steve Langasek

Bug Description

[Impact]

 * Some systems fail to upgrade due to conflicts between systemd and the (now removed from the archive) systemd-shim / upstart.

 * Instead of trying to work out what's the problem in ordering / removal of diverts, ensure that systemd is never unpacked whilst systemd-shim/upstart are still on disk. Thus declare conflicts against systemd-shim/upstart packages in systemd package.

[Test Case]

 * monitor drop-off of upgrades with below reported problem

 * Check that it is possible to upgrade to bionic's libpam-systemd from xenial with systemd-shim installed on xenial, ie.

lxc launch ubuntu-daily:xenial test-shim-upgrade
lxc exec test-shim-upgrade
apt update
apt install systemd-shim
wget https://deb.debian.org/debian/pool/main/s/systemd-shim/systemd-shim_10-3_amd64.deb
apt install ./systemd-shim_10-3_amd64.deb
sed 's/xenial/bionic/' -i /etc/apt/sources.list
apt update
apt install systemd

this currently passes, however, systemd-shim remains installed. It should be removed instead. Apt install systemd should have lines like this:

The following packages will be REMOVED:
  systemd-shim
...
Removing 'diversion of /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service to /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service.systemd by systemd-shim'
...

[Regression Potential]

 * systemd-shim/upstart are both removed and not supported in bionic, thus forcing their removal via conflicts should bring the system into an expected state.

[Other Info]

 * original bug report

$ sudo apt upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages will be REMOVED:
  systemd-shim
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 71.7 kB disk space will be freed.
Do you want to continue? [Y/n] y
(Reading database ... 632222 files and directories currently installed.)
Removing systemd-shim (9-1bzr4ubuntu1) ...
Removing 'diversion of /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service to /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service.systemd by systemd-shim'
dpkg-divert: error: rename involves overwriting '/usr/share/dbus-1/system-services/org.freedesktop.systemd1.service' with
  different file '/usr/share/dbus-1/system-services/org.freedesktop.systemd1.service.systemd', not allowed
dpkg: error processing package systemd-shim (--remove):
 subprocess installed post-removal script returned error exit status 2
Errors were encountered while processing:
 systemd-shim
E: Sub-process /usr/bin/dpkg returned an error code (1)

Commenting out the dpkg-divert in systemd-shim's postrm solved this for me and I was about to continue the upgrade.

tags: added: xenial2bionic
Changed in systemd-shim (Ubuntu):
assignee: nobody → Steve Langasek (vorlon)
Changed in systemd-shim (Ubuntu Bionic):
milestone: none → ubuntu-18.04.1
Steve Langasek (vorlon) wrote :

The error complains that files will be overwritten, but this code runs in the systemd-shim postrm script, which is after systemd-shim's files have been removed from disk. What does 'dpkg -S /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service' report in this situation?

Changed in systemd-shim (Ubuntu):
status: New → Incomplete
importance: Undecided → High
tags: added: id-5b196b4ece6c63860998716b
Shane Synan (digitalcircuit) wrote :

I just ran into this situation myself. After I received the error report and let the upgrade recover, running the dpkg command gives me...

diversion by systemd-shim from: /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service
diversion by systemd-shim to: /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service.systemd
systemd: /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service

Shane Synan (digitalcircuit) wrote :

Apologies for the double-comment.

Following the guide from here...
https://askubuntu.com/questions/838491/systemd-shim-error-after-upgrading-from-16-04-to-16-10/838673#838673

I was able to continue upgrading with these commands:

[let upgrader bail out and run dpkg configure]
sudo mv /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service.bak
sudo apt-get install -f
sudo apt dist-upgrade
sudo apt autoremove

Then, to optionally finish cleaning up, check what packages are no longer supported using the command from...
https://askubuntu.com/questions/691051/how-to-get-the-list-of-the-unsupported-packages-mentioned-during-the-os-upgrade

awk -F\' '/demoted/ {gsub(/ /,"\n",$2); print $2}' /var/log/dist-upgrade/main.log

The system in question appears to work fine now, just the usual cleanup of changes for any major OS upgrade.

On Sun, Jun 10, 2018 at 07:38:26PM -0000, Shane Synan wrote:
> I just ran into this situation myself. After I received the error
> report and let the upgrade recover, running the dpkg command gives me...

> diversion by systemd-shim from: /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service
> diversion by systemd-shim to: /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service.systemd
> systemd: /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service

Thanks for the information. And does the file
/usr/share/dbus-1/system-services/org.freedesktop.systemd1.service exist on
your system? If so, please attach it to the bug report so we can see its
contents and try to figure out where it came from.

Steve Langasek (vorlon) wrote :

Thanks, that confirms that the file existed before the upgrade. I would still need a copy of this file to try to understand where it came from.

Kees Cook (kees) wrote :

# cat /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service
[D-BUS Service]
Name=org.freedesktop.systemd1
User=root
Exec=/usr/lib/x86_64-linux-gnu/systemd-shim

Steve Langasek (vorlon) wrote :

That certainly matches the copy of the file shipped in systemd-shim in xenial. But I'm at a loss to explain why it's present on your system after dpkg has removed the package.

Kees Cook (kees) wrote :

# dpkg -L systemd-shim
/.
/usr
/usr/lib
/usr/lib/i386-linux-gnu
/usr/lib/i386-linux-gnu/systemd-shim
/usr/lib/i386-linux-gnu/systemd-shim-cgroup-release-agent
/usr/lib/systemd
/usr/lib/systemd/ntp-units.d
/usr/lib/systemd/ntp-units.d/systemd-shim.list
/usr/share
/usr/share/dbus-1
/usr/share/dbus-1/system-services
/usr/share/dbus-1/system-services/org.freedesktop.systemd1.service
package diverts others to: /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service.systemd
/usr/share/doc
/usr/share/doc/systemd-shim
/usr/share/doc/systemd-shim/copyright
/usr/share/doc/systemd-shim/changelog.Debian.gz

# cat /var/lib/dpkg/info/systemd-shim.postrm
#!/bin/sh

set -e

if [ "$1" = remove -o "$1" = purge ]; then
        dpkg-divert --package systemd-shim --remove --rename --divert \
                /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service.systemd \
                /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service
fi

# Automatically added by dh_installdeb
dpkg-maintscript-helper rm_conffile /etc/dbus-1/system.d/org.freedesktop.systemd-shim.conf 8-4 systemd-shim -- "$@"
# End automatically added section
# Automatically added by dh_installdeb
dpkg-maintscript-helper rm_conffile /etc/dbus-1/system.d/org.freedesktop.systemd1.conf 6-2 systemd-shim -- "$@"
# End automatically added section

The error was:

Removing systemd-shim (9-1bzr4ubuntu1) ...
Removing 'diversion of /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service to /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service.systemd by systemd-shim'
dpkg-divert: error: rename involves overwriting '/usr/share/dbus-1/system-services/org.freedesktop.systemd1.service' with
  different file '/usr/share/dbus-1/system-services/org.freedesktop.systemd1.service.systemd', not allowed

I have no idea what the dpkg-divert error means there, but I assume there's some interaction I'm not following with the divert...

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in systemd (Ubuntu Bionic):
status: New → Confirmed
Changed in systemd (Ubuntu):
status: New → Confirmed
Changed in systemd-shim (Ubuntu Bionic):
status: New → Confirmed
Richard Eames (naddiseo) wrote :

I ran into this running a `do-release-upgrade -d` on a xenial machine at $work. The upgrade failed partway through leaving the system in a partial upgrade state afaict; lsb-release -a reports 18.04, but the apt sources are still xenial.

Simmo Saan (sim642) wrote :

I just ran into this during do-release-upgrade from 16.04.5 to 18.04.1 as well among other issues. The suggested mv solution worked.

I ended up in a situation where some to-be-upgraded packages like network-manager-gnome were removed at first but never reinstalled, which turned out to be problematic, although I'm not certain it was this interruption's fault that apt somehow "forgot".

udippel (udippel) wrote :

I have tried with mine: bug #1787367.
Okay, the usual update / upgrade runs through now, though what got was just the removal of the systemd-shim, and nothing else. feh and flowblade have been kept back. OpenOffice 6.0 (just as example) remains uninstalled. How can I know what else remains missing? The awk command lists a dozen of rather irrelevant stuff.

Thanks anyway for the trick to remove the systemd-shim blocker!

David Anderson (davea42) wrote :

I thought one aspect of the bug that nobody specifically highlighted was interesting:

dpkg-divert: error: rename involves overwriting '/usr/share/dbus-1/system-services/org.freedesktop.systemd1.service' with
  different file '/usr/share/dbus-1/system-services/org.freedesktop.systemd1.service.systemd', not allowed

Notice the replacement has an extra .systemd on the end of the name.

The fix instructions reported above worked for me.

A friend of mine also got this on upgrade (he's not skilled so was quite critical to him):

Whole error on further upgrades were (sorry for italian locale):

I seguenti pacchetti NUOVI saranno installati:
  libmsgpackc2 tmate
0 aggiornati, 2 installati, 1 da rimuovere e 1 non aggiornati.
1 non completamente installati o rimossi.
È necessario scaricare 0 B/259 kB di archivi.
Dopo quest'operazione, verranno occupati 652 kB di spazio su disco.
Continuare? [S/n] s
(Lettura del database... 402540 file e directory attualmente installati.)
Rimozione di systemd-shim (9-1bzr4ubuntu1)...
Rimozione di "deviazione di /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service in /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service.systemd da systemd-shim"
dpkg-divert: errore: la rinomina comprende il sovrascrivere "/usr/share/dbus-1/system-services/org.freedesktop.systemd1.service" con
   il file "/usr/share/dbus-1/system-services/org.freedesktop.systemd1.service.systemd", non consentito
dpkg: errore nell'elaborare il pacchetto systemd-shim (--remove):
 installed systemd-shim package post-removal script subprocess returned error exit status 2
Si sono verificati degli errori nell'elaborazione:
 systemd-shim
E: Sub-process /usr/bin/dpkg returned an error code (1)

Laurent Bigonville (bigon) wrote :

Just upgraded today from 16.04 to 18.04 and I got the same issue.

The systemd-shim package was still installed, the only way I had to uninstall it was to force remove systemd, then I was able to purge systemd-shim and reinstall systemd

I made sure that xenial was up2date before starting the update (using update-manager) to bionic

Dimitri John Ledkov (xnox) wrote :

systemd-shim removed from the archive, so cannot be fixed really.

Changed in systemd-shim (Ubuntu Bionic):
status: Confirmed → Won't Fix
Changed in systemd-shim (Ubuntu):
status: Incomplete → Won't Fix
Changed in systemd (Ubuntu Cosmic):
status: Confirmed → Fix Committed
Changed in systemd (Ubuntu Bionic):
status: Confirmed → In Progress
description: updated
Mark Fraser (launchpad-mfraz) wrote :

Just upgraded my server from 16.04 to 18.04 and I also came across this error.

Managed to carry on by doing /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service.bak

elowney (erik-lowney-b) wrote :

Just another "me too". Renamed the file to bak, and had a semi-working system. Also had to reinstall Nvidia driver since i was stuck at 640x480, that was fun....

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package systemd - 239-7ubuntu10

---------------
systemd (239-7ubuntu10) cosmic; urgency=medium

  * units: Disable journald Watchdog (LP: #1773148)
  * Add conflicts with upstart and systemd-shim. (LP: #1773859)

 -- Dimitri John Ledkov <email address hidden> Thu, 04 Oct 2018 15:58:51 +0100

Changed in systemd (Ubuntu Cosmic):
status: Fix Committed → Fix Released
tags: added: bugpattern-written
José Enrique (atreides1960) wrote :

Hy, in this moment I can't update my laptop or install any package or
program
Greetings

El mié., 17 oct. 2018 23:11, Brian Murray <email address hidden> escribió:

> ** Tags added: bugpattern-written
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1792241).
> https://bugs.launchpad.net/bugs/1773859
>
> Title:
> upgrades to 18.04 fail
>
> Status in systemd package in Ubuntu:
> Fix Released
> Status in systemd-shim package in Ubuntu:
> Won't Fix
> Status in systemd source package in Bionic:
> In Progress
> Status in systemd-shim source package in Bionic:
> Won't Fix
> Status in systemd source package in Cosmic:
> Fix Released
> Status in systemd-shim source package in Cosmic:
> Won't Fix
>
> Bug description:
> [Impact]
>
> * Some systems fail to upgrade due to conflicts between systemd and
> the (now removed from the archive) systemd-shim / upstart.
>
> * Instead of trying to work out what's the problem in ordering /
> removal of diverts, ensure that systemd is never unpacked whilst
> systemd-shim/upstart are still on disk. Thus declare conflicts against
> systemd-shim/upstart packages in systemd package.
>
> [Test Case]
>
> * monitor drop-off of upgrades with below reported problem
>
> * Check that it is possible to upgrade to bionic's libpam-systemd
> from xenial with systemd-shim installed on xenial.
>
> [Regression Potential]
>
> * systemd-shim/upstart are both removed and not supported in bionic,
> thus forcing their removal via conflicts should bring the system into
> an expected state.
>
> [Other Info]
>
> * original bug report
>
>
> $ sudo apt upgrade
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Calculating upgrade... Done
> The following packages will be REMOVED:
> systemd-shim
> 0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
> 1 not fully installed or removed.
> After this operation, 71.7 kB disk space will be freed.
> Do you want to continue? [Y/n] y
> (Reading database ... 632222 files and directories currently installed.)
> Removing systemd-shim (9-1bzr4ubuntu1) ...
> Removing 'diversion of
> /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service to
> /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service.systemd
> by systemd-shim'
> dpkg-divert: error: rename involves overwriting
> '/usr/share/dbus-1/system-services/org.freedesktop.systemd1.service' with
> different file
> '/usr/share/dbus-1/system-services/org.freedesktop.systemd1.service.systemd',
> not allowed
> dpkg: error processing package systemd-shim (--remove):
> subprocess installed post-removal script returned error exit status 2
> Errors were encountered while processing:
> systemd-shim
> E: Sub-process /usr/bin/dpkg returned an error code (1)
>
> Commenting out the dpkg-divert in systemd-shim's postrm solved this
> for me and I was about to continue the upgrade.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1773859/+subscriptions
>

Alejandro (vertanes) wrote :
Download full text (6.1 KiB)

Histill having the same problem  with the "systemd-shim"I don't know how to fix it May be I will format everything and reinstall Ubuntu 18 againgreetings

      From: José Enrique <email address hidden>
 To: <email address hidden>
 Sent: Thursday, October 18, 2018 3:10 AM
 Subject: Re: [Bug 1773859] Re: upgrades to 18.04 fail

Hy, in this moment I can't update my laptop or install any package or
program
Greetings

El mié., 17 oct. 2018 23:11, Brian Murray <email address hidden> escribió:

> ** Tags added: bugpattern-written
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1792241).
> https://bugs.launchpad.net/bugs/1773859
>
> Title:
>  upgrades to 18.04 fail
>
> Status in systemd package in Ubuntu:
>  Fix Released
> Status in systemd-shim package in Ubuntu:
>  Won't Fix
> Status in systemd source package in Bionic:
>  In Progress
> Status in systemd-shim source package in Bionic:
>  Won't Fix
> Status in systemd source package in Cosmic:
>  Fix Released
> Status in systemd-shim source package in Cosmic:
>  Won't Fix
>
> Bug description:
>  [Impact]
>
>    * Some systems fail to upgrade due to conflicts between systemd and
>  the (now removed from the archive) systemd-shim / upstart.
>
>    * Instead of trying to work out what's the problem in ordering /
>  removal of diverts, ensure that systemd is never unpacked whilst
>  systemd-shim/upstart are still on disk. Thus declare conflicts against
>  systemd-shim/upstart packages in systemd package.
>
>  [Test Case]
>
>    * monitor drop-off of upgrades with below reported problem
>
>    * Check that it is possible to upgrade to bionic's libpam-systemd
>  from xenial with systemd-shim installed on xenial.
>
>  [Regression Potential]
>
>    * systemd-shim/upstart are both removed and not supported in bionic,
>  thus forcing their removal via conflicts should bring the system into
>  an expected state.
>
>  [Other Info]
>
>    * original bug report
>
>
>  $ sudo apt upgrade
>  Reading package lists... Done
>  Building dependency tree
>  Reading state information... Done
>  Calculating upgrade... Done
>  The following packages will be REMOVED:
>    systemd-shim
>  0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
>  1 not fully installed or removed.
>  After this operation, 71.7 kB disk space will be freed.
>  Do you want to continue? [Y/n] y
>  (Reading database ... 632222 files and directories currently installed.)
>  Removing systemd-shim (9-1bzr4ubuntu1) ...
>  Removing 'diversion of
> /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service to
> /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service.systemd
> by systemd-shim'
>  dpkg-divert: error: rename involves overwriting
> '/usr/share/dbus-1/system-services/org.freedesktop.systemd1.service' with
>    different file
> '/usr/share/dbus-1/system-services/org.freedesktop.systemd1.service.systemd',
> not allowed
>  dpkg: error processing package systemd-shim (--remove):
>    subprocess installed post-removal script returned error exit status 2
>  Errors were encountered while processing:
>    systemd-shim
>  E: Sub-process /usr/bin/dpkg returned an erro...

Read more...

Colin Belton (colinbelton) wrote :
Download full text (9.6 KiB)

I got mine fixed with the following:

Firstly removed gdm:

sudo apt purge gdm gdm3 etc

Then installed:
sudo apt-get install --reinstall ubuntu-desktop
sudo reboot

On Mon, Oct 22, 2018 at 8:52 AM Alejandro <email address hidden>
wrote:

> Histill having the same problem with the "systemd-shim"I don't know how
> to fix it May be I will format everything and reinstall Ubuntu 18
> againgreetings
>
> From: José Enrique <email address hidden>
> To: <email address hidden>
> Sent: Thursday, October 18, 2018 3:10 AM
> Subject: Re: [Bug 1773859] Re: upgrades to 18.04 fail
>
> Hy, in this moment I can't update my laptop or install any package or
> program
> Greetings
>
> El mié., 17 oct. 2018 23:11, Brian Murray <email address hidden> escribió:
>
> > ** Tags added: bugpattern-written
> >
> > --
> > You received this bug notification because you are subscribed to a
> > duplicate bug report (1792241).
> > https://bugs.launchpad.net/bugs/1773859
> >
> > Title:
> > upgrades to 18.04 fail
> >
> > Status in systemd package in Ubuntu:
> > Fix Released
> > Status in systemd-shim package in Ubuntu:
> > Won't Fix
> > Status in systemd source package in Bionic:
> > In Progress
> > Status in systemd-shim source package in Bionic:
> > Won't Fix
> > Status in systemd source package in Cosmic:
> > Fix Released
> > Status in systemd-shim source package in Cosmic:
> > Won't Fix
> >
> > Bug description:
> > [Impact]
> >
> > * Some systems fail to upgrade due to conflicts between systemd and
> > the (now removed from the archive) systemd-shim / upstart.
> >
> > * Instead of trying to work out what's the problem in ordering /
> > removal of diverts, ensure that systemd is never unpacked whilst
> > systemd-shim/upstart are still on disk. Thus declare conflicts against
> > systemd-shim/upstart packages in systemd package.
> >
> > [Test Case]
> >
> > * monitor drop-off of upgrades with below reported problem
> >
> > * Check that it is possible to upgrade to bionic's libpam-systemd
> > from xenial with systemd-shim installed on xenial.
> >
> > [Regression Potential]
> >
> > * systemd-shim/upstart are both removed and not supported in bionic,
> > thus forcing their removal via conflicts should bring the system into
> > an expected state.
> >
> > [Other Info]
> >
> > * original bug report
> >
> >
> > $ sudo apt upgrade
> > Reading package lists... Done
> > Building dependency tree
> > Reading state information... Done
> > Calculating upgrade... Done
> > The following packages will be REMOVED:
> > systemd-shim
> > 0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
> > 1 not fully installed or removed.
> > After this operation, 71.7 kB disk space will be freed.
> > Do you want to continue? [Y/n] y
> > (Reading database ... 632222 files and directories currently installed.)
> > Removing systemd-shim (9-1bzr4ubuntu1) ...
> > Removing 'diversion of
> > /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service to
> >
> /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service.systemd
> > by systemd-shim'
> > dpkg-divert: error: rename involves overwriting
> > '/usr/share/dbus-1/sy...

Read more...

Jacob Ngalya (ngalya-2018.) wrote :

this package failed to upgrade when is upgrading to ubuntu 18.04, may you help me to resolve this issue

Colin Belton (colinbelton) wrote :

Sure, happy to try
On Thu, Oct 25, 2018 at 2:05 PM Jacob Ngalya <email address hidden>
wrote:

> this package failed to upgrade when is upgrading to ubuntu 18.04, may
> you help me to resolve this issue
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1793916).
> https://bugs.launchpad.net/bugs/1773859
>
> Title:
> upgrades to 18.04 fail
>
> Status in systemd package in Ubuntu:
> Fix Released
> Status in systemd-shim package in Ubuntu:
> Won't Fix
> Status in systemd source package in Bionic:
> In Progress
> Status in systemd-shim source package in Bionic:
> Won't Fix
> Status in systemd source package in Cosmic:
> Fix Released
> Status in systemd-shim source package in Cosmic:
> Won't Fix
>
> Bug description:
> [Impact]
>
> * Some systems fail to upgrade due to conflicts between systemd and
> the (now removed from the archive) systemd-shim / upstart.
>
> * Instead of trying to work out what's the problem in ordering /
> removal of diverts, ensure that systemd is never unpacked whilst
> systemd-shim/upstart are still on disk. Thus declare conflicts against
> systemd-shim/upstart packages in systemd package.
>
> [Test Case]
>
> * monitor drop-off of upgrades with below reported problem
>
> * Check that it is possible to upgrade to bionic's libpam-systemd
> from xenial with systemd-shim installed on xenial.
>
> [Regression Potential]
>
> * systemd-shim/upstart are both removed and not supported in bionic,
> thus forcing their removal via conflicts should bring the system into
> an expected state.
>
> [Other Info]
>
> * original bug report
>
>
> $ sudo apt upgrade
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Calculating upgrade... Done
> The following packages will be REMOVED:
> systemd-shim
> 0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
> 1 not fully installed or removed.
> After this operation, 71.7 kB disk space will be freed.
> Do you want to continue? [Y/n] y
> (Reading database ... 632222 files and directories currently installed.)
> Removing systemd-shim (9-1bzr4ubuntu1) ...
> Removing 'diversion of
> /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service to
> /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service.systemd
> by systemd-shim'
> dpkg-divert: error: rename involves overwriting
> '/usr/share/dbus-1/system-services/org.freedesktop.systemd1.service' with
> different file
> '/usr/share/dbus-1/system-services/org.freedesktop.systemd1.service.systemd',
> not allowed
> dpkg: error processing package systemd-shim (--remove):
> subprocess installed post-removal script returned error exit status 2
> Errors were encountered while processing:
> systemd-shim
> E: Sub-process /usr/bin/dpkg returned an error code (1)
>
> Commenting out the dpkg-divert in systemd-shim's postrm solved this
> for me and I was about to continue the upgrade.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1773859/+subscriptions
>

Nick Kirkendall (nrk) wrote :

Did this upgrade fail to happen because of the age of my desktop? It's a Core 2

Hello Kees, or anyone else affected,

Accepted systemd into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/systemd/237-3ubuntu10.8 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in systemd (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic
Jason M. (jason-ubuntu) wrote :

Similar experience on a DO instance. Initial do-release-upgrade failure due to bug #1793932: exim4 deprecated conffile issue. Now recovery is systemd-shim (9-1bzr4ubuntu1) blocked. @digitalcircuit's 2018-06-10 suggestion above did not work for me. Will restore 16.04 and try again later.

Details:
$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  cgmanager libcryptsetup4 rename
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  debconf debconf-i18n exim4-base exim4-daemon-heavy libapparmor-perl libgdbm-compat4 libgdbm5 libhtml-parser-perl
  liblocale-gettext-perl libmailutils5 libnet-ssleay-perl libpam-systemd libperl5.26 libreadline7 libsocket6-perl libssl1.1
  libtext-charwidth-perl libtext-iconv-perl networkd-dispatcher perl perl-base perl-modules-5.26 perl-openssl-defaults
  systemd
Suggested packages:
  debconf-doc debconf-utils libterm-readline-gnu-perl libgtk3-perl libnet-ldap-perl libqtgui4-perl libqtcore4-perl eximon4
  exim4-doc-html | exim4-doc-info spf-tools-perl swaks gdbm-l10n libdata-dump-perl perl-doc libterm-readline-gnu-perl
  | libterm-readline-perl-perl systemd-container policykit-1
The following packages will be REMOVED:
  libperl5.22 perl-modules-5.22 systemd-shim
The following NEW packages will be installed:
  libgdbm-compat4 libgdbm5 libmailutils5 libperl5.26 libreadline7 libssl1.1 networkd-dispatcher perl-modules-5.26
  perl-openssl-defaults
The following packages will be upgraded:
  debconf debconf-i18n exim4-base exim4-daemon-heavy libapparmor-perl libhtml-parser-perl liblocale-gettext-perl
  libnet-ssleay-perl libpam-systemd libsocket6-perl libtext-charwidth-perl libtext-iconv-perl perl perl-base systemd
15 upgraded, 9 newly installed, 3 to remove and 389 not upgraded.
3 not fully installed or removed.
Need to get 0 B/14.9 MB of archives.
After this operation, 3,000 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Preconfiguring packages ...
(Reading database ... 97832 files and directories currently installed.)
Removing systemd-shim (9-1bzr4ubuntu1) ...
Removing 'diversion of /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service to /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service.systemd by systemd-shim'
dpkg-divert: error: rename involves overwriting '/usr/share/dbus-1/system-services/org.freedesktop.systemd1.service' with
  different file '/usr/share/dbus-1/system-services/org.freedesktop.systemd1.service.systemd', not allowed
dpkg: error processing package systemd-shim (--remove):
 subprocess installed post-removal script returned error exit status 2
Errors were encountered while processing:
 systemd-shim

Download full text (4.5 KiB)

Thanks a lot for your help. I resolved my problem erasing systemd-shim and
updating.
I'll try new solution in another pc.
Kind regards

El lun., 19 nov. 2018 15:11, Łukasz Zemczak <email address hidden>
escribió:

> Hello Kees, or anyone else affected,
>
> Accepted systemd into bionic-proposed. The package will build now and be
> available at
> https://launchpad.net/ubuntu/+source/systemd/237-3ubuntu10.8 in a few
> hours, and then in the -proposed repository.
>
> Please help us by testing this new package. See
> https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how
> to enable and use -proposed. Your feedback will aid us getting this
> update out to other Ubuntu users.
>
> If this package fixes the bug for you, please add a comment to this bug,
> mentioning the version of the package you tested and change the tag from
> verification-needed-bionic to verification-done-bionic. If it does not
> fix the bug for you, please add a comment stating that, and change the
> tag to verification-failed-bionic. In either case, without details of
> your testing we will not be able to proceed.
>
> Further information regarding the verification process can be found at
> https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in
> advance for helping!
>
> N.B. The updated package will be released to -updates after the bug(s)
> fixed by this package have been verified and the package has been in
> -proposed for a minimum of 7 days.
>
> ** Changed in: systemd (Ubuntu Bionic)
> Status: In Progress => Fix Committed
>
> ** Tags added: verification-needed verification-needed-bionic
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1792241).
> https://bugs.launchpad.net/bugs/1773859
>
> Title:
> upgrades to 18.04 fail
>
> Status in systemd package in Ubuntu:
> Fix Released
> Status in systemd-shim package in Ubuntu:
> Won't Fix
> Status in systemd source package in Bionic:
> Fix Committed
> Status in systemd-shim source package in Bionic:
> Won't Fix
> Status in systemd source package in Cosmic:
> Fix Released
> Status in systemd-shim source package in Cosmic:
> Won't Fix
>
> Bug description:
> [Impact]
>
> * Some systems fail to upgrade due to conflicts between systemd and
> the (now removed from the archive) systemd-shim / upstart.
>
> * Instead of trying to work out what's the problem in ordering /
> removal of diverts, ensure that systemd is never unpacked whilst
> systemd-shim/upstart are still on disk. Thus declare conflicts against
> systemd-shim/upstart packages in systemd package.
>
> [Test Case]
>
> * monitor drop-off of upgrades with below reported problem
>
> * Check that it is possible to upgrade to bionic's libpam-systemd
> from xenial with systemd-shim installed on xenial.
>
> [Regression Potential]
>
> * systemd-shim/upstart are both removed and not supported in bionic,
> thus forcing their removal via conflicts should bring the system into
> an expected state.
>
> [Other Info]
>
> * original bug report
>
>
> $ sudo apt upgrade
> Reading package lists... Done
> Building dependency tree
> Reading...

Read more...

José Enrique (atreides1960) wrote :
Download full text (3.1 KiB)

I solved problem sttoping services and erasing systemd-shim upon console.
After I could updating my pc, also, from console
Kind regards

El mié., 17 oct. 2018 23:11, Brian Murray <email address hidden> escribió:

> ** Tags added: bugpattern-written
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1792241).
> https://bugs.launchpad.net/bugs/1773859
>
> Title:
> upgrades to 18.04 fail
>
> Status in systemd package in Ubuntu:
> Fix Released
> Status in systemd-shim package in Ubuntu:
> Won't Fix
> Status in systemd source package in Bionic:
> In Progress
> Status in systemd-shim source package in Bionic:
> Won't Fix
> Status in systemd source package in Cosmic:
> Fix Released
> Status in systemd-shim source package in Cosmic:
> Won't Fix
>
> Bug description:
> [Impact]
>
> * Some systems fail to upgrade due to conflicts between systemd and
> the (now removed from the archive) systemd-shim / upstart.
>
> * Instead of trying to work out what's the problem in ordering /
> removal of diverts, ensure that systemd is never unpacked whilst
> systemd-shim/upstart are still on disk. Thus declare conflicts against
> systemd-shim/upstart packages in systemd package.
>
> [Test Case]
>
> * monitor drop-off of upgrades with below reported problem
>
> * Check that it is possible to upgrade to bionic's libpam-systemd
> from xenial with systemd-shim installed on xenial.
>
> [Regression Potential]
>
> * systemd-shim/upstart are both removed and not supported in bionic,
> thus forcing their removal via conflicts should bring the system into
> an expected state.
>
> [Other Info]
>
> * original bug report
>
>
> $ sudo apt upgrade
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> Calculating upgrade... Done
> The following packages will be REMOVED:
> systemd-shim
> 0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
> 1 not fully installed or removed.
> After this operation, 71.7 kB disk space will be freed.
> Do you want to continue? [Y/n] y
> (Reading database ... 632222 files and directories currently installed.)
> Removing systemd-shim (9-1bzr4ubuntu1) ...
> Removing 'diversion of
> /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service to
> /usr/share/dbus-1/system-services/org.freedesktop.systemd1.service.systemd
> by systemd-shim'
> dpkg-divert: error: rename involves overwriting
> '/usr/share/dbus-1/system-services/org.freedesktop.systemd1.service' with
> different file
> '/usr/share/dbus-1/system-services/org.freedesktop.systemd1.service.systemd',
> not allowed
> dpkg: error processing package systemd-shim (--remove):
> subprocess installed post-removal script returned error exit status 2
> Errors were encountered while processing:
> systemd-shim
> E: Sub-process /usr/bin/dpkg returned an error code (1)
>
> Commenting out the dpkg-divert in systemd-shim's postrm solved this
> for me and I was about to continue the upgrade.
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/177385...

Read more...

description: updated
Jason M. (jason-ubuntu) wrote :

CONFIRM: @digitalcircuit's 2018-06-10 recommendation works to complete do-release-upgrade from 16.04.5 to 18.04.1, after addressing exim4 issue.

Hello Kees, or anyone else affected,

Accepted systemd into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/systemd/237-3ubuntu10.10 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Download full text (5.0 KiB)

Dear Łukasz ZemczakThank you for all your replies.Sorry I couldn't make this test in the last weeks I will make them as soon as possibleRegardsAlejandro

      From: Łukasz Zemczak <email address hidden>
 To: <email address hidden>
 Sent: Tuesday, November 20, 2018 9:21 AM
 Subject: [Bug 1773859] Please test proposed package

Hello Kees, or anyone else affected,

Accepted systemd into bionic-proposed. The package will build now and be
available at
https://launchpad.net/ubuntu/+source/systemd/237-3ubuntu10.10 in a few
hours, and then in the -proposed repository.

Please help us by testing this new package.  See
https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how
to enable and use -proposed.  Your feedback will aid us getting this
update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug,
mentioning the version of the package you tested and change the tag from
verification-needed-bionic to verification-done-bionic. If it does not
fix the bug for you, please add a comment stating that, and change the
tag to verification-failed-bionic. In either case, without details of
your testing we will not be able to proceed.

Further information regarding the verification process can be found at
https://wiki.ubuntu.com/QATeam/PerformingSRUVerification .  Thank you in
advance for helping!

N.B. The updated package will be released to -updates after the bug(s)
fixed by this package have been verified and the package has been in
-proposed for a minimum of 7 days.

--
You received this bug notification because you are subscribed to a
duplicate bug report (1796221).
https://bugs.launchpad.net/bugs/1773859

Title:
  upgrades to 18.04 fail

Status in systemd package in Ubuntu:
  Fix Released
Status in systemd-shim package in Ubuntu:
  Won't Fix
Status in systemd source package in Bionic:
  Fix Committed
Status in systemd-shim source package in Bionic:
  Won't Fix
Status in systemd source package in Cosmic:
  Fix Released
Status in systemd-shim source package in Cosmic:
  Won't Fix

Bug description:
  [Impact]

   * Some systems fail to upgrade due to conflicts between systemd and
  the (now removed from the archive) systemd-shim / upstart.

   * Instead of trying to work out what's the problem in ordering /
  removal of diverts, ensure that systemd is never unpacked whilst
  systemd-shim/upstart are still on disk. Thus declare conflicts against
  systemd-shim/upstart packages in systemd package.

  [Test Case]

   * monitor drop-off of upgrades with below reported problem

   * Check that it is possible to upgrade to bionic's libpam-systemd
  from xenial with systemd-shim installed on xenial, ie.

  lxc launch ubuntu-daily:xenial test-shim-upgrade
  lxc exec test-shim-upgrade
  apt update
  apt install systemd-shim
  wget https://deb.debian.org/debian/pool/main/s/systemd-shim/systemd-shim_10-3_amd64.deb
  apt install ./systemd-shim_10-3_amd64.deb
  sed 's/xenial/bionic/' -i /etc/apt/sources.list
  apt update
  apt install systemd

  this currently passes, however, systemd-shim remains installed. It
  should be removed instead. Apt install systemd should have lines like
  this:

  The...

Read more...

José Enrique (atreides1960) wrote :
Download full text (9.1 KiB)

Lo siento Alejandro, no soy Lucas
 Saludos

El mar., 27 nov. 2018 18:51, Alejandro <email address hidden>
escribió:

> Dear Łukasz ZemczakThank you for all your replies.Sorry I couldn't make
> this test in the last weeks I will make them as soon as
> possibleRegardsAlejandro
>
> From: Łukasz Zemczak <email address hidden>
> To: <email address hidden>
> Sent: Tuesday, November 20, 2018 9:21 AM
> Subject: [Bug 1773859] Please test proposed package
>
> Hello Kees, or anyone else affected,
>
> Accepted systemd into bionic-proposed. The package will build now and be
> available at
> https://launchpad.net/ubuntu/+source/systemd/237-3ubuntu10.10 in a few
> hours, and then in the -proposed repository.
>
> Please help us by testing this new package. See
> https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how
> to enable and use -proposed. Your feedback will aid us getting this
> update out to other Ubuntu users.
>
> If this package fixes the bug for you, please add a comment to this bug,
> mentioning the version of the package you tested and change the tag from
> verification-needed-bionic to verification-done-bionic. If it does not
> fix the bug for you, please add a comment stating that, and change the
> tag to verification-failed-bionic. In either case, without details of
> your testing we will not be able to proceed.
>
> Further information regarding the verification process can be found at
> https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in
> advance for helping!
>
> N.B. The updated package will be released to -updates after the bug(s)
> fixed by this package have been verified and the package has been in
> -proposed for a minimum of 7 days.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1796221).
> https://bugs.launchpad.net/bugs/1773859
>
> Title:
> upgrades to 18.04 fail
>
> Status in systemd package in Ubuntu:
> Fix Released
> Status in systemd-shim package in Ubuntu:
> Won't Fix
> Status in systemd source package in Bionic:
> Fix Committed
> Status in systemd-shim source package in Bionic:
> Won't Fix
> Status in systemd source package in Cosmic:
> Fix Released
> Status in systemd-shim source package in Cosmic:
> Won't Fix
>
> Bug description:
> [Impact]
>
> * Some systems fail to upgrade due to conflicts between systemd and
> the (now removed from the archive) systemd-shim / upstart.
>
> * Instead of trying to work out what's the problem in ordering /
> removal of diverts, ensure that systemd is never unpacked whilst
> systemd-shim/upstart are still on disk. Thus declare conflicts against
> systemd-shim/upstart packages in systemd package.
>
> [Test Case]
>
> * monitor drop-off of upgrades with below reported problem
>
> * Check that it is possible to upgrade to bionic's libpam-systemd
> from xenial with systemd-shim installed on xenial, ie.
>
> lxc launch ubuntu-daily:xenial test-shim-upgrade
> lxc exec test-shim-upgrade
> apt update
> apt install systemd-shim
> wget
> https://deb.debian.org/debian/pool/main/s/systemd-shim/systemd-shim_10-3_amd64.deb
> apt install ./syste...

Read more...

Alejandro (vertanes) wrote :
Download full text (13.2 KiB)

José Enrique,disculpa y gracias por contestarme.Quería pedirte si me puedes contar brevemente ¿cómo pudiste borrar el systemd-shim package?No se cómo accederloMuchas graciasAlejandro
      -
      -
         -

      -
         - -----------------
José Enrique <email address hidden>

      -
      - Nov 19 at 2:01 PM

   - To <email address hidden>
      -

Message body
Thanks a lot for your help. I resolved my problem erasing systemd-shim and
updating.
I'll try new solution in another pc.
Kind regards

      From: José Enrique <email address hidden>
 To: <email address hidden>
 Sent: Tuesday, November 27, 2018 3:01 PM
 Subject: Re: [Bug 1773859] Please test proposed package

Lo siento Alejandro, no soy Lucas
 Saludos

El mar., 27 nov. 2018 18:51, Alejandro <email address hidden>
escribió:

> Dear Łukasz ZemczakThank you for all your replies.Sorry I couldn't make
> this test in the last weeks I will make them as soon as
> possibleRegardsAlejandro
>
>      From: Łukasz Zemczak <email address hidden>
>  To: <email address hidden>
>  Sent: Tuesday, November 20, 2018 9:21 AM
>  Subject: [Bug 1773859] Please test proposed package
>
> Hello Kees, or anyone else affected,
>
> Accepted systemd into bionic-proposed. The package will build now and be
> available at
> https://launchpad.net/ubuntu/+source/systemd/237-3ubuntu10.10 in a few
> hours, and then in the -proposed repository.
>
> Please help us by testing this new package.  See
> https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how
> to enable and use -proposed.  Your feedback will aid us getting this
> update out to other Ubuntu users.
>
> If this package fixes the bug for you, please add a comment to this bug,
> mentioning the version of the package you tested and change the tag from
> verification-needed-bionic to verification-done-bionic. If it does not
> fix the bug for you, please add a comment stating that, and change the
> tag to verification-failed-bionic. In either case, without details of
> your testing we will not be able to proceed.
>
> Further information regarding the verification process can be found at
> https://wiki.ubuntu.com/QATeam/PerformingSRUVerification .  Thank you in
> advance for helping!
>
> N.B. The updated package will be released to -updates after the bug(s)
> fixed by this package have been verified and the package has been in
> -proposed for a minimum of 7 days.
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1796221).
> https://bugs.launchpad.net/bugs/1773859
>
> Title:
>  upgrades to 18.04 fail
>
> Status in systemd package in Ubuntu:
>  Fix Released
> Status in systemd-shim package in Ubuntu:
>  Won't Fix
> Status in systemd source package in Bionic:
>  Fix Committed
> Status in systemd-shim source package in Bionic:
>  Won't Fix
> Status in systemd source package in Cosmic:
>  Fix Released
> Status in systemd-shim source package in Cosmic:
>  Won't Fix
>
> Bug description:
>  [Impact]
>
>    * Some systems fail to upgrade due to conflicts between systemd and
>  the (now removed from the archive) systemd-...

b0w (kiwifunk) wrote :
Download full text (17.8 KiB)

Yo tambien tengo dudas de como resolverlo! I Still have some doubts on how
to fix it, but if in 7 days it will be available for everyone i will just
wait the update.
Greetings!

On Thu, Nov 29, 2018 at 12:31 PM Alejandro <email address hidden>
wrote:

> José Enrique,disculpa y gracias por contestarme.Quería pedirte si me
> puedes contar brevemente ¿cómo pudiste borrar el systemd-shim package?No se
> cómo accederloMuchas graciasAlejandro
> -
> -
> -
>
>
> -
> - -----------------
> José Enrique <email address hidden>
>
> -
> - Nov 19 at 2:01 PM
>
>
> - To <email address hidden>
> -
>
> Message body
> Thanks a lot for your help. I resolved my problem erasing systemd-shim and
> updating.
> I'll try new solution in another pc.
> Kind regards
>
>
> From: José Enrique <email address hidden>
> To: <email address hidden>
> Sent: Tuesday, November 27, 2018 3:01 PM
> Subject: Re: [Bug 1773859] Please test proposed package
>
> Lo siento Alejandro, no soy Lucas
> Saludos
>
> El mar., 27 nov. 2018 18:51, Alejandro <email address hidden>
> escribió:
>
> > Dear Łukasz ZemczakThank you for all your replies.Sorry I couldn't make
> > this test in the last weeks I will make them as soon as
> > possibleRegardsAlejandro
> >
> > From: Łukasz Zemczak <email address hidden>
> > To: <email address hidden>
> > Sent: Tuesday, November 20, 2018 9:21 AM
> > Subject: [Bug 1773859] Please test proposed package
> >
> > Hello Kees, or anyone else affected,
> >
> > Accepted systemd into bionic-proposed. The package will build now and be
> > available at
> > https://launchpad.net/ubuntu/+source/systemd/237-3ubuntu10.10 in a few
> > hours, and then in the -proposed repository.
> >
> > Please help us by testing this new package. See
> > https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how
> > to enable and use -proposed. Your feedback will aid us getting this
> > update out to other Ubuntu users.
> >
> > If this package fixes the bug for you, please add a comment to this bug,
> > mentioning the version of the package you tested and change the tag from
> > verification-needed-bionic to verification-done-bionic. If it does not
> > fix the bug for you, please add a comment stating that, and change the
> > tag to verification-failed-bionic. In either case, without details of
> > your testing we will not be able to proceed.
> >
> > Further information regarding the verification process can be found at
> > https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in
> > advance for helping!
> >
> > N.B. The updated package will be released to -updates after the bug(s)
> > fixed by this package have been verified and the package has been in
> > -proposed for a minimum of 7 days.
> >
> > --
> > You received this bug notification because you are subscribed to a
> > duplicate bug report (1796221).
> > https://bugs.launchpad.net/bugs/1773859
> >
> > Title:
> > upgrades to 18.04 fail
> >
> > Status in systemd package in Ubuntu:
> > Fix Released
> > Status in systemd-shim package in Ubuntu:
> > Won't Fix
> > Status in systemd source package in Bionic:...

b0w (kiwifunk) wrote :

Is there any package available that fix this thing?

José Enrique (atreides1960) wrote :
Download full text (22.7 KiB)

Hola mira esta solución.

Saludos.

El jue., 29 nov. 2018 22:51, b0w <email address hidden> escribió:

> Yo tambien tengo dudas de como resolverlo! I Still have some doubts on how
> to fix it, but if in 7 days it will be available for everyone i will just
> wait the update.
> Greetings!
>
> On Thu, Nov 29, 2018 at 12:31 PM Alejandro <email address hidden>
> wrote:
>
> > José Enrique,disculpa y gracias por contestarme.Quería pedirte si me
> > puedes contar brevemente ¿cómo pudiste borrar el systemd-shim package?No
> se
> > cómo accederloMuchas graciasAlejandro
> > -
> > -
> > -
> >
> >
> > -
> > - -----------------
> > José Enrique <email address hidden>
> >
> > -
> > - Nov 19 at 2:01 PM
> >
> >
> > - To <email address hidden>
> > -
> >
> > Message body
> > Thanks a lot for your help. I resolved my problem erasing systemd-shim
> and
> > updating.
> > I'll try new solution in another pc.
> > Kind regards
> >
> >
> > From: José Enrique <email address hidden>
> > To: <email address hidden>
> > Sent: Tuesday, November 27, 2018 3:01 PM
> > Subject: Re: [Bug 1773859] Please test proposed package
> >
> > Lo siento Alejandro, no soy Lucas
> > Saludos
> >
> > El mar., 27 nov. 2018 18:51, Alejandro <email address hidden>
> > escribió:
> >
> > > Dear Łukasz ZemczakThank you for all your replies.Sorry I couldn't make
> > > this test in the last weeks I will make them as soon as
> > > possibleRegardsAlejandro
> > >
> > > From: Łukasz Zemczak <email address hidden>
> > > To: <email address hidden>
> > > Sent: Tuesday, November 20, 2018 9:21 AM
> > > Subject: [Bug 1773859] Please test proposed package
> > >
> > > Hello Kees, or anyone else affected,
> > >
> > > Accepted systemd into bionic-proposed. The package will build now and
> be
> > > available at
> > > https://launchpad.net/ubuntu/+source/systemd/237-3ubuntu10.10 in a few
> > > hours, and then in the -proposed repository.
> > >
> > > Please help us by testing this new package. See
> > > https://wiki.ubuntu.com/Testing/EnableProposed for documentation on
> how
> > > to enable and use -proposed. Your feedback will aid us getting this
> > > update out to other Ubuntu users.
> > >
> > > If this package fixes the bug for you, please add a comment to this
> bug,
> > > mentioning the version of the package you tested and change the tag
> from
> > > verification-needed-bionic to verification-done-bionic. If it does not
> > > fix the bug for you, please add a comment stating that, and change the
> > > tag to verification-failed-bionic. In either case, without details of
> > > your testing we will not be able to proceed.
> > >
> > > Further information regarding the verification process can be found at
> > > https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you
> in
> > > advance for helping!
> > >
> > > N.B. The updated package will be released to -updates after the bug(s)
> > > fixed by this package have been verified and the package has been in
> > > -proposed for a minimum of 7 days.
> > >
> > > --
> > > You received this bug notification because you are subscribed to a
> > > d...

José Enrique (atreides1960) wrote :
Download full text (17.7 KiB)

Mira esta solucion
Saludos

El jue., 29 nov. 2018 19:31, Alejandro <email address hidden>
escribió:

> José Enrique,disculpa y gracias por contestarme.Quería pedirte si me
> puedes contar brevemente ¿cómo pudiste borrar el systemd-shim package?No se
> cómo accederloMuchas graciasAlejandro
> -
> -
> -
>
>
> -
> - -----------------
> José Enrique <email address hidden>
>
> -
> - Nov 19 at 2:01 PM
>
>
> - To <email address hidden>
> -
>
> Message body
> Thanks a lot for your help. I resolved my problem erasing systemd-shim and
> updating.
> I'll try new solution in another pc.
> Kind regards
>
>
> From: José Enrique <email address hidden>
> To: <email address hidden>
> Sent: Tuesday, November 27, 2018 3:01 PM
> Subject: Re: [Bug 1773859] Please test proposed package
>
> Lo siento Alejandro, no soy Lucas
> Saludos
>
> El mar., 27 nov. 2018 18:51, Alejandro <email address hidden>
> escribió:
>
> > Dear Łukasz ZemczakThank you for all your replies.Sorry I couldn't make
> > this test in the last weeks I will make them as soon as
> > possibleRegardsAlejandro
> >
> > From: Łukasz Zemczak <email address hidden>
> > To: <email address hidden>
> > Sent: Tuesday, November 20, 2018 9:21 AM
> > Subject: [Bug 1773859] Please test proposed package
> >
> > Hello Kees, or anyone else affected,
> >
> > Accepted systemd into bionic-proposed. The package will build now and be
> > available at
> > https://launchpad.net/ubuntu/+source/systemd/237-3ubuntu10.10 in a few
> > hours, and then in the -proposed repository.
> >
> > Please help us by testing this new package. See
> > https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how
> > to enable and use -proposed. Your feedback will aid us getting this
> > update out to other Ubuntu users.
> >
> > If this package fixes the bug for you, please add a comment to this bug,
> > mentioning the version of the package you tested and change the tag from
> > verification-needed-bionic to verification-done-bionic. If it does not
> > fix the bug for you, please add a comment stating that, and change the
> > tag to verification-failed-bionic. In either case, without details of
> > your testing we will not be able to proceed.
> >
> > Further information regarding the verification process can be found at
> > https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in
> > advance for helping!
> >
> > N.B. The updated package will be released to -updates after the bug(s)
> > fixed by this package have been verified and the package has been in
> > -proposed for a minimum of 7 days.
> >
> > --
> > You received this bug notification because you are subscribed to a
> > duplicate bug report (1796221).
> > https://bugs.launchpad.net/bugs/1773859
> >
> > Title:
> > upgrades to 18.04 fail
> >
> > Status in systemd package in Ubuntu:
> > Fix Released
> > Status in systemd-shim package in Ubuntu:
> > Won't Fix
> > Status in systemd source package in Bionic:
> > Fix Committed
> > Status in systemd-shim source package in Bionic:
> > Won't Fix
> > Status in systemd source package in Cosmic:
> > Fix Releas...

Dimitri John Ledkov (xnox) wrote :

systemd now correctly conflicts with systemd-shim, and installing both simultaniously is now even harder:

$ sudo apt install systemd-shim
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following package was automatically installed and is no longer required:
  python3-netifaces
Use 'sudo apt autoremove' to remove it.
The following additional packages will be installed:
  cgmanager cgroup-lite libcgmanager0 libnih-dbus1
Suggested packages:
  pm-utils
The following packages will be REMOVED:
  cloud-init friendly-recovery init libnss-systemd libpam-systemd netplan.io nplan plymouth plymouth-theme-ubuntu-text policykit-1 snapd
  systemd systemd-sysv ubuntu-minimal ubuntu-standard
The following NEW packages will be installed:
  cgmanager cgroup-lite libcgmanager0 libnih-dbus1 systemd-shim
WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
  init systemd-sysv (due to init)
0 upgraded, 5 newly installed, 15 to remove and 0 not upgraded.
Need to get 147 kB of archives.
After this operation, 77.6 MB disk space will be freed.
You are about to do something potentially harmful.
To continue type in the phrase 'Yes, do as I say!'
 ?] ^C
ubuntu@ubuntu:~$ dpkg-query -W systemd
systemd 237-3ubuntu10.10

Thus it should also cause removal of systemd-shim on upgrades. Marking as validation done.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
To post a comment you must log in.