shim does not implement 'Subscribe' method called by logind

Bug #1348039 reported by dino99 on 2014-07-24
28
This bug affects 6 people
Affects Status Importance Assigned to Milestone
systemd-shim (Ubuntu)
Low
Unassigned

Bug Description

Get that error logged at the end of the dmesg file. That error seems to have no sad effect on the system:

[ 30.793181] systemd-logind[1006]: Failed to enable subscription: No such method 'Subscribe'

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: systemd 208-6ubuntu2
ProcVersionSignature: Ubuntu 3.16.0-4.9-generic 3.16.0-rc5
Uname: Linux 3.16.0-4-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.14.4-0ubuntu2
Architecture: i386
CurrentDesktop: GNOME
Date: Thu Jul 24 07:25:46 2014
SourcePackage: systemd
UpgradeStatus: No upgrade log present (probably fresh install)

dino99 (9d9) wrote :
tags: added: systemd-boot
dino99 (9d9) on 2014-07-24
description: updated
Martin Pitt (pitti) wrote :

I suppose you were not actually running systemd for this, but upstart (I see this here as well). systemd-shim apparently does not implement that stub. Reassigning and dropping systemd-boot tag.

description: updated
tags: removed: systemd-boot
affects: systemd (Ubuntu) → systemd-shim (Ubuntu)
Changed in systemd-shim (Ubuntu):
importance: Undecided → Low
status: New → Triaged
summary: - systemd-logind: no such method 'subscribe'
+ shim does not implement 'Subscribe' method called by logind
dino99 (9d9) wrote :

@Martin,

its logged while booting with systemd-boot (back with it since 208)

Martin Pitt (pitti) wrote :

Your dmesg talks about plymouth-upstart-bridge, which only exists under upstart. So I'm still convinced you were running upstart here, with systemd-shim.

Martin Pitt (pitti) wrote :

I don't see this message; what do you do to trigger it? Anyway, I'll just test this with d-feet.

Martin Pitt (pitti) wrote :
Changed in systemd-shim (Ubuntu):
status: Triaged → Fix Committed
dino99 (9d9) wrote :

Thanks Martin,

got the new 7.1 into Utopic archives

    - Add stubs for Subscribe and Unsubscribe (LP: #1348039)

Changed in systemd-shim (Ubuntu):
status: Fix Committed → Fix Released
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1348039

tags: added: iso-testing
yamaplos (yama-ploskonka) wrote :

During install of
Kubuntu Utopic Unicorn Release AMD64 20141022.1
from DVD

confirm bug sighted.

Computer froze twice on "Failed to start... user@999.service

let's go for a third freeze? :-)

yamaplos (yama-ploskonka) wrote :

other details: booting with splash disabled so as to see process, on desktop with no ethernet connection (would the later make a difference? too noob to know)
dunno what else to share that would be of any help, or unusual. 4 monitors. A rather oldish processor, AMD Phenom II X4 940 3 GHz

third freeze achieved.

I wanted to have a clean install. I guess I'll go back to upgrading from 12.04

yamaplos (yama-ploskonka) wrote :

4th and 5th freeze, the later after connecting to ethernet, so that didn't help.
gpgv sez package signature DSA FBB75451

kthanxbye

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers