Backport system-tools-backends 2.10.0 to Lucid

Bug #616682 reported by Milan Bouchet-Valat on 2010-08-12
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
system-tools-backends (Ubuntu)
High
Unassigned
Lucid
High
Unassigned

Bug Description

Binary package hint: system-tools-backends

Lucid ships with system-tools-backends 2.9.4-0ubuntu1, which is an upstream development version considered as unstable, and which suffers form several serious bugs. Maverick now has 2.10.0 synced from Debian, with very limited changes (bugfixes only). It fixes bug 534154, bug 533870, bug 542183, and bug 546873.

Summary of the bugs:
Bug 534154: crash on amd64
Bug 533870: another crash on amd6' preventing from editing user's own Real name
Bug 542183: changing UID doesn't work
Bug 546873: very long delays with no feedback when applying changes

Attached is the diff between Lucid and Maverick versions.

Changelog (see bug 613362):

system-tools-backends (2.10.0-2) unstable; urgency=low

  * Break g-s-t and liboobs < 2.30 since the protocol has changed.

system-tools-backends (2.10.0-1) unstable; urgency=low

  * New upstream release.
  * debian/control.in:
    - Bump libpolkit-gobject-1-dev build-depend to 0.94.
    - Standards-Version is 3.8.4, no changes needed.
  * debian/patches/08_use_md5.patch:
    - Removed, dbus method no more returns whether to use md5 or not,
      password is now changed via PAM.
  * Switch to source format 3.0 (quilt).
    - Add debian/source/format.
    - Drop quilt from Build-Depends.
    - Remove /usr/share/cdbs/1/rules/patchsys-quilt.mk include.
 -- Christophe Sauthier (huats) <email address hidden> Mon, 12 Apr 2010 14:53:17 +0200

Milan Bouchet-Valat (nalimilan) wrote :
Changed in system-tools-backends (Ubuntu):
importance: Undecided → High
description: updated
Colin Watson (cjwatson) wrote :

I've marked the main task invalid since this is already in Maverick, but approved the Lucid task so that this bug remains open.

Changed in system-tools-backends (Ubuntu):
status: New → Invalid
Changed in system-tools-backends (Ubuntu Lucid):
importance: Undecided → High
Colin Watson (cjwatson) wrote :

Thanks for this suggestion! I think that the easiest way to move this forward (i.e. the way most likely to be accepted) would be to prepare a targeted backport of just the bug-fixes, without things like whitespace changes, translation updates (which would need to go in language packs for an Ubuntu stable release anyway), etc. I agree that 2.10.0 doesn't seem to change much beyond the bug-fixes, but a diff that's absolutely clearly "bug fixes only" would be easier to get through the stable release update process. See https://wiki.ubuntu.com/StableReleaseUpdates for details.

Are you OK with preparing this, or do you need assistance?

Changed in system-tools-backends (Ubuntu Lucid):
status: New → Confirmed
Milan Bouchet-Valat (nalimilan) wrote :

Seriously, I've moved on to other things since Lucid has been released - glad to know SRUs are considered even when they are that old, though! ;-)

The only translation change between Lucid and Maverick package is in one file and for two strings, so definitely not something to care about. If somebody wants to prepare a new package for SRU, that's cool, but given how hard it was to get somebody work on this, I don't think it will be quicker than backporting the Maverick package.

Chris Coulson (chrisccoulson) wrote :

This is basically the upstream diff, minus autotools cruft and translations, which looks much more palatable

Milan Bouchet-Valat (nalimilan) wrote :

Thanks Chris! But we really don't need to backport 2.10.1, 2.10.0 will be enough. 2.10.1 only brings in a few improvements that are used by the gnome-system-tools 2.32, which are not in Lucid. This removes most of the changes (in terms of lines of code), which makes the SRU even safer.

Martin Pitt (pitti) wrote :

Looks ok, please upload. Thanks, Milan and Chris!

Marc Deslauriers (mdeslaur) wrote :

I've prepared an SRU for lucid based on a minimal backport from 2.10.0. See the attached debdiff.

Changed in system-tools-backends (Ubuntu Lucid):
status: Confirmed → Fix Committed
Milan Bouchet-Valat (nalimilan) wrote :

Thanks for the diff!

Looks good to me, except that the change log line:
- Identify users and groups by login instead of UID (LP: #533870, LP: #542183)
is wrong: Bug 533870 is a crash on amd64 too, not a login vs. UID issue.

Marc Deslauriers (mdeslaur) wrote :

Thanks for taking a look. Unfortunately, I have already uploaded it to -proposed.
I don't think it's worth another upload just to fix the changelog.

No, I don't think it is. ;-) As long as the right number is listed...

Marc Deslauriers [2010-12-06 15:18 -0000]:
> Thanks for taking a look. Unfortunately, I have already uploaded it to -proposed.

For the record, you can just upload again with the fixed changelog
(same version number), I'll reject the previous one once I get to
reviewing the queue.

Marc Deslauriers (mdeslaur) wrote :

@Martin:

Ah! I didn't know I could do that. I just re-uploaded with a fixed changelog. Thanks!

Accepted system-tools-backends into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Martin Pitt (pitti) wrote :

Any testers of the lucid-proposed package? As this has been in -proposed for a long time already, I'll remove the proposed package soon if there is no feedback. Thank you!

Marc Deslauriers (mdeslaur) wrote :

I have successfully tested the package in -proposed. With the updated package, I was able to add and remove users, change parameters, etc.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-tools-backends - 2.9.4-0ubuntu1.1

---------------
system-tools-backends (2.9.4-0ubuntu1.1) lucid-proposed; urgency=low

  * debian/patches/03-lp616682.patch: backport fixes from 2.10.0 to fix
    various issues (LP: #616682):
    - Fix crash on authentication error (LP: #534154)
    - Fix crash due to wrong int size with SelfConfig (LP: #533870)
    - Identify users and groups by login instead of UID (LP: #542183)
    - Major performance improvements when committing groups (LP: #546873)
 -- Marc Deslauriers <email address hidden> Mon, 06 Dec 2010 09:19:18 -0500

Changed in system-tools-backends (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments