users-admin has significantly delayed response after clicking OK

Bug #546873 reported by Paddy Launch on 2010-03-25
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
system-tools-backends
Fix Released
Undecided
Unassigned
system-tools-backends (Ubuntu)
Low
Unassigned
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: gnome-system-tools

Possible duplicate of #542744 ?

Ubuntu 10.04 Beta 1.

When using the users-admin tool from gnome-system-tools, every instance of clicking on an 'OK' button causes the application to pause/freeze/delay for 10-20 seconds before completing the intended action, even if the action is not actually causing any change to data.

E.g. I click on Advanced Settings (for the current user), and then Authenticate. I click on the User Privileges tab, and then 'OK'. There is no response for several seconds before the dialog finally disappears. I then click Manage Groups, and examine the properties of any group, e.g. Audio - when I click 'OK' to close the dialog there is no response for 10-20 seconds before the dialog finally closes.

Milan Bouchet-Valat (nalimilan) wrote :

Yes, I see what you're talking about. And no, that's not a duplicate of bug 542744 (there, committing leads to an error message).

What happens is that we don't check for actual changes when you click OK, we always commit changes. Everytime groups are involved, we commit changes to all groups, which takes some time.

In the upcoming 2.10.0 version, the system-tools-backends don't apply changes when nothing has actually changed. This makes most operations must faster, especially when no changes were made at all. Plus, we no longer reload settings for each separate group commit. So I consider this fixed upstream, it should be in Lucid soon.

Changed in gnome-system-tools (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Changed in system-tools-backends:
status: New → Fix Committed
affects: gnome-system-tools (Ubuntu) → system-tools-backends (Ubuntu)
summary: - User Administration Tool has significantly delayed repsonse (with no
- feedback)
+ users-admin has significantly delayed response after clicking OK
Paddy Launch (paddylaunch) wrote :

The delay is one thing, but it's the not having any visual feedback (e.g. busy icon) that's most disconcerting, as you don't know whether or not your click has been registered, or whether or not the app has completely locked up!

Milan Bouchet-Valat (nalimilan) wrote :

Sure, but you don't need feedback when the operation takes one second instead of 20.

Milan Bouchet-Valat (nalimilan) wrote :

Fixed with 2.10.0 in Maverick (delays are much shorter). Waiting for a Lucid backport.

Changed in system-tools-backends (Ubuntu):
status: Triaged → Fix Released
Changed in system-tools-backends:
status: Fix Committed → Fix Released
Changed in system-tools-backends (Ubuntu Lucid):
status: New → Fix Committed

Accepted system-tools-backends into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Martin Pitt (pitti) wrote :

Any testers of the lucid-proposed package? As this has been in -proposed for a long time already, I'll remove the proposed package soon if there is no feedback. Thank you!

On Tue, Jan 25, 2011 at 09:23:07AM -0000, Martin Pitt wrote:
> Any testers of the lucid-proposed package? As this has been in -proposed
> for a long time already, I'll remove the proposed package soon if there
> is no feedback. Thank you!

OK, I guess as I'm the only person this bug affects, the task falls to
me ;)

I have installed the lucid-proposed update and tested it - the bug
appears to have been fixed, there is no longer any significant delay
after clicking "OK" in supervisor mode.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-tools-backends - 2.9.4-0ubuntu1.1

---------------
system-tools-backends (2.9.4-0ubuntu1.1) lucid-proposed; urgency=low

  * debian/patches/03-lp616682.patch: backport fixes from 2.10.0 to fix
    various issues (LP: #616682):
    - Fix crash on authentication error (LP: #534154)
    - Fix crash due to wrong int size with SelfConfig (LP: #533870)
    - Identify users and groups by login instead of UID (LP: #542183)
    - Major performance improvements when committing groups (LP: #546873)
 -- Marc Deslauriers <email address hidden> Mon, 06 Dec 2010 09:19:18 -0500

Changed in system-tools-backends (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers