system-tools-backends crashed with SIGSEGV in dbus_message_iter_append_basic()

Bug #534154 reported by oktubr3 on 2010-03-08
90
This bug affects 12 people
Affects Status Importance Assigned to Milestone
system-tools-backends
Fix Released
Undecided
Unassigned
system-tools-backends (Ubuntu)
High
Unassigned
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: system-tools-backends

The system is completely locked and can only restart giving the off button.

ProblemType: Crash
Architecture: amd64
Date: Sun Mar 7 23:25:04 2010
DistroRelease: Ubuntu 10.04
ExecutablePath: /usr/sbin/system-tools-backends
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100113)
Package: system-tools-backends 2.9.2-0ubuntu1
ProcCmdline: /usr/sbin/system-tools-backends
ProcEnviron:

ProcVersionSignature: Ubuntu 2.6.32-15.22-generic
SegvAnalysis:
 Segfault happened at: 0x7ffa07abae72: pcmpeqb (%rdi),%xmm2
 PC (0x7ffa07abae72) ok
 source "(%rdi)" (0x6c614d0065746160) not located in a known VMA region (needed readable region)!
 destination "%xmm2" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: system-tools-backends
StacktraceTop:
 ?? () from /lib/libc.so.6
 ?? () from /lib/libdbus-1.so.3
 ?? () from /lib/libdbus-1.so.3
 dbus_message_iter_append_basic ()
 dbus_message_new_error () from /lib/libdbus-1.so.3
Title: system-tools-backends crashed with SIGSEGV in dbus_message_iter_append_basic()
Uname: Linux 2.6.32-15-generic x86_64
UserGroups:

oktubr3 (mauroh) wrote :

StacktraceTop:
 __strlen_sse2 () at ../sysdeps/x86_64/multiarch/../strlen.S:31
 _dbus_marshal_write_basic (str=0xc0cdc8,
 _dbus_type_writer_write_basic (
 dbus_message_iter_append_basic (
 dbus_message_new_error (

Changed in system-tools-backends (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Milan Bouchet-Valat (nalimilan) wrote :

Thanks for your report. I think I've found the cause of the problem.

Could you install the following package, test it and report if that fixes the bug for you? Note it will take some time before the link below works (about 7 hours).
https://launchpad.net/~nalimilan/+archive/ppa/+files/system-tools-backends_2.9.2-0ubuntu2+ppa0gerror_amd64.deb

visibility: private → public
Changed in system-tools-backends (Ubuntu):
importance: Medium → High
status: New → Incomplete
oktubr3 (mauroh) wrote :

It worked! Thank you very much. Could you explain a little what was the problem? Sorry for my poor English.

Milan Bouchet-Valat (nalimilan) wrote :

The fix was really trivial: when writing the code, I forgot to make a variable used to return an error message as NULL before passing it to the authentication function. Since this is required for the function to fill in the error message, we were getting an invalid pointer: in case of error, we were reading invalid memory an crashing.

You can see the one-line fix here:
http://git.gnome.org/browse/system-tools-backends-clone/commit/?id=00d6fafc4ee7788e103244bc8159e82373b22b9e

This fix will be released upstream with 2.10.0, in about 10 days.

Thanks for the feedback. Please continue to test Lucid, and especially the gnome-system-tools!

Changed in system-tools-backends (Ubuntu):
status: Incomplete → Triaged
Changed in system-tools-backends:
status: New → Fix Committed
oktubr3 (mauroh) wrote :

thank you very much Milan!

That one is fixed upstream with 2.9.10, which should be in Lucid soon.

Changed in system-tools-backends:
status: Fix Committed → Fix Released

Hugh - not 2.9.10, but the system-tools-backends 2.10.0.

Changed in system-tools-backends (Ubuntu):
status: Triaged → Fix Released
Changed in system-tools-backends (Ubuntu Lucid):
status: New → Fix Committed

Accepted system-tools-backends into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Martin Pitt (pitti) wrote :

Any testers of the lucid-proposed package? As this has been in -proposed for a long time already, I'll remove the proposed package soon if there is no feedback. Thank you!

Marc Deslauriers (mdeslaur) wrote :

I have successfully tested the package in -proposed. With the updated package, I was able to add and remove users, change parameters, etc. and have not seen the crash.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package system-tools-backends - 2.9.4-0ubuntu1.1

---------------
system-tools-backends (2.9.4-0ubuntu1.1) lucid-proposed; urgency=low

  * debian/patches/03-lp616682.patch: backport fixes from 2.10.0 to fix
    various issues (LP: #616682):
    - Fix crash on authentication error (LP: #534154)
    - Fix crash due to wrong int size with SelfConfig (LP: #533870)
    - Identify users and groups by login instead of UID (LP: #542183)
    - Major performance improvements when committing groups (LP: #546873)
 -- Marc Deslauriers <email address hidden> Mon, 06 Dec 2010 09:19:18 -0500

Changed in system-tools-backends (Ubuntu Lucid):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers